none
Kaspersky Update Issues RRS feed

  • Question

  • Hi There I'm having what seems to be a current issue with the Kaspersky enginge being unable to update in Antigen for SMTP gateways version 9.2.1097 Service Pack 2 and none of the suggestions so far have helped or were applicable (mostly this is currently being reported on Forefront systems)

    Every night since June 19 I'm getting this in the event log:

    Event Type:    Error
    Event Source:    Application Error
    Event Category:    (100)
    Event ID:    1000
    Date:        6/23/2014
    Time:        1:45:48 AM
    User:        N/A
    Computer:    SV001
    Description:
    Faulting application ScanEngineTest.exe, version 9.2.1097.72, faulting module klsrlsvc.ppl, version 9.0.0.741, fault address 0x00003876.

    Followed by:

    Event Type:	Error
    Event Source:	GetEngineFiles
    Event Category:	Engine Error 
    Event ID:	6014
    Date:		6/23/2014
    Time:		1:45:49 AM
    User:		N/A
    Computer:	SV001
    Description:
    The Kaspersky scan engine test failed. hr = 0xC0000005.
    

    I just now tried removing the storage520.dat file inside the directory C:\Documents and Settings\All Users\Application Data\Kaspersky SDK and tried the update again only to get the failure reported in ProgramLog.txt file:

    Wed Jun 25 10:15:39 2014 (  844- 3884), "INFORMATION: Attempting to download the Kaspersky scan engine package from http://antigendl.microsoft.com/antigen/x86/Kaspersky."
    
    Wed Jun 25 10:17:25 2014 (  844- 3884), "INFORMATION: The Kaspersky scan engine for Antigen has been downloaded"
    
    Wed Jun 25 10:17:26 2014 ( 2700- 2720), "Disabled engines. Mails will NOT queue as engine is updated."
    
    Wed Jun 25 10:17:28 2014 ( 2692- 2716), "Disabled engines. Mails will NOT queue as engine is updated."
    
    Wed Jun 25 10:17:37 2014 (  844- 3884), "INFORMATION: The Kaspersky scan engine for Antigen has been staged."
    
    Wed Jun 25 10:17:37 2014 ( 3964- 1420), "INFORMATION: Testing the Kaspersky scan engine."
    
    Wed Jun 25 10:17:44 2014 (  844- 3884), "ERROR: The Kaspersky scan engine test failed. hr = 0xC0000005"
    
    Wed Jun 25 10:17:45 2014 (  844- 3884), "INFORMATION: The Kaspersky scan engine for Antigen has been rolled back."
    Please advise,


    Sam

    Wednesday, June 25, 2014 2:49 PM

Answers

All replies

  • Has there been an update?

    renaming the sdk folder and the engine folder does nothing.  Kaspersky still isn't updateing or working

    However, in Forefront it is updating and working.

    Thanks

    SB

    Wednesday, June 25, 2014 5:29 PM
  • Hi,

    Try this:

    http://social.technet.microsoft.com/Forums/forefront/en-US/0c16fdbe-31c2-494f-98ab-bc1c68ea5d09/kaspersky-engine-is-not-updating-successfully-on-forefrontantigen-installations-on-both-exchange?forum=forefrontSharePoint

    Wednesday, June 25, 2014 5:42 PM
  • Thanks Damian but the Program Files\Microsoft Antigen for SMTP\Engines\x86\Kaspersky\Package folder was already empty.

    It DID however populate when I attempted another update however it ended up empty again immediately after the update failed again the same way it has been for the last few days.

    That thread you pointed us to did advise some updates would be forthcoming to resolve the issue so I guess we'll just wait until then that's fine.

    Thanks for trying, anyway it's much appreciated,


    Sam

    Wednesday, June 25, 2014 6:10 PM
  • Hi,

    Please have a look on the following thread. This might help.

    Quote:

    "In fact, it seems there are two differents problems

    - Manual and Local Scheduled updates not working
    New Kaspersky update needs to have permissions on C:\Windows\temp\sdk8 for NETWORK SERVICE.
    Older Kaspersky updates didn't need them so they were not present. New update doesn't add them.
    The proper way to resolve this issue is to stop FSCController and MSExchangeTransport service, remove C:\Windows\temp\sdk8, restart FSCController and MSExchangeTransport service

    - Other (Management server ?) scheduled checks not working
    Neil's registry solution resolves this issue

    In our case, we got both issues :)
    After implementing our resolution, we still had Last check failed but not always.
    It worked fine for Local Scheduled Checks (Policy Management>Global Settings>Advanced Options, Select Engine, Edit Selected Engine).
    But it didn't work every hour at a different minute (maybe checks performed by Management server. Not sure as we are not responsible of the management server)"

    For more information:

    http://social.technet.microsoft.com/Forums/en-US/94f85be5-9c0f-46c8-bb31-ba7602285d95/kaspersky-update-issues?forum=FSENext

    Best Regards,

    Joyce


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, June 27, 2014 1:35 AM
    Moderator