locked
FFOCS Install issue on Edge Edge Server RRS feed

  • Question

  • Greetings,

    I am running OCS 2007 R2 and I am trying to install FFOCS on my new edge server. However I keep getting this error:

    "The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2892."

    I added the ForefrontRTCProxy to the appropriate groups and gave it "Logon As Service" rights and I continue to get the same error.

    Any ideas?

    Ian
    Monday, May 11, 2009 10:29 PM

Answers

  • Hello,

    One of our engineers analyzed the issue and it appears that a parsing error on proxy server configuration settings is causing the FSOCS installer to fail in some cases.

    During the FSOCS setup process, certain system level parameters are read. One of these is the ProxyServer information which is stored in the following registry key for the current user:

     

                    HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Internet Settings.

     

    Typically, this value is set in Internet Explorer through configuring Internet Options for proxy server settings.

     

    The dialog where these settings are configured can be found by opening up Internet Options and selecting the Connections tab. On that tab is a button entitled “LAN Setting” which opens up the “Local Area Network (LAN) Settings dialog where there is a section for Proxy server settings. If the “Use a proxy server for your LAN…” check box is checked, the “Advanced” button will be enabled. Clicking the “Advanced” button will bring you to the "Proxy Setting" dialog where the relevant configuration settings can be modified. 

     

    The FSOCS install process evaluates the data IE stores in the registry key for proxy setting information. If the “‘Use the same proxy server for all protocols’” check box is checked on the “Proxy Setting” dialog, a single entry is created and stored in the registry key that has the following format:

     

                    Proxy address:Port number

     

    The FSOCS installer knows how to parse this string to isolate the port number.

     

    When the “‘Use the same proxy server for all protocols’” check box is not enabled, the default is for IE store a string that concatenates a proxy address and port number for each supported protocol. The FSOCS installer does not parse this correctly.

     

    To work around the issue, you can temporarily check the “‘Use the same proxy server for all protocols’” check box and run the installer. This check box can be unchecked immediately after the FSOCS install has been run. If you are using the same proxy server for all protocols, this should not have a negative effect.

     

    Thanks,

    Molly

     

     

    Friday, May 15, 2009 10:06 PM

All replies

  • Hello Ian,

    The error code of 2892 does not map to a specific issue within the FSOCS installer. Can you submit a bug through the Microsoft Connect site in the feedback section (https://connect.microsoft.com/feedback/default.aspx?SiteID=101) so we can work with you to get additional information? As long as you are a registered user on Microsoft Connect you will have access to the Forefront feedback forms.

    Thanks,
    Molly
    Tuesday, May 12, 2009 9:22 PM
  • Molly/Ian -

    Any Luck?  I'm experiencing the same exact issue, but on a front-end server. 

    Molly - I submitted my bug via Microsoft Connect.  It's titled:  The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2892.

    Do I just wait for feedback now?

    Tuesday, May 12, 2009 10:36 PM
  • Hi,

    We responded to your Connect bug. We're evaluating the log information and will post a reply shortly.

    Thanks,
    Molly

    Thursday, May 14, 2009 1:16 PM
  • Hello,

    One of our engineers analyzed the issue and it appears that a parsing error on proxy server configuration settings is causing the FSOCS installer to fail in some cases.

    During the FSOCS setup process, certain system level parameters are read. One of these is the ProxyServer information which is stored in the following registry key for the current user:

     

                    HKEY_CURRENT_USER\ Software\Microsoft\Windows\CurrentVersion\Internet Settings.

     

    Typically, this value is set in Internet Explorer through configuring Internet Options for proxy server settings.

     

    The dialog where these settings are configured can be found by opening up Internet Options and selecting the Connections tab. On that tab is a button entitled “LAN Setting” which opens up the “Local Area Network (LAN) Settings dialog where there is a section for Proxy server settings. If the “Use a proxy server for your LAN…” check box is checked, the “Advanced” button will be enabled. Clicking the “Advanced” button will bring you to the "Proxy Setting" dialog where the relevant configuration settings can be modified. 

     

    The FSOCS install process evaluates the data IE stores in the registry key for proxy setting information. If the “‘Use the same proxy server for all protocols’” check box is checked on the “Proxy Setting” dialog, a single entry is created and stored in the registry key that has the following format:

     

                    Proxy address:Port number

     

    The FSOCS installer knows how to parse this string to isolate the port number.

     

    When the “‘Use the same proxy server for all protocols’” check box is not enabled, the default is for IE store a string that concatenates a proxy address and port number for each supported protocol. The FSOCS installer does not parse this correctly.

     

    To work around the issue, you can temporarily check the “‘Use the same proxy server for all protocols’” check box and run the installer. This check box can be unchecked immediately after the FSOCS install has been run. If you are using the same proxy server for all protocols, this should not have a negative effect.

     

    Thanks,

    Molly

     

     

    Friday, May 15, 2009 10:06 PM