Updates failing with error 0x80070002


  • Greetings,

         I am trying to deploy updates to FEP.   When forefront attempts to update itself, (or I do it with MpCmdRun.exe) It results in error: 0x80070002

    Here's a snippet from MpRunCmd.exe:

    MpCmdRun: Command Line: "c:\Program Files\Microsoft Security Client\Antimalware\MpCmdRun.exe" -SignatureUpdate"
     Start Time: ‎Thu ‎Oct ‎21 ‎2010 13:44:30

    Start: MpSignatureUpdate()
    Update started
    Search Started (UNC share) (Path: \\server\softwaredeployment$\FEP Definitions\Updates\x64)...
    Search Completed
    Update completed with hr: 0x80070002
    ERROR: Signature Update failed with hr=80070002
    MpCmdRun: End Time: ‎Thu ‎Oct ‎21 ‎2010 13:44:30


    At first, i thought it was permission issues to the share, but I changed it to a local machine, and resulted in the same error.

    Does anyone know what might be happening?



    Friday, October 22, 2010 1:10 PM

All replies

  • Hi Jason,

    Have you tried to access the share manually?

    The error translates to:

    # for hex 0x80070002 / decimal -2147024894
      COR_E_FILENOTFOUND                                             corerror.h
      DIERR_NOTFOUND                                                 dinput.h
      DIERR_OBJECTNOTFOUND                                           dinput.h
      STIERR_OBJECTNOTFOUND                                          stierr.h
    # as an HRESULT: Severity: FAILURE (1), FACILITY_WIN32 (0x7), Code 0x2
    # for hex 0x2 / decimal 2
      ERROR_FILE_NOT_FOUND                                           winerror.h
    # The system cannot find the file specified.
    # 5 matches found for "0x80070002"

    Try to access the share  \\server\softwaredeployment$\FEP Definitions\Updates\x64 and review the share/NTFS permissions. Both user and computer account need read access.


    Kurt Sarens | SR. Security Support Engineer | Microsoft EMEA CSS Security
    Tuesday, October 26, 2010 9:00 AM
  • Is it a 64bit signature?

    If so, you need to rename mpam-fex64.exe to mpam-fe.exe.

    Andrea Piazza

    Wednesday, November 24, 2010 12:18 PM