Forefront MMC Snap-in Exception


  • Hi All,

    I have a 2003 R2 SP2 Member Server that runs Forefront. Yesterday i could access the Forefront Client Security Console just fine but this morning I'm getting the following error when trying to access it;


    Exception has been thrown by the target of an invocation.

    Exception type:


    Exception stack trace:

    at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.OnThreadException(Object sender, ThreadExceptionEventArgs e)
       at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
       at System.Windows.Forms.Application.OnThreadException(Exception t)
       at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    No updates were applied to the server during this time, I've tried rebooting and have tried deleting the "MMC" folder from C:\DOCUMENTS AND SETTINGS\%USERNAME%\APPLICATION DATA\MICROSOFT but still get the error.
    Other MMC snap-ins on that server, such as WSUS and MOM are still working fine.

    Has anyone encountered this issue and managed to get it fixed?
    Any help would be most appreciated.

    Tuesday, December 02, 2008 12:08 PM

All replies

  • Hi!

    Have you clicked around in the WSUS MMC console? i've see this before and in those cases there where only a subset of the functions in WSUS console that threw this exeption.

    Check out this thread

    Any events in the eventlog? event IDs?

    MCSE, forefront spec |
    Tuesday, December 02, 2008 6:20 PM
  • Did you ever find a solution to this?  If so can you point me in the right direction? I am have the exact same error message and your post is the first one I have seen with the same issue.   I am losing what is left of my precious hair!


    Friday, March 06, 2009 9:57 PM
  • I'm having exactly the same problem.  Does anyone yet have a solution ? I've done the above and run svc /scannnow, chkdsk /f and the usual stuff, to no avail.

    If anyone could help I would really appreciate it.
    "Keep a cool head and always carry a lightbulb."
    Tuesday, April 07, 2009 2:12 PM
  • Look up M$ Hotfix KB942581.  It worked for me.
    "Keep a cool head and always carry a lightbulb."
    • Proposed as answer by cdd Monday, June 22, 2009 2:33 PM
    Tuesday, April 07, 2009 2:34 PM
  • Look up M$ Hotfix KB942581.  It worked for me.
    "Keep a cool head and always carry a lightbulb."

    I had the same problem and the KB-file from Microsoft helped me as well.
    I found it on but I had to "order" it from Micrsoftsupport who in their case mailed me a link where i could get it.
    It´s an .sql script which seems to fix this issue.

    Best regards

    Sverker Stenlund
    Wednesday, July 15, 2009 12:59 PM
  • Look up M$ Hotfix KB942581.  It worked for me.
    "Keep a cool head and always carry a lightbulb."

    This also fixed my same issue.  Thanks for posting this!!
    Monday, December 12, 2011 8:55 PM