none
Problem installing FEP Client (0x80070645)

    Question

  • Hi,

    I'm currently deploying FEP 2010 and it is working on most of my PCs just fine.

    But on one PC, FEP2010 client will not install. The error is:

    0x80070645 Cannot complete the Forefront Endpoint Protection installation. An error has prevented the Forefront Endpoint Protection setup wizard from completing successfully. Please restart your computer and try again. Error code:0x80070645. This action is only valid for products that are currently installed.

    It seems to me that epp.msi is the one triggering this error.

    What can I do to fix this?

    Thanks.

    Tuesday, January 4, 2011 11:21 PM

All replies

  • Hi,

    Have your tried to reboot that machine ?


    Bechir Gharbi | http://myitforum.com/cs2/blogs/bgharbi/
    Wednesday, January 5, 2011 8:01 AM
  • Sure. Multiple times.

    Btw, I was running FCS previously.

    Wednesday, January 5, 2011 2:31 PM
  • I think FCS didn't remove cleanly...did you remove it manually? (BTW FEP can remove the FCS client automatically as part of the default FEP install: http://technet.microsoft.com/en-us/library/ff823842.aspx)

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Wednesday, January 5, 2011 11:22 PM
  • Sure.

    Tried to remove it manually and using the FEP install. Tried to reinstall and remove as well.

    But FEP always fails with 0x80070645.

    Friday, January 7, 2011 10:16 AM
  • Hi,

    What OS version is running on the client that fails to install FEP?

    Cheers,


    Bess, Kenneth - http://www.systemcenterblog.net - http://www.systemcenterforum.net
    Monday, January 17, 2011 10:06 AM
  • Windows 7 Professional.
    Tuesday, February 1, 2011 6:28 PM
  • I've been having the same problem with several servers. I have found that uninstalling FCS can sometimes be a pain.

    If you open your REGEDIT and find the HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\UserData\S-1-5-18\Products folder and here search for ForeFront you will find the 2 installations from ForeFront.

    What I found on some machines is that it's worth trying to force an uninstall using a command prompt (Run as Administrator) and then run the UninstallSring key found in these Product listings manually but using /X instead of /I.

    If that doesn't remove it completely (For me in some cases the mp_ambits.msi was installed using an old server that was bugging out due to it forcing the installation of x86 installers on x64 machines) remove these two keys manually, then reinstall the proper verison of FCS and then see if FEP can remove it via te installer or if you still have to then uninstall the normal old fashioned way by hand or via MSIEXEC.exe /X

    Hope that helps.

    EDIT: Note that this was done on Windows 2008 / Windows 2003 Servers so it might be slightly different for Windows 7. And ofcourse create backups before removing REGkeys.

    Thursday, February 3, 2011 10:08 AM
  • Any progress on this? We have the same issue on some machines and nothign we do gets FEP installed, short of reloading the machine.
    Wednesday, March 2, 2011 6:52 PM
  • I'm also having this issue. I've tried everything listed within this thread yet the stale install of FEP still exists. How can get it cleaned up so I can install FEP 2010? This is a big issue because I need the latest FEP on my machine asap, without having to ghost the entire machine.
    Wednesday, March 30, 2011 2:23 AM
  • I was getting the same error mesasge.  My usual steps for getting FEP to install is as follows:

    1. uninstall Forefront client Security
    2. Search the Registry for any of the following words and delete all references (within reason):  'forefront', 'fcsam', 'fcssas', 'mom', 'microsoft operations manager'
    3. Install FEP

    this usually works, but not in the case of the systems that get the 0x80070645 error.  I found the following article where someone suggested deleted the keys below:

    http://answers.microsoft.com/en-us/protect/forum/protect_start/the-installation-for-the-latest-version-of-the-mse/3841366e-03a5-4eec-92bf-dd909e6e6797

    this has worked for me so far on the systems that have had this error code.  Delete the following registry keys after uninstalling FCS and before installing FEP:

           HKEY_CLASSES_ROOT\Installer\UpgradeCodes\1F69ACF0D1CF2B7418F292F0E05EC20B

           HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\1F69ACF0D1CF2B7418F292F0E05EC20B


    Brian Kirby, CISSP
    • Edited by Brian Kirby Wednesday, November 23, 2011 6:06 PM
    • Proposed as answer by Paul ORear MSFT Wednesday, December 7, 2011 11:02 PM
    Wednesday, November 23, 2011 6:05 PM
  • THANK YOU!!!

    I've been trying to solve this problem for a couple years now on an old Windows 2003 Server SP2 box to no avail until I tried this final recent suggestion. And it worked! Thank you, thank you, thank you.

    Sincerely,


    Paul O'Rear Library Experience (LEX) Microsoft Corporation http://blogs.msdn.com/TheHelpGuy
    Wednesday, December 7, 2011 11:04 PM
  • THANK YOU!!!!

    Ditto everything Paul ORear just said. Deleting the two reg keys re: UpgradeCodes worked!

     

    Yipee!

    Tuesday, December 13, 2011 8:42 PM
  • Thank you!  that did it for me.
    Friday, September 28, 2012 1:16 PM