none
TMG 2010 SP2 report 10054 An existing connection was forcibly closed by the remote host.

    Question

  • Hello,

    Our proxy server returns that error when we try to open some page on a website ( http://www.bemedical-trials.com/ )

    We can log on on this web site, then navigate but some pages are unavailable.

    After logging on the TMG server I noticed that error :

    Log type: Web Proxy (Forward)
    Status: 10054 An existing connection was forcibly closed by the remote host.
    Rule: HTTP et HTTPS
    Source: Internal (xxx)
    Destination: External (89.200.203.78:80)
    Request: GET http://www.bemedical-trials.com/OpenClinica/InitialDataEntry?eventCRFId=8&exitTo=ViewStudySubject?id=11
    Filter information: Req ID: 17e4ce28; Compression: client=No, server=No, compress rate=0% decompress rate=0%

    Our configuration :

    Server OS : Windows 2008 R2 SP1

    TMG : Forefront TMG SP2 ( 7.0.9193.540 )

    2 NIC Cards, one on the internal network, the other directly connected on internet.

    It works perfectly if we connect directly to the site without the proxy.

    Already tried :

    • In Networking -> Internal network -> Properties -> Web Browser -> I set the ip of the website
    • I created a rule to allow this particular website
    • I tried this KB: http://support.microsoft.com/kb/927263

    Thanks in advance for your help

    Thursday, January 10, 2013 8:13 AM

Answers

  • Hi Anders,

    Thanks for all the explanations.

    For the moment, I will uncheck the box "Use HTTP 1.1 through proxy connections" because it is needed for one of our surgeons.

    I will contact the owner of the site and try to explain that ;-)

    have a nice day


    Don't be nervous, stay cool !

    • Marked as answer by eljub Monday, January 14, 2013 1:18 PM
    Monday, January 14, 2013 1:18 PM

All replies

  • The error you quote means that the website has closed the connection as it is something in the request proxied by TMG that the site doesn't like. It is key here to know that TMG adheres to standards and is very strict about it. Some sites are less strict.

    Things I would start with to t-shoot this:

    - run IE dev tools (F12) on two clients, one through TMG and one direct and compare the result. Look at headers specifically.

    - If the above doesn't show anything obvious, run Netmon (or the tracing tool of your choice) on the the two clients and compare the resulting traces.

    - Run TMG Best Practices Analyzer and run TMG Data Packager on the TMG server and see in the resulting traces and logs what TMG sends and what happens.

    - Try to disable the compression filter (without any hard evidence that this would be the reason) and try again.


    Hth, Anders Janson Enfo Zipper

    Thursday, January 10, 2013 1:31 PM
  • Hi Anders,

    Thanks for your suggestions :

    - For IE in dev tools, the problem is when it does not work I have and error web page (Internet explorer cannot display this page) so I do not think that the header can help me.

    - When I try with Firefox, the error is different : Content Encoding Error : The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.

    - I ran the BPA and I did not see anything special, errors are from old things from september 2012

    - I disabled the compression filter and restarted the firewall service

    It is still not working

    I do not want to configure the workstation to connect directly to internet so I will continue to search a solution


    Don't be nervous, stay cool !




    • Edited by eljub Friday, January 11, 2013 9:32 AM
    Friday, January 11, 2013 9:18 AM
  • Here is the header when it works :


    <head><title>OpenClinica Initial Data Entry</title>
        <meta http-equiv="X-UA-Compatible" content="IE=8" />
        
        <link rel="stylesheet" href="includes/styles.css" type="text/css" media="screen">
    
        <link rel="stylesheet" href="includes/print.css" type="text/css" media="print">
        <script type="text/javascript" language="JavaScript">
            //this has been declared here so that it is accessible from other functions in the global_functions_javascript.js
            var checkboxObject;
        </script>
        <script type="text/JavaScript" language="JavaScript" src="includes/global_functions_javascript.js"></script>
        <script type="text/JavaScript" language="JavaScript" src="includes/Tabs.js"></script>
        <script type="text/JavaScript" language="JavaScript" src="includes/CalendarPopup.js"></script>
        <script type="text/javascript"  language="JavaScript" src=
          "includes/repetition-model/repetition-model.js"></script>
        <script type="text/JavaScript" language="JavaScript" src="includes/prototype.js"></script>
        <script type="text/JavaScript" language="JavaScript" src="includes/scriptaculous.js?load=effects"></script>
        <script type="text/JavaScript" language="JavaScript" src="includes/effects.js"></script>
    
        <!-- Added for the new Calender -->
    
            <link rel="stylesheet" type="text/css" media="all" href="includes/new_cal/skins/aqua/theme.css" title="Aqua" />
            <script type="text/javascript" src="includes/new_cal/calendar.js"></script>
            <script type="text/javascript" src="includes/new_cal/lang/calendar-en.js"></script>
            <script type="text/javascript" src="includes/new_cal/calendar-setup.js"></script>
        <!-- End -->
    
    </head>



    Don't be nervous, stay cool !

    Friday, January 11, 2013 10:06 AM
  • Did you run the Data Packager and look at the Netmons when reproducing the issue?

    I believe the the reason why IE says what it says is that you have "Friendly Errors" enabled (Internet Options / Advanced) and that it would be somewhat more useful if that is disabled.

    Btw, do you have any 3rd party filters installed in TMG? Websense, GFI or such?


    Hth, Anders Janson Enfo Zipper

    Monday, January 14, 2013 8:26 AM
  • Hi Anders,

    - I disabled the "Friendly Errors" but the page displayed is still the same

    - We did not use a 3rd party filter


    I ran Wireshark and is have this error when I have the proxy configured on IE

    ip-source ip_tmg_server TCP wv-csp-udp-cir > http-alt [RST, ACK] Seq=711 Ack=8777 Win=0 Len=0


    I ran Netmon and here is the last frame

    - Tcp: Flags=...A.R.., SrcPort=1152, DstPort=HTTP Alternate(8080), PayloadLen=0, Seq=654499415, Ack=4008658942, Win=0 (scale factor 0x0) = 0
        SrcPort: 1152
        DstPort: HTTP Alternate(8080)
        SequenceNumber: 654499415 (0x2702DE57)
        AcknowledgementNumber: 4008658942 (0xEEEF47FE)
      - DataOffset: 80 (0x50)
         DataOffset: (0101....) 20 bytes
         Reserved:   (....000.)
         NS:         (.......0) Nonce Sum not significant
      - Flags: ...A.R..
         CWR:    (0.......) CWR not significant
         ECE:    (.0......) ECN-Echo not significant
         Urgent: (..0.....) Not Urgent Data
         Ack:    (...1....) Acknowledgement field significant
         Push:   (....0...) No Push Function
         Reset:  (.....1..) Reset
         Syn:    (......0.) Not Synchronize sequence numbers
         Fin:    (.......0) Not End of data
        Window: 0 (scale factor 0x0) = 0
        Checksum: 0x4BEA, Disregarded
        UrgentPointer: 0 (0x0)

    I suspect and error between IE and TM because if I interpret correctly IE sent a reset to TMG

    Again thanks for your help


    Don't be nervous, stay cool !


    • Edited by eljub Monday, January 14, 2013 10:03 AM
    Monday, January 14, 2013 9:53 AM
  • I found something !

    When I disable this settings on IE :

    Use HTTP 1.1 through proxy connections

    It works !


    Don't be nervous, stay cool !

    Monday, January 14, 2013 10:34 AM
  • That tells us that the remote site does not support HTTP/1.1 through proxy where the main 'features' are to use keep-alives for the connections and compression.

    Fror details, please see http://technet.microsoft.com/en-us/library/cc995175.aspx


    Hth, Anders Janson Enfo Zipper

    Monday, January 14, 2013 12:33 PM
  • Hi Anders,

    Thanks for all the explanations.

    For the moment, I will uncheck the box "Use HTTP 1.1 through proxy connections" because it is needed for one of our surgeons.

    I will contact the owner of the site and try to explain that ;-)

    have a nice day


    Don't be nervous, stay cool !

    • Marked as answer by eljub Monday, January 14, 2013 1:18 PM
    Monday, January 14, 2013 1:18 PM