none
Proxy Server Loop Event ID 14141 RRS feed

  • Question

  • Hello,

    I have 3 ISA 2006 Enterprise array member servers, one a hardware server and two virtual boxes, both are on Windows 2003 R2 and ISA SP1. All are configured the same way and are fully patched. One member is getting event ID 14141 Proxy Server Loop. I can't find anything recent on this or anything helpful in resolving the issue. If I reboot the box it goes away for about 8 hours or so.

    Thank you,
    Monday, January 25, 2010 9:27 PM

Answers

  • Hi,

     

    Thank you for the update.

     

    Please try the following steps to see if we can resolve this issue:

     

    1.      If there is no virus found, you may open regedit program and navigate to the following registry:

    HKLM\Software\Microsoft\fpc\Arrays\{GUID}\ArrayPol icy\WebProxy\
    Locate the value FPCDnsCacheTTL and change the value date to 0. Reboot the server and then check the event log. Will the problem be resolved?

    2.      Please make sure the DNS configuration is set as following

    External NIC:
    IP: assigned by your ISP or your hardware router
    Gateway: your ISP or your Hardware router IP
    DNS: INTERNAL NIC IP as the only entry

    Internal NIC:
    IP: Fixed IP
    Gateway: None
    DNS: INTERNAL NIC IP as the only entry

    In the DNS console (dnsmgmt.msc), right click your ServerName and click properties. In the Forwarders tab, your ISP DNS server IP should be inputted there.

     

    3. Please open the DNS tab of the external NIC TCP/IP properties page and make sure "Register this connection's address in DNS" is unchecked

     

    Regards,


    Nick Gu - MSFT
    Tuesday, February 2, 2010 1:44 AM
    Moderator
  • Nick, thank you for your reply. I found the problem. This is a virtual server and it had an extra NIC configured for DHCP and so the ISA server was seeing 2 gateways configured. Even though they were the same gateway the ISA configuration did not like it. After disabling the extra NIC all is well. Thank you for your time and attention and I'm very sorry to have wasted your time.

    Rick
    • Marked as answer by Rickmart61 Thursday, February 4, 2010 8:30 PM
    Thursday, February 4, 2010 8:30 PM

All replies

  • Hi,

     

    Thank you for the post.


    I did some research regarding this error message and found it may be caused by different causes:

     

    1. Network routing and ISA configuration issue. For example, as web proxy server, ISA forwarded client request to another device, but that device returned such request back to ISA. Thus caused “proxy loop” issue. Please check network routing and ISA configuration, especially Intern network range. Make sure ISA internal network range is consistent with network routing. When configuring ISA Internal network, we may click “Add Adapter” to import the routing table, instead of configuring it manually.

     

    2. We have experience that some 3rd party antivirus or firewall applications on ISA server caused similar error. Do you have such application running on ISA server? If any, as test please uninstall them to check if issue can be resolve.

     

    3. Other issues, as “Traffic Is in a Proxy Chain Loop” in

    http://technet.microsoft.com/en-us/library/cc302564.aspx

     

    If the alert is just happening randomly and client access to internet is not impacted, you may ignore it safely.

     

    Regards,


    Nick Gu - MSFT
    Thursday, January 28, 2010 7:53 AM
    Moderator
  • Hello, thank you for your response. I've checked all routing and network ranges for the internal network and everything seems to be configured correctly. I have three servers all configured the exact same way and yet this is the only one of the three recieving these errors. Only connections to the virtual IP address that are serviced by this server are affected. Anything else you could suggest would be great!

    Rick

    Thursday, January 28, 2010 7:46 PM
  • Hi,

     

    Thank you for the update.

     

    Please try the following steps to see if we can resolve this issue:

     

    1.      If there is no virus found, you may open regedit program and navigate to the following registry:

    HKLM\Software\Microsoft\fpc\Arrays\{GUID}\ArrayPol icy\WebProxy\
    Locate the value FPCDnsCacheTTL and change the value date to 0. Reboot the server and then check the event log. Will the problem be resolved?

    2.      Please make sure the DNS configuration is set as following

    External NIC:
    IP: assigned by your ISP or your hardware router
    Gateway: your ISP or your Hardware router IP
    DNS: INTERNAL NIC IP as the only entry

    Internal NIC:
    IP: Fixed IP
    Gateway: None
    DNS: INTERNAL NIC IP as the only entry

    In the DNS console (dnsmgmt.msc), right click your ServerName and click properties. In the Forwarders tab, your ISP DNS server IP should be inputted there.

     

    3. Please open the DNS tab of the external NIC TCP/IP properties page and make sure "Register this connection's address in DNS" is unchecked

     

    Regards,


    Nick Gu - MSFT
    Tuesday, February 2, 2010 1:44 AM
    Moderator
  • Nick, thank you for your reply. I found the problem. This is a virtual server and it had an extra NIC configured for DHCP and so the ISA server was seeing 2 gateways configured. Even though they were the same gateway the ISA configuration did not like it. After disabling the extra NIC all is well. Thank you for your time and attention and I'm very sorry to have wasted your time.

    Rick
    • Marked as answer by Rickmart61 Thursday, February 4, 2010 8:30 PM
    Thursday, February 4, 2010 8:30 PM