none
Internet Explorer 9 breaks Forefront TMG Management Tools

    Question

  • Hello

    We use here TMG Management tools to administrate a TMG array remotely, and after installing IE9 (RTM), these tools give all kinds of error messages like 'member not found', 'refresh failed' and so on. Is there a (hot)fix for this?

    Thanks in advance,


    Jeroen.

    • Edited by Jeroen Landheer Thursday, March 17, 2011 7:17 PM Added the IE9 version
    Thursday, March 17, 2011 7:16 PM

Answers

  • * Open "C:\Program Files\Microsoft Forefront Threat Management Gateway\UI_HTMLs\TabsHandler\TabsHandler.htc"
    * Search for the 3 lines which contain "paddingTop", and remark-out each of them by adding "//" in the begining.
    Example: Change the line:
    m_aPages [niPage].m_tdMain.style.paddingTop = ((m_nBoostUp < 0) ? -m_nBoostUp : 0) ;
    into:
    // m_aPages [niPage].m_tdMain.style.paddingTop = ((m_nBoostUp < 0) ? -m_nBoostUp : 0) ;
    * Save the file, and re-open TMG management console.

    Tuesday, April 12, 2011 11:26 AM

All replies

  • Hi,

     

    Thank you for the post.

     

    Do you confirm that this issue is only occur for IE9? If running IE8, do you have any error message?

     

    Regards,


    Nick Gu - MSFT
    Saturday, March 19, 2011 1:59 AM
    Moderator
  • what is TMG Management tools  ??
    Tarek Majdalani | MS Forefront Edge Security MVP | http://www.elmajdal.net
    Saturday, March 19, 2011 2:15 PM
    Moderator
  • Hi,

    I have exactly the same problem with IE9 on Win7 64.

    When I uninstall IE9 and go back to IE8, the problem is solved.

    Regards,

    Lionel

     

    Monday, March 21, 2011 9:57 AM
  • same problem here !

    Henning

    Monday, March 21, 2011 12:52 PM
  • same also ...

    Monday, March 21, 2011 1:22 PM
  • so it is here - i can reproduce the error in my vms!

    :-(


    gruss, jens mander aka karsten hentrup - www.aixperts.de - www.forefront-tmg.de - www.hentrup.net |<-|
    Monday, March 21, 2011 1:25 PM
  • Same problem here!
    Tuesday, March 22, 2011 2:05 PM
  • Russian sector too supports, when decisions to wait?

    http://social.technet.microsoft.com/Forums/ru-RU/isaru/thread/15753843-1774-4c77-bc83-0d04a37d1817

    Wednesday, March 23, 2011 12:31 PM
  • These are the standard management tools for Microsoft Forefront Thread Management Gateway, or in other words, the MMC Snapin which is part of TMG
    Wednesday, March 23, 2011 8:36 PM
  • Yes, once I uninstall IE9 and go back to IE8, the problem is resolved.

    Try it yourself. Just install the TMG management tools on a computer, install IE9 and it won't work. Uninstall IE9 and everything works fine. I think it has to do with the JScript which is part of the right pane in the MMC snapin, because the error messages look like JScript error messages.

    Wednesday, March 23, 2011 8:41 PM
  • From memory, parts of the console use HTML files..an example here: http://technet.microsoft.com/en-us/library/cc891502.aspx

    Guess IE9 broke these HTML elements???

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Thursday, March 24, 2011 12:15 AM
    Moderator
  • Same problem here on the 2 management workstations.
    Dario Palermo
    Thursday, March 24, 2011 3:04 PM
  • It not in a script the error, an error in too strong protection IE9 which even to disconnect is impossible (even if safety level everywhere low to make (in all zones). I do not understand, already have passed more weeks, and the problem decision still is not present... microsooooft :)
    Monday, March 28, 2011 9:23 PM
  • Same Problem here !
    Thursday, March 31, 2011 8:38 AM
  • Same Problem here !

    I have the same problem too!
    Thursday, March 31, 2011 1:47 PM
  • I also confirm this behavior since early betas of IE9, and still present with latest IE version.

    Forefront TMG Management MMC will not work properly unless IE9 is uninstalled.

    Friday, April 1, 2011 6:14 PM
  • Hi there,

     

    As we need more information to investigate the issue. Would you please help to find out the following details?

     

    What type of Client they use:

    OS: Win7 32\64, with SP1?

    TMG Management build:  RTM\SP1\UP1?

     

    Server :

    OS : 2008sp2 \ 2008R2 ?

    Standalone/Standalone Array/EMS?

    TMG build :  RTM\SP1\UP1 ?

     

    User:

    Domain\WG

    Role : Administrator \Auditor\Monitoring ?

     

    Regards,


    Nick Gu - MSFT
    Sunday, April 3, 2011 10:09 AM
    Moderator
  • Client:

    Win7 SP1 x64

    TMG 2010 With SP1 & SU1      7.0.9027.400

     

    Server:

    2008R2

    Standalone

    TMG 2010 With SP1 & SU1       7.0.9027.400

     

    User:

    Domain

    Administrator

     

    I will try to update to Rollup3 today.

    Thank you for your support.


    Dario Palermo
    Sunday, April 3, 2011 10:19 AM
  • Update Rollup3 dind't solve the problem (not that was supposed to, anyway...)

     

    Best regards


    Dario Palermo
    Sunday, April 3, 2011 10:36 AM
  • Client: Windows 7 Enterprise SP1 x64 / TMG 2010 SP1 & SU1 

     

    Server: Windows 2008 R2 SP1 in the domain / TMG 2010 SP1 & SU1

     

    User: Domain / Administrator

    Sunday, April 3, 2011 5:34 PM
  • Hi All,

    Microsoft are aware of the problem and are currently investigating...

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Monday, April 4, 2011 8:44 AM
    Moderator
  • Hi there,

     

    Thank you for the update.

     

    Our engineer is investigating the issue, however we got no repro after several tests. We may need your help to get a repro in our lab.

     

    Jens.Mander – “so it is here - i can reproduce the error in my vms!” – hi jens, would you please help us to get the export of your virtual machine? For your convenience, I have created a workspace for you.  You can upload the information files to the following link.  (Please choose "Send Files to Microsoft")

     

    Workspace URL:  (https://sftasia.one.microsoft.com/choosetransfer.aspx?key=86fea7d2-6ab0-4f30-8e52-ea6d6c79b8da)

     

    Password: L{GXQ3mB#xwi

    Note: Due to differences in text formatting with various email clients, the workspace link above may appear to be broken.  Please be sure to include all text between '(' and ')' when typing or copying the workspace link into your browser.

     

    Regards,


    Nick Gu - MSFT
    Tuesday, April 5, 2011 2:31 AM
    Moderator
  • hi nick,

    no problem - i got several large network-layouts with tmg/uag here in my office. will the tmg-vm be enough (hyper-v-vm)? you can contact me via pm if you like to discuss what you need in detail. my email is jemand@forefront-tmg.de.

    Greets!


    gruss, jens mander aka karsten hentrup - www.aixperts.de - www.forefront-tmg.de - www.hentrup.net |<-|
    Tuesday, April 5, 2011 4:19 PM
  • Server:

    OS: W2K8R2SP1 + IE9 Patchlvl up 2 date - Domainmember

    TMG: 7.0.9027.441

    Language: German

    User: Domain-Admin


    gruss, jens mander aka karsten hentrup - www.aixperts.de - www.forefront-tmg.de - www.hentrup.net |<-|
    Tuesday, April 5, 2011 4:46 PM
  • hi nick,

    now zipping the vms (1dc + 1tmg) - 40gb. this will take a while to upload!

    ;-(


    gruss, jens mander aka karsten hentrup - www.aixperts.de - www.forefront-tmg.de - www.hentrup.net |<-|
    Tuesday, April 5, 2011 4:51 PM
  • My setup here:

    * Client
    SO: Win7 Enterprise x64 SP1
    TMG Management: 7.0.9027.400
    IE: 9.0.8112.16421

    * Server
    OS: 2008R2 Standard SP1
    TMG: 7.0.9027.410 - Standalone server
    IE: 8.0.7601.17514

    * User
    Domain user
    Role: TMG Admin

    Tuesday, April 5, 2011 4:59 PM
  • hi nick,

    i zipped 40gb of vms and splitted them in 2gb chunks. now trying to uplaod these files to your webserver is really annoying! qos is to low, only got 80kb/sec.

    if you are still interested in my vms, than provide me plz. with a high-bandwith-ftp-server with resuming-ability!


    gruss, jens mander aka karsten hentrup - www.aixperts.de - www.forefront-tmg.de - www.hentrup.net |<-|
    Thursday, April 7, 2011 6:40 PM
  • * Open "C:\Program Files\Microsoft Forefront Threat Management Gateway\UI_HTMLs\TabsHandler\TabsHandler.htc"
    * Search for the 3 lines which contain "paddingTop", and remark-out each of them by adding "//" in the begining.
    Example: Change the line:
    m_aPages [niPage].m_tdMain.style.paddingTop = ((m_nBoostUp < 0) ? -m_nBoostUp : 0) ;
    into:
    // m_aPages [niPage].m_tdMain.style.paddingTop = ((m_nBoostUp < 0) ? -m_nBoostUp : 0) ;
    * Save the file, and re-open TMG management console.

    Tuesday, April 12, 2011 11:26 AM
  • Nice work, Evgeniya. It solved the problem.

    Thanks!

    Best regards,


    Dario Palermo
    Tuesday, April 12, 2011 11:31 AM
  • Mine too :).

    Thanks!

    Tuesday, April 12, 2011 11:47 AM
  • Thanks, it works for me too !

    Tuesday, April 12, 2011 1:33 PM
  • One word: Awsome!

    Problem solved, thank you very much :)

    Tuesday, April 12, 2011 1:41 PM
  • It is solved, thank you.

    Tuesday, April 12, 2011 1:44 PM
  • Works great :)
    Tuesday, April 12, 2011 2:14 PM
  • Well ! The problems is corrected. Thank you.
    Thursday, April 21, 2011 1:43 PM
    • Proposed as answer by danma_ Thursday, August 4, 2011 3:38 AM
    Friday, April 29, 2011 5:53 AM
  • Thanks Evgeniya, it solved the problem.

    Thanks a lot.

    Regards.

    Sunday, May 15, 2011 3:58 AM
  • No. The problem is not corrected, se update on

    http://blogs.technet.com/b/asiasupp/archive/2011/04/29/internet-explorer-9-ie9-and-forefront-tmg-2010.aspx

    Hope an update is comming soon.

     Working on the server: (Not remotely)

    Running: Windows Server 2008 R2 Standard SP1
    8GB RAM, 64-bit OS
    TMG Version: 7.09027.400
    Management Console 3.0, Version 6.1 (Build 7601: SP 1)

    User: Domain / Administrator

     


    Saturday, June 4, 2011 9:15 PM
  • It (IE9) also causes problems with the Exchange 2010 MMC so that you can't close the MMC
    Saturday, June 4, 2011 11:27 PM
  • Problem solved, thank you very much :)

    Thanks,

     

    Wednesday, June 29, 2011 4:14 PM
  • Worked! Thanks

    Tuesday, October 25, 2011 1:43 PM
  • For TMG, this is now solved in SP2 for TMG.

     

    TMG SP2 fixlist at:

    http://support.microsoft.com/kb/2555840

    TMG SP2 IE9 fix (included in SP2) described in:

    http://support.microsoft.com/kb/2599067 


    Hth, Anders Janson Enfo Zipper
    • Proposed as answer by Anders Janson Wednesday, October 26, 2011 8:15 AM
    Wednesday, October 26, 2011 8:15 AM
  • Nice work Evgeniya Kotovich!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, May 15, 2013 2:38 PM
  • Hi, We must search for the three lines which contains the keyword "paddingTop" and then comment each of them by adding the characters "//" in the begining. 

    Matias Colli

    Tuesday, May 27, 2014 8:24 PM
  • * Open "C:\Program Files\Microsoft Forefront Threat Management Gateway\UI_HTMLs\TabsHandler\TabsHandler.htc"
    * Search for the 3 lines which contain "paddingTop", and remark-out each of them by adding "//" in the begining.
    Example: Change the line:
    m_aPages [niPage].m_tdMain.style.paddingTop = ((m_nBoostUp < 0) ? -m_nBoostUp : 0) ;
    into:
    // m_aPages [niPage].m_tdMain.style.paddingTop = ((m_nBoostUp < 0) ? -m_nBoostUp : 0) ;
    * Save the file, and re-open TMG management console.

    Hi,

    In my case i have 4 lines cointaining "paddingTop", i had to add "//" to all of them so i can have the problem completely fixed. Thanks.

    Thursday, November 23, 2017 10:00 AM