none
SAP GUI 7.20 connecting through directaccess.

    Question

  • I have SAP GUI 7.20 trying to connect to the SAP application servers.  Inside the LAN it works fine, on the DA connection it fails with hostname not found.  Our SAPLOGON.INI is configured using hostnames(FQDN) and not IP address' so I'm not sure where to go from here.  I have had no love searching for various combinations of directaccess & SAP GUI so I am asking for some direction here.  Thanks.

     

    Edit:

    So theres no one that can point me in the direction of an article or anything to help me get SAP GUI working through DA?

    Tuesday, October 26, 2010 1:14 PM

Answers

  • Jam.Dav and RyanM_H: Using the client system environment variable SAP_IPv6_ACTIVE=1 is the first step. To be able to do load balancing you need to install SAPRouter. The client will connect over DA to the SAPRouter on the LAN, and SAPRouter will connect to the SAP servers over IPv4. This enables load balancing to work.

    • Marked as answer by Jam.Dav Monday, November 01, 2010 6:17 PM
    Monday, November 01, 2010 10:11 AM
  • Noam,  thanks again for your tip.  We have added the necessary permissions to the route permissions table in our SAPRouter instance and added the SAPRouter entry into the SAPlogin.ini on our local machines and the connections to the load balanced SAP application servers work as required.

    Now to work out either load balancing or HA of the SAPRouter.....

    • Marked as answer by Jam.Dav Monday, November 01, 2010 6:17 PM
    Monday, November 01, 2010 2:04 PM

All replies

  • The only way i've been able to get SAP to work so far is to use a terminal server with RemoteApps on it and give the users the SAP GUI from there.  I'd love to get it to work through DA normally though and would love to know if you find an alternative way.
    Friday, October 29, 2010 11:36 AM
  • RemoteApp is the route I have been recommending but I recently found some documentation about enabling IPv6 for SAP.  If you are using UAG then IPv6 should matter only to the client side, bit it might be worth looking in to.

    http://help.sap.com/saphelp_nwpi71/helpdata/en/46/d280d334381d21e10000000a1553f6/frameset.htm

    Excerpt: "Establishing the connection from the IPv6-enabled system to the IPv4 system. Since the IPv4 system can only accept IPv4 connections, the connection must be established using IPv4. Note that with an IPv6-enabled system the host name of the target system is resolved to an IPv4 address. Thus a host name that has not defined any IPv6 address must be used for the target. Alternatively, the IP address can be entered as the target system instead of the host name."

    You might consider doing End-to-End instead of End-to-Edge for SAP so you can keep IPv6 over the entire route and see if that helps.


    MrShannon | TechNuggets Blog | Concurrency Blogs
    Friday, October 29, 2010 2:21 PM
  • Currently I have had success by adding a system environment variable on the client of SAP_IPv6_ACTIVE=1 as per http://blog.beanylan.co.uk/  and connecting directly to server connections.  The group connections (load balanced) are the ones im trying to work through now.

    At least I know it will work now.

    • Proposed as answer by RyanM_H Sunday, October 31, 2010 8:06 PM
    Friday, October 29, 2010 2:27 PM
  • This worked great for me and is a heck of a lot better than using the RemoteApps i was getting ready do use.  Thank you so much for this info.
    Sunday, October 31, 2010 8:07 PM
  • Jam.Dav and RyanM_H: Using the client system environment variable SAP_IPv6_ACTIVE=1 is the first step. To be able to do load balancing you need to install SAPRouter. The client will connect over DA to the SAPRouter on the LAN, and SAPRouter will connect to the SAP servers over IPv4. This enables load balancing to work.

    • Marked as answer by Jam.Dav Monday, November 01, 2010 6:17 PM
    Monday, November 01, 2010 10:11 AM
  • Glad to hear that this info worked and helped someone else.
    Monday, November 01, 2010 11:20 AM
  • That makes sense.  Thanks for sharing, now to get the SAP team to understand what I need.  I will post back any interesting bits if I get any.

    Monday, November 01, 2010 11:22 AM
  • Noam,  thanks again for your tip.  We have added the necessary permissions to the route permissions table in our SAPRouter instance and added the SAPRouter entry into the SAPlogin.ini on our local machines and the connections to the load balanced SAP application servers work as required.

    Now to work out either load balancing or HA of the SAPRouter.....

    • Marked as answer by Jam.Dav Monday, November 01, 2010 6:17 PM
    Monday, November 01, 2010 2:04 PM
  • Hi Noam,

    Great info!

    Thanks!

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Monday, November 01, 2010 2:45 PM
    Moderator
  • Hi Jam,

    Very helpful!

    Thanks!

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Monday, November 01, 2010 2:46 PM
    Moderator
  • In case you haven't seen it there is a technet blog article on getting SAP to work.  It covers SAP GUI 7.1 and the SAPRouter for load balancing.

    http://blogs.technet.com/b/edgeaccessblog/archive/2010/12/08/connecting-directaccess-clients-to-sap.aspx


    MrShannon | TechNuggets Blog | Concurrency Blogs
    Thursday, December 16, 2010 12:37 PM
  • Hi Shannon,

    Thanks for bubbling up the blog post to the forum!

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Thursday, December 16, 2010 4:11 PM
    Moderator
  • Hey Jam Can you please through some more light of what exactly entried needs to be in SAP Router config ?

    Thanks for your help.

    Tuesday, January 22, 2013 5:05 PM
  • Any Help with SAP router Configuration would be Appreciated.
    Wednesday, January 23, 2013 7:08 AM
  • We're using SAP 7.4. If I enable the variable, I get an error when trying to connect. "Internal error (this retcode should be handled by caller of DPTM-layer)". This happens even if I'm inside the network using IPV4. Anyone know a way around this error?

    Mike Pietrorazio


    Friday, January 06, 2017 2:54 PM
  • It's possible setting that environment variable to enable IPv6 makes SAP run in IPv6 mode all the time...? If so I think others would have posted about that trouble as well, but I have seen the same behavior out of other non-IPv6-complaint applications before.

    If that turns out to be the case, I have also gotten SAP working over DirectAccess before by using the App46 tool that we built at work. It is a client agent that intercepts traffic streams from IPv4-only applications (that don't work over DA), spins those packets into IPv6, and then shoots them across the DA tunnels, thereby making that application connect successfully over DirectAccess.

    Since SAP has its own workaround by using this environment variable, I haven't used App46 on it too many times, but for some of our customer who have App46 for other applications they have chosen to use it for SAP as well, so they don't have to deal with the environment variable, particularly if it causes trouble to do so.

    Friday, January 06, 2017 4:00 PM
  • I know it's been a while, but thought I would add that we se this same behavior with 7.4.  If you downgrade to 7.3 it works fine.  We have had a case open with SAP for a while now with no luck.  This only happens on a handful of PCs in our environment, where as thousands of PCs work fine.  We believe we have tracked it down to a single location in our company where we believe the locals are installing some piece of software that is causing the issue.  We have not been able to pinpoint the cause and worse we can't ever get the client to work after the problem arises, minus reimaging the PC.

    I'll be happy to reply to this post if we ever do get any resolution.

    Friday, July 07, 2017 7:44 PM
  • Thanks for the update. We're still struggling with this issue, so if you do find some resolution, it would be great to hear. -MIKE

    Mike Pietrorazio

    Monday, July 10, 2017 11:59 AM