Sections of FEP Reports getting Subreport could not be shown error


  • Running FEP 2010 on an SQL 2008 SP2  & SCCM 2007 server.

    When running reports such as the Antimalware Protection Summary with default settings, we get the error on several of the sections in the report. If we select Day rather than Week and regenerate the report, it works OK. If we pick Custom and set the range for 1 day (same as the Day option) if also has the problem.


    Any help on this would be greatly appreciated!!

    giovedì 19 maggio 2011 13:59

Tutte le risposte

  • It should work. Could you give me the error please.
    Bechir Gharbi |
    giovedì 19 maggio 2011 16:09
  • The report itself runs but a subset of the sections where specific graphs or indicators should be instead display the error "Subreport could not be shown." 
    lunedì 23 maggio 2011 16:48
  • Same setup, same issue here.

    Error: Subreport could not be shown.



    giovedì 2 giugno 2011 19:22
  • Error: Subreport could not be shown.

    Maybe onr of the following cause :

    1# the reporting server is pointing to the wrong computer running SQL Server or a SQL Server instance.

    2# the account configured (in SQL Server Reporting Services) to connect to the reporting database does not have appropriate permissions for the database.

    To determine which reason is causing the error, attempt to directly open the subreport reporting the error, by clicking the name of the subreport.

    Bechir Gharbi |
    venerdì 3 giugno 2011 08:24
  • I have the same issue.

    When i manually run the sub report it works fine, but when it runs as the sub report i get the error.  Additionally when i set the Antimalware protection summary report and set it to day only the report works fine, but if i set it to anything else it does't work.

    Win 2008 R2 Standard SP1, SQL 2008 R2 SP1 Reporting Service is on the site server, and the databases are stored on a remote server.

    giovedì 22 settembre 2011 15:30
  • i ended up 'fixing' this by putting my reporting services, sql, site, and fep all on the same server.
    mercoledì 28 settembre 2011 21:59
  • I've got what appears to be the same problem as the original poster.

    When I configure any domain account as the stored credential in SQL Reporting for the FEP , then try to run a FEP report (such as the Antimalware Protection Summary Report), it will show some subreports fine and others will show "Error: Subreport could not be shown".

    In troubleshooting, we have tried to open the erroring subreports.  They work fine when opened directly, where they have a Report Time Span of 1 day.  When we try to expand the report to a Week, it gives an error that looks like (report tried from the SQL Reporting server, to get better detail in error message):

           An error occurred during client rendering.

    An error hasoccurred during report processing.

    Query execution failed for dataset 'dsAMProtectionBreakdown'.

    Error 15274,
    Procedure -, Line 1, Message Access to the remote server is denied because the
    current security context is not trusted.

    While it seems that errors like this have a few forum threads, I haven't seen a solution yet... and a re-install for co-locating all components on the same server isn't practical in our environment.

    Anyone have ideas or a solution for this yet?

    venerdì 16 marzo 2012 20:46