Slow Upload - Even with SP1 Update 2 installed.


  • Morning all, I’m trying to solve a rather annoying issue with two of our TMG servers (virtualised on ESXi).

    It started with the VPN connections for uploads being very slow. After more testing, I found that it affected all traffic that was uploading!


    We have a 50 up, 50 down internet connection.


    Both TMGs are less than a month old, and were installed with all updates before they were used/configured.


    Background testing & notes

    • Our old physical ISA box doesn’t have the fault - This takes internal switching and internet connection problems out of the equation.
    • The issue appears on both of our TMG servers.
    • Doing a file transfer to/from each TMG server to machines in the local LAN doesnt show there to be a problem with that, with speeds hitting 80-100MB/s - this takes a problem with the virtual hosts nic/MTU setup out of the equation.

    Steps tried:

    • EnablePMTUDiscovery has been tried as on (but not off yet).
    • The knowledge base article listed here: has been applied to the SP2 w/Update 2 boxes.
    • One of the TMGs has had all patches and updates removed all the way back to SP1 Update 1, and then re-applied in order, with SP1 Update 2 having the reg keys and script ran before testing, then further upgrades to the latest.


    The registry keys, at any point and patch level don’t exist, nor do the DWORD values.

    So what I have done is to create under the registry key location:

    HKLM\System\CurrentControlSet\Services\W3Proxy is the following:

    A key called “Paramaters”

    And created the 32bit DWORD Values with 16 in hexadecimal





    The script to modify the TCP Buffer was set to use a value of 60,000.

    The issue has been logged with Partner Support Services, but they only operate Monday to Friday, and I was hoping to make some progress on this over this weekend.

    Any help would be much appreciated.

    Thanks in advance all.

    sabato 16 giugno 2012 11:03

Tutte le risposte

  • Hi,

    Thank you for the post.

    Is there any firewall outside of the TMG server? as far as I know, they are new features introduced in 2008 and some old NIC driver or networking device may not support well. We can prevent such issues by disabling them. Please run them in the command prompt started with “run as administrator”

    netsh int tcp set global chimney=disabled

    netsh int tcp set global rss=disabled

    netsh int tcp set global autotuninglevel=disabled


    Nick Gu - MSFT

    venerdì 22 giugno 2012 05:18
  • Hi Nick,

    This is an old post and I have not posted the problem. But I encounter exactly the same issue. Never had this kind of issue before. In our case the above netsh command did not solve the problem.

    I have tried and checked a lot of things. It only appears to occur when NLB is enabled.

    Any suggestions?

    Boudewijn Plomp, BPMi Infrastructure & Security

    martedì 5 marzo 2013 11:27
  • In my case the problem is solved. Our TMG was (temporary) connected to a Cisco SMB (Small Medium Business) switch that does not handle NLB well. After connecting it to a Cisco Catalyst 3850, it worked like a charm!

    Apparently, NLB works properly within the VLAN. But if you configure the SMB switch in L3 mode, and traffic is coming from another VLAN then NLB is very very slow. Not with a Catalyst.

    Boudewijn Plomp, BPMi Infrastructure & Security | Please remember, if you see a post that helped you please click "Vote as Helpful" and if it answered your question, please click "Mark as Answer".

    mercoledì 15 ottobre 2014 14:21