[FCS Evalution - One Server Topology] - Add Management Server SQL Server Login Error


  • Hello,

    I am using Evaluation version of FCS , on minimum recommended config for server with one server topology ,
    I am successful in installing FCS and moved on to next step ie configuration , in verification everything was successful but in next step I received following error.

    And following log is created corrosponding to above error.
    [9/15/2009 8:30:42 AM] Task(Add Management Server SQL Server Login)
    Login information does not exist in SQL for ICCS\FOREFRONTSERVER$.
    [9/15/2009 8:31:17 AM] Task(Add Management Server SQL Server Login)
    Failed to create SQL Server login.
    [9/15/2009 8:31:17 AM] Task(Add Management Server SQL Server Login)
    System.Data.SqlClient.SqlException: Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.
       at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParserStateObject.ReadSniError(TdsParserStateObject stateObj, UInt32 error)
       at System.Data.SqlClient.TdsParserStateObject.ReadSni(DbAsyncResult asyncResult, TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParserStateObject.ReadPacket(Int32 bytesExpected)
       at System.Data.SqlClient.TdsParserStateObject.ReadBuffer()
       at System.Data.SqlClient.TdsParserStateObject.ReadByte()
       at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
       at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)
       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
       at Microsoft.Forefront.ClientSecurity.Configure.AddCredentialsToSqlServerTask.AddSqlLoginInfo(String creds, String db, SqlConnection connection)
       at Microsoft.Forefront.ClientSecurity.Configure.AddCredentialsToSqlServerTask.AddCredentials(String creds, String datasource, String dbname)Number of tasks completed: [9/15/2009 8:31:17 AM]
    General Information about FCS Installation ,

    I have Domain, Forefrontadmin is user of domain and Local admin , this user is also have admin role in SQL Server . And I ensured that I follow all steps stated in deployement guide published by Microsoft.

    So your help requested.

    15 septembrie 2009 03:18

Toate mesajele

  • Hi,


    Thank you for your post.


    Based on my research, this issue may occur when the FCS server in the workgroup environment. Please also refer to the following link to check up the system requirements





    Nick Gu - MSFT
    17 septembrie 2009 06:51
  • Hello Nick, Thanks for reply, But as i cleared in my post , I am testing on domain , and machine where i am installing FCS is domain admin user . I already gone thru Deployment guide and fulfilling all requirements. Everything was fine. It worked after one restart. I dont know how it worked. So I feel it was random error :(

    Now my problem is solved.
    21 septembrie 2009 12:45
  • Hello!

    I'm getting almost the same problem:

    I'm trying to run Forefront Client Security for the first time. I was able to install it without problems (after installing SQL Server Enterprise 2005 SP2) in a Windows Server 2003 SP2. I've installed Forefront Client Security in a single server environment.

    When I try running the Client Security Console for the first time, I'm requested to put some information. For the reporting database, I'm putting the following information:

    Reporting Database: MYMACHINE.
    User Name: MYMACHINE\Administrator.

    In the "Verify Settings and Requirements" screen, everything is OK and I'm not getting any error.

    But, when I run the "Completing the Configuration Wizard", I'm getting an error:

    "Windows NT user or group 'MYGROUP\MYMACHINE' not found. Check the name again "

    The problem is, I haven't given 'MYGROUP\MYMACHINE ' as user. And I do not know how to solve the problem. I've installed the product. But I'm not able to run it.

    Kind regards,
    24 septembrie 2009 05:34
  • We were also running this in a test environment and received the same error that led us to this site. I just figured out that our test DC was not online for it to connect to. Please make sure you can connect to your DC and that the account you are using has permissions to the SQL databases.


    Hope this helps =)


    23 aprilie 2010 18:19
  • I am having the same error

    [4/26/2010 11:44:01 AM] Task(Add Management Server SQL Server Login)
    System.Data.SqlClient.SqlException: Windows NT user or group 'WORKGROUP\MSFC$' not found. Check the name again.

    I am running a single machine test setup. I have given my Login ID as my user name on the computer MSFC\Administrator ( Machine Name\Logon ID).

    I have also created a Group called MSFC on my server and added the account Administrator to it.

    It would be great if you could help me out with this.







    26 aprilie 2010 15:46
  • Same error here.  However, I have a two server topology and am not installing in a Domain environment.  I have not seen in the system requirements that a Domain is required to make the installation.  I do see that as a fix for different errors encounterd from the FCS techs in other parts of the forum.  In an earlier part of my installation process where I was getting stuck with the msiexec.exe error I simply needed to provide the server name where the setup process was asking for a Domain.  That cleared the error.  I'm hoping that this case will be similar.  Judging by the original post of September 2009 I'm guessing that the answer will not be coming from the FCS team any time soon. 
    3 mai 2010 14:21