none
Serveur FTP anonyme inaccessible (Windows Server 2012 R2) RRS feed

  • Question

  • Bonjour, 

    Je n'arrive pas à accéder au contenu de mon serveur FTP sur le réseau. 
    Le serveur FTP est bien accessible en local, mais inaccessible depuis les clients. (Quand je dis local, c'est en localhost, le serveur se trouve bien dans nos locaux. Nous ne passons pas par un serveur distant)

    J'ai vérifié dans le pare-feu du serveur, les règles dédiées au FTP sont bien activées. Un telnet depuis un client vers le serveur sur le port 21 m'indique que la connexion se passe bien à ce niveau-là. Mais j'ai un ERROR_TIME_OUT lorsque j'essaye d'y accéder depuis un navigateur. Ce n'est pas non plus accessible depuis l'explorateur Windows.

    Donc, dans le pare-feu, les 3 règles créées par défaut lors de l'ajout du rôle FTP sont activées.
    Une 4e règle nommée "FTP", ouverte pour tous les programmes sur le port 21 a manuellement été ajoutée.

    Cependant, si je désactive le pare-feu du domaine du serveur, j'arrive à accéder au contenu FTP. 

    Je n'arrive pas à comprendre d'où vient le problème...

    Je vous remercie pour votre aide.


    • Modifié Jo_Biblio mercredi 4 novembre 2020 09:01
    mercredi 4 novembre 2020 09:01

Toutes les réponses

  • Bonjour,

    Tu dois régler correctement le pare-feu.

    Il y a plusieurs type de FTP (actif, passif ...) donc en fonction du type tu ouvres les bons ports.

    https://docs.microsoft.com/en-us/iis/publish/using-the-ftp-service/configuring-ftp-firewall-settings-in-iis-7

    exemple pour FTP passive

    Step 1: Configure the Passive Port Range for the FTP Service

    In this section, you configure the server-level port range for passive connections to the FTP service. Use the following steps:

    1. Go to IIS 7 Manager. In the Connections pane, click the server-level node in the tree.

    2. Double-click the FTP Firewall Support icon in the list of features.
    1. Enter a range of values for the Data Channel Port Range.

    2. Once you have entered the port range for your FTP service, click Apply in the Actions pane to save your configuration settings.

    Notes

    1. The valid range for ports is 1024 through 65535. (Ports from 1 through 1023 are reserved for use by system services.)

    2. You can enter a special port range of "0-0" to configure the FTP server to use the Windows TCP/IP dynamic port range.

    3. For additional information, please see the following Microsoft Knowledge Base articles:

    4. This port range will need to be added to the allowed settings for your firewall server.


    "Marquer comme réponse" les réponses qui ont résolu votre problème






    mercredi 4 novembre 2020 11:12
  • Bonjour, 

    Je n'ai pas la possibilité de modifier la plage de ports, cette option est grisée. 

    Et... A la base ce serveur FTP était hébergé sur un Windows Server 2008 R2, et j'ai simplement récréé un serveur FTP, avec les mêmes paramètres sur WS2012 R2, en vérifiant les règles de pare-feu, et tout me semble similaire pourtant...
    D'ailleurs, sur le serveur 2008, cette option n'était pas modifié dans IIS.

    Dans le cas d'un serveur FTP actif, j'ai suivi cette procédure, mais cela ne résout pas mon problème...

    1. Ouvrez une invite de commande: cliquez sur Démarrer , sur Tous les programmes , sur Accessoires , puis sur Invite de commandes .

    2. Pour configurer le pare-feu pour permettre au service FTP d'écouter sur tous les ports qu'il ouvre, tapez la syntaxe suivante puis appuyez sur Entrée:

      netsh advfirewall firewall add rule name="FTP for IIS7" service=ftpsvc action=allow protocol=TCP dir=in
    3. Pour désactiver le filtrage FTP avec état afin que le pare-feu Windows ne bloque pas le trafic FTP, tapez la syntaxe suivante puis appuyez sur Entrée:

      netsh advfirewall set global StatefulFtp disable



    • Modifié Jo_Biblio mercredi 4 novembre 2020 14:06
    mercredi 4 novembre 2020 13:56
  • Bonjour Jo_Biblio,

    Si vous avez trouvé une solution à votre problème, merci de la partager avec la communauté TechNet ou "Marquer comme réponse" les réponses qui ont résolu votre problème.

    Je vous remercie par avance pour votre retour.

    Cordialement, 
    Nedeltcho

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mercredi 25 novembre 2020 08:27