locked
Windows 8.1 IE 11 freezes when using proxy.pac RRS feed

  • Discussion générale

  • We are using a proxy.pac in my compagny, and IE is set to use this :

    http://proxyhost.mycompagny.local/proxy.pac

    It was working fine on Windows 8 with IE 10 (and also on Window 7 , Windows XP ...)

    Since I upgraded to Windows 8.1 , IE 11 can no longer access to Internet. Let me explain:

    I start my computer, then I start IE and it does nothing, it doesn't load or show the URL of my homewebpage.

    Then I close IE, I go to the control panel in order to remove the proxy setting, then I start IE again and I can access internet. Then I go directly in to the Internet Options from IE , I reactivate the proxy settings and now IE can access internet using the proxy.pac

    This is very weird.

    Thanks in advance for your help

    vendredi 27 septembre 2013 12:15

Toutes les réponses

  • Bonjour,

    Regardez ici:

    http://support.microsoft.com/kb/271361/fr

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT

    lundi 30 septembre 2013 01:55
  • Bonjour Bricoleur,

    j'ai testé les 2 solutions ( clé de registre ; gpo locale ) mais aucune des 2 ne fonctionne.

    En même temps, cette KB ne s'applique pas sur Windows 8.1 , et encore moins sur IE 11. Qui plus est, j'ai dans mon entreprise des postes sous Windows XP, Windows 7, avec des version d'IE diverses, et nous n'avions pas ce problème.

    Merci pour votre aide

    Cordialement

    lundi 30 septembre 2013 13:33
  • Bonjour à tous,

    malheureusement ça ne fonctionne toujours pas correctement. Je respecte pourtant les recommandations de MS.

    Actuellement, mon IE 11 est configuré pour utiliser ceci :

    http://frsecure02.macompagnie.fr/proxy.pac

    Mais c'est un bug Windows , tout simplement je pense. Je redémarre mon poste, je lance IE , il ne charge pas ma page de démarrage, et semble planté, je le referme et je réessaye 2-3 fois (de relancer IE) et là ça fonctionne....

    Y a t il moyen d'utiliser IE 10 sur Windows 8.1 , au pire des cas ?

    Merci pour vos réponses.

    Cordialement

    mercredi 2 octobre 2013 14:14
  • Bonjour Alexis,

    Avez-vous essayé de déployer le proxy.pac par GPP?

    Windows 8 and IE10 not accepting Proxy Settings via Group Policy

    IE10 Proxy .PAC File – Windows 8

    Internet Explorer 11 fait partie de la mise à jour 8.1 de Windows. Il n'est pas possible de revenir à Internet Explorer 10, tandis que Windows 8.1 est installé.

    Cordialement,

    Florin


    Florin CIUCA, MSFT  Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    lundi 7 octobre 2013 08:40
  • Bonjour Florin,

    merci pour votre réponse, mais mon problème n'est pas au niveau du déploiement du paramètre par GPO.

    Mon problème est que mon IE ne charge rien / freeze , lorsque je spécifie un script de configuration automatique.

    Cela se produit lorsque le paramètre est déjà configuré et que je lance IE.

    Si je retire ce paramètre dans mes options internet (directement dans le panneau de config, IE fermé), je lance IE et il charge bien ma page de démarrage en ne passant pas par le proxy.

    A partir de là, si je vais dans les options internet et que je réactive le paramètre de script auto, IE prend bien en compte le paramètre (je sais que je passe bien par mon proxy parce que je bloque des URL que j'ai testées) et il fonctionne bien.

    Si je referme IE, et que je le relance, il fait rien. Un vieux bug de m...

    mardi 8 octobre 2013 13:56
  • Bonjour à tous,

    je pense avoir trouvé la raison de mon pb, mais il y a qql chose que je n'arrive pas à expliquer.

    Dans mon proxy.pac , il y a donc des exceptions (c'est un peu le but d'un proxy.pac) et sinon il me renvoie le serveur proxy à utiliser. Mon serveur proxy répond au port 8082.

    J'ai rajouté une exception dans le pare-feu Windows pour autoriser ce port en sortie. Et là ça fonctionne, IE démarre et charge bien ma page de démarrage.

    Ce que je n'arrive pas à expliquer, c'est que si c'était vraiment le pare-feu, alors IE n'arriverait pas à accéder à internet une fois que je rajoute le paramètre proxy.pac , or ça fonctionnait (comme je vous l'expliquais dans mon poste précédent).

    Qu'en pensez-vous ?

    Cordialement 

    mercredi 16 octobre 2013 15:52
  • Fausse alerte, finalement ça ne fonctionne toujours pas. ça a marché un temps, mais là ...

    De plus, j'ai un nouveau poste sous Windows 8.1 , avec IE 11 donc, qui présente exactement le même problème !

    Voici le proxy.pac que j'utilise :

    function FindProxyForURL(url, host)
    {
       if ( host == "127.0.0.1" ||
     isInNet(host, "192.9.202.0", "255.255.255.0") ||
     host == "192.9.202.36" ||
     shExpMatch(host, "127.0.0.1") ||
     shExpMatch(host, "localhost") )
     

             return "DIRECT";
       else
             return "PROXY frsecure02.mycompany.local:8082";
    }

    Merci pour votre aide

    jeudi 12 décembre 2013 15:34
  • Bonjour à tous,

    joyeux Noël !

    Suis je le seul à rencontrer ce pb ? Je ne comprends vraiment pas ce qu'il se passe.

    jeudi 26 décembre 2013 11:26
  • Bonjour,

    Il semblerait qu'Ie11 ne reconnait pas les fichiers de configuration automatique de "Proxy" avec le préfixe " file// ".

    Essayez ceci:

    - Activation de l'option Client Proxy utilise HTTP pour le script de configuration automatique de Proxy dans la ressource de l'accès au réseau.

    Bonne année 2014.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT


    • Modifié Bricoleur mercredi 1 janvier 2014 21:42
    mercredi 1 janvier 2014 21:42
  • Bonjour,

    je n'avais pas vu la réponse désolé.

    Désolé aussi mais à aucun moment je n'ai dit que je faisais appel à un share dans les paramètres proxy.

    Mon fichier proxy.pac a toujours été hébergé sur un serveur web IIS. C'est un Windows 2003 R2 le IIS.

    Bon weekend.

    vendredi 7 février 2014 16:17
  • Bonjour à Tous,

    Internet fige égualement à l'utilisation d'un .pac  avec préfixe en Http.
    Lance IE, pas de reponse. Ferme et relance IE => OK

    Je teste en renseignant le serveur proxy => OK

    Je pense à un bug Windows 8.1 (sous Xp et Win7, pas de problèmes)?

    Avez-vous une Idée ?

    jeudi 22 mai 2014 09:55
  • Bonjour,

    nous commençons à déployer IE11 sur notre master Windows 7 et nous avons le même problème.

    Un autre symptôme, on lance IE avec le proxy.pac , ça s'ouvre bien mais lorsque l'on souhaite ouvrir un nouvel onglet, celui-ci fige pendant 40 sec avant de rendre la main.

    ça commence à être très problématique.

    mardi 14 octobre 2014 10:00
  • Bonjour,

    J'ai également le même problème sous Windows 8.1 / IE11.

    Est ce que l'un d'entre vous a fini par trouver une solution ?

    vendredi 13 mai 2016 13:30