none
Sharepoint Foundation 2010 problème de droits RRS feed

  • Question

  • Bonjour à tous,

    Voila donc mon soucis, je suis actuellement sous Sharepoint 2010 (synchroniser avec AD) et je me retrouve bloquer avec le probleme suivant:

    J'ai créer un site sans difficulter dans lequel j'ai créer un calendrier.Au niveau du site j'ai créer 3 groupes Site owners , site members , et site visitors dans lesquels j'ai mis les personnes adapté.Jusque la aucun soucis.

    Lorsque maintenant je veux configurer les droits du calendrier uniquement en cliquant dessus et en allant de library permissions, je casse l'héritage des droits et la quand si je rajoute par exemple l'utilisateur toto tout fonctionne appart que même avec l'héritage casser si je retourne sur les permissions du site et non de la library toto apparait ce que je ne veux surtout pas...

    Comment faire ?

    Merci

    jeudi 16 août 2012 07:39

Réponses

  • Bonjour,

    Si vous ne voulez pas voir les utilisateurs dans les permissions, au lieu d'utiliser les groups par défault de sharePoint ( owner, membern visitor ) créez des nouveau permission level et enlevez l'option " Manage Permissions " ...

    1) créer un nouveau groupe

    2) créer un nouveau permission level et retirer "Manage Permissions"

    3) lier les 2

    4) ajouter les personnes adéquate dans le nouveau groupe

    5) ces personnes la ne pourront plus voir toto qui est dans la list cassé ou pas

    courage,

    Gokan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 08:05
  • Bonjour,

    Simple, casser l'héritage au niveau Shared Documents et retirer le groupe -ou toto de Shared Documents ..

    Courage,

    Gokan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 09:37
  • Euuuhhm, Je vous pose la question hors sharepoint..

    • Vous n'avez pas le droit de vous connecter sur le domaine ( via le GPO, on vous a bloquer ) esque vous savez prendre un fichier qui est sur votre pc de domaine? NON
    • Vous avez une tasse de café dans votre cuisine, mais elle est fermé a clé.. esque vous savez la boire? NON
    • Vous avez un calendrier que vous voulez modifier, mais vous n'avez pas les droit sur le site, savez vous le modifier? NON :-)

    J'éspère que cela vous aidera..

    Golan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 09:56

Toutes les réponses

  • Bonjour,

    Si vous ne voulez pas voir les utilisateurs dans les permissions, au lieu d'utiliser les groups par défault de sharePoint ( owner, membern visitor ) créez des nouveau permission level et enlevez l'option " Manage Permissions " ...

    1) créer un nouveau groupe

    2) créer un nouveau permission level et retirer "Manage Permissions"

    3) lier les 2

    4) ajouter les personnes adéquate dans le nouveau groupe

    5) ces personnes la ne pourront plus voir toto qui est dans la list cassé ou pas

    courage,

    Gokan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 08:05
  • Bonjour,

    Merci de cette réponse mais le probleme n'est pas un probleme de visibilité mais de droits mon calendrier à un héritage cassé, lorsque je rajoute toto dans ce même calendrier je le vois apparaître au niveau des permissions du site. En gros lorque je donne le droit a toto d'écrire sur le calendrier il obtient directement les droits d'écrire sur le site complet alors que l'héritage est cassé..

    Comment cela ce fait?

    Merci

    jeudi 16 août 2012 08:51
  • Salut,

    Aaaahh, c'est un peux normal, si il n'a pas le droit d'écrire sur le site, il n'aurai pas le droit d'écrire sur le calendrier..

    Vous devez d'abord acceder au site, puis le calendrier ..

    Si vous avez aucun droit au niveau site, vous n'aurez pas le droit sur le calendrier.. C'est le comportement normal de SharePoint.. Il faut toujours regarder en "haut" vers "bas"

    1) Web App

    2) Site Coll

    3) Site

    4)Doc

    5) element

    Vous avez votre calendrier au niveau site, donc automatiquement il a les droit sur site, site coll et web app ..

    Courage,

    Gokan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 08:59
  • Ok, mais comment faire si jamais je veux que toto sur ce même site puisse modifier le calendrier mais pas la partie shared documents par exemple?
    jeudi 16 août 2012 09:19
  • Bonjour,

    Simple, casser l'héritage au niveau Shared Documents et retirer le groupe -ou toto de Shared Documents ..

    Courage,

    Gokan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 09:37
  • ok est le sens inverse c'est pas faisable? je trouve sa assez étrange... en gros si je veux que toto ne puisse que modifier le calendrier il est obliger de modifier tout le site en question c'est assez bete
    jeudi 16 août 2012 09:40
  • Euuuhhm, Je vous pose la question hors sharepoint..

    • Vous n'avez pas le droit de vous connecter sur le domaine ( via le GPO, on vous a bloquer ) esque vous savez prendre un fichier qui est sur votre pc de domaine? NON
    • Vous avez une tasse de café dans votre cuisine, mais elle est fermé a clé.. esque vous savez la boire? NON
    • Vous avez un calendrier que vous voulez modifier, mais vous n'avez pas les droit sur le site, savez vous le modifier? NON :-)

    J'éspère que cela vous aidera..

    Golan


    My blog: SharePoint Pirate http://www.gokanozcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    SharePoint Server 2010 Contributor on BTgonulluleri.com
    SharePoint Server 2010 Contributor on NothingButSharepoint.com
    SharePoint Server 2010 Contributor on SPCNL.NL
    SharePoint Server 2010 Contributor on MSHOWTO.org
    Join Me on my Linkedin Profile

    jeudi 16 août 2012 09:56