none
Visio 2010 keeps hanging

    Question

  • Last December, I created a Visio document that uses the database template. I worked on the file several times over a period of a week or two and never had any issues with it. Today, I tried editing the file and after about a minute, Visio hung. When it hung, Task Manager showed CPU utilization at 13% (basically, four cores each at around 25%). I killed the process, re-opened the file, and it hung again. I tried this several times, always with the same result.

    I then copied the file to my notebook and tried editing it there - same behavior. I then created a new Visio file using the Database model, and that hung also. I then disabled my three active plugins, no change in behavior. However, a Visio file I extensively edited yesterday, a Basic Diagram, had no issues.

    The problem clearly has nothing to do with the installation of Visio (so do not tell me to uninstall/reinstall) since this behavior is identical on two separate machines. I also looked at Windows Updates and saw no Visio updates since I last worked on this file, so this is probably not the issue.

    What the heck is going on? More importantly, is there a way 'fix' things so that I can again work on database diagrams?


    Gerald P Roston

    jeudi 26 avril 2018 23:21

Toutes les réponses

  • Hi Gerald,

    >>I then created a new Visio file using the Database model, and that hung also. I then disabled my three active plugins, no change in behavior.<<

    A new file also crashing the app, it seems the issue only happens when using the Database Model template. Does the crash issue happens to other Database templates?

    In addition, I would like to know the detailed Visio build number installed on your computer. Open Visio 2010, click File > Help > About Microsoft Visio. Also confirm if you have installed any new program or any changes on this computers recently.

    Please disable the third-party Anti-Virus program temporarily. Open Control Panel > Programs and Features, select Visio 2010, click Change > Repair.


    Best Regards,
    Winnie Liang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 27 avril 2018 08:54
    Modérateur
  • Winnie,

    Thanks for the prompt reply.

    I am running Visio Premium 2010, V14.0.7197.5000 (32 bit). I disabled my AV, ran repair, rebooted, and same problem. I created a new document using the Database Model template. I dragged two table objects into the model, connected them, then tried to add a column - that is when Visio hung and I had to forcibly kill the process. (Not that I think any specific action caused the problem, just wanted to show how quickly this happens).

    This seems to be the only template that is causing problems.


    Gerald P Roston

    vendredi 27 avril 2018 12:43
  • Winnie,

    Thanks for the prompt reply.

    I am running Visio Premium 2010, V14.0.7197.5000 (32 bit). I disabled my AV, ran repair, rebooted, and same problem. I created a new document using the Database Model template. I dragged two table objects into the model, connected them, then tried to add a column - that is when Visio hung and I had to forcibly kill the process. (Not that I think any specific action caused the problem, just wanted to show how quickly this happens).

    This seems to be the only template that is causing problems.


    Gerald P Roston

    Unfortunately, I was updated to the same Visio version as yours but failed to reproduce the issue. I can add a column in Visio Database Model template properly.

    In your scenario, I suggest you can perform a clean boot on Windows for further troubleshooting.


    Best Regards,
    Winnie Liang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    lundi 30 avril 2018 09:46
    Modérateur
  • This is not an answer - I am experiencing the exact same problem on two entirely different computers. Clean boot is a red herring. This must be related to some update pushed by MS between Dec 2017 and now.

    Gerald P Roston

    dimanche 6 mai 2018 15:45