none
Project Server 2013 : Errors in the back-end database access module. The provider 'SQLNCLI10' is not registered.

    Question

  • Bonjour,

    Je rencontre un problème concernant Project Server 2013 et le service Analysis Service.
    SharePoint Server 2013 est installé sur une plateforme SQL Server 2012 et Project Server installé et configuré.
    Cependant mon problème se situe au moment de lancer le build pour créer une base dans le Cube.
    Après avoir lancé le Build, la base se créé mais celui ci passe en statue "Failure" avec le message d'erreur suivant :

    ===== Process Completed =====
    [3/19/2013 2:20 PM] Failed to build the OLAP cubes. Error: Failed to process the Analysis Services database ProjectServer2013 on the SFRASSQL01.demostraining.com server. Error: Errors in the back-end database access module. The provider 'SQLNCLI10' is not registered.
    The following system error occurred:  Class not registered
    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Project Reporting data source', Name of 'Project Reporting data source'.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Task Is Overallocated', Name of 'Task Is Overallocated' was being processed.
    Server: The current operation was cancelled because another operation in the transaction failed.

    J'ai retourné internet mais a part avoir trouvé cet article qui ressemble sensiblement bien qu'il concerne la version 2010, je n'ai pu le résoudre.

    http://blogs.msdn.com/b/brismith/archive/2012/07/03/a-new-sql-server-and-some-different-cube-building-errors.aspx

    Je précise que j'ai déja tenté avec une version du client SQL SQLNCLI 10.0 mais rien y fait, tout comme SQLSERVER2008_ASAMO10.
    Avez vous une idée car là je seche !

    Merci!
    mardi 19 mars 2013 14:13

Réponses

  • Salut,

    Votre message d'erreur est le suivant;

    Failed to process the Analysis Services database ProjectServer2013 on the SFRASSQL01.demostraining.com server. Error: Errors in the back-end database access module. The provider 'SQLNCLI10' is not registered.
    The following system error occurred:  Class not registered

    C'est un problème de configuration.

    Prière d'installer SP1 de SQL Server 2012 et les CU..

    Puis de désinstaller Analysis Services et le réinstaller via les exe de SQL Server..

    Puis re-tentez votre manipulation..

    Merci,

    Gokan


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    lundi 25 mars 2013 20:46
    Modérateur

Toutes les réponses

  • Personne ? !!!
    jeudi 21 mars 2013 13:32
  • Bonjour

    Personnellement désolé mais a part les articles sur internet je ne peux t'aider plus.Je ne suis pas expert dans les produits Project server et a part te dire qu'il y a un probléme la et la en lisant le message d'erreur je ne peux pas t'aider plus :/

    Peux être mettre ton post dans un forum plutôt project server ?

    Bon courage,

    Valentin


    Mon blog sur SharePoint
    Site du Groupe AFG
    viadeotwitter

    jeudi 21 mars 2013 13:51
  • Hello,

    Le problème c'est que peut d'article sur le net en parle et quand j'en trouve c'est pas forcément  le même problème ...
    Je n'ai pas trouvé de forum project server en français, il existe en anglais, mais j'ai déja posté.
    Merci.
    jeudi 21 mars 2013 14:42
  • Bonsoir,

    Vérifier votre Web.Config sur SFRASSQL01 car le provider 'SQLNCLI10' n'est pas registrée.

    Courage,

    g


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    dimanche 24 mars 2013 18:07
    Modérateur
  • Bonjour Gokan,

    Merci mais pouvez vous préciser ? le web.Config sur mon serveur SQL ?
    Merci.
    lundi 25 mars 2013 13:50
  • Salut,

    Votre message d'erreur est le suivant;

    Failed to process the Analysis Services database ProjectServer2013 on the SFRASSQL01.demostraining.com server. Error: Errors in the back-end database access module. The provider 'SQLNCLI10' is not registered.
    The following system error occurred:  Class not registered

    C'est un problème de configuration.

    Prière d'installer SP1 de SQL Server 2012 et les CU..

    Puis de désinstaller Analysis Services et le réinstaller via les exe de SQL Server..

    Puis re-tentez votre manipulation..

    Merci,

    Gokan


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    lundi 25 mars 2013 20:46
    Modérateur
  • Bonjour DarkMoutch,

    Un petit retour? ^^

    Merci,

    Gokan


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    vendredi 29 mars 2013 07:58
    Modérateur
  • Bonjour Gokan,

    Je n'ai pas testé ta solution encore je reviendrai dessus un peut plus tard il n'y a rien d'urgent.
    Cela dit le SP1 et dernier CU d'SQL Server est déja installé.
    Merci je marque ta réponse. ;-)
    jeudi 4 avril 2013 09:37
  • Bonjour,

    Ce post arrive peut être après les hostilités, mais je souhaite partager mon experience, pour completer la répoinse précédente.
    Après une installation de Project Server 2013 sur un SQL Server 2012 SP1, j'ai rencontré ce même problème lors de la construction  du cube OLAP.
    le composant SQLNCLI10 n'a pas été trouvé.

    Je viens de résoudre le problème, et je trouve que la doc sur internet n'est pas très claire à ce sujet.

    Donc voici ce que j'ai fait pour régler le problème chez mon client:
    - S'assurer qu'effectivement on est bien en SQL2012 SP1
    - Télécharger le feature pack de SQL 2008R2. Attention, ce n'est pas une erreur, c'est vraiment le pack SQL2008 qu'il faut récupérer. La dernière version (Microsoft SQL Server 2008 Service Pack 3 Feature Pack) semble être celle ci
    http://www.microsoft.com/en-us/download/details.aspx?id=27596
    - Sélectionner les éléments qui correspondent à votre archi de serveur: x86, IA64, AMD64 selon le cas. La sélection du fichier SQLNCLI.msi est suffisante
    - Installer ce composant sur le serveur d'application ET sur le serveur SQL. L'installer sur votre serveur appli Project Server ne suffit pas
    - Il est possible que vous ayez à interrompre le service de Project Server Queue sur le serveur d'appli
    - Relancer la build du cube: vous devriez voir le process arrivé au bout...à moins que vous n'ayez d'autres soucis après (pb de droits d'accès sur la base relationnelle !)

    En espérant que ça serve à quelqu'un !

    Sylvain Gross
    Neos-SDI

     

    lundi 27 janvier 2014 16:23