none
Worflow mail partiellement défaillant. RRS feed

  • Discussion générale

  • Bonjour,

    J'ai créé un workflow sur une liste qui envoi par mail des informations de l'élément créé à une liste de personne.

    Les email sont sous le forme yyyy@xxxx.com ou yyyy@zzzz.xxxx.com

    Le workflow fonctionne mais les emails yyyy@xxxx.com sont ignoré (pas de réception dans la boite et n'apparaisse  pas dans le champs A de l'email reçu.

    Un email yyyy@zzzz.xxxx.com a le même comportement, mais les autres fonctionnent

    J'ai essayer d'envoyer des emails avec un script powershell et toutes les adresses fonctionnent normalement.

    Je suis en WSS 3.0 (12.0.0.6421) sur Windows 2008 R2

    Cordialement,

    Eric OSI

    mercredi 22 juin 2011 15:36

Toutes les réponses

  • Bonjour,

    A ma connaissance Designer utilise le paramétrage WSS pour envoyer les mails 'Courrier electronique sortant'. Verifier bien que vous n'avez pas un serveur SMTP spécifique configuré pour votre collection de site.

    Dans tous les cas, pour introspécter cette problématique il peut être utile de :

    Logguer des informations dans l'historique du workflow, en ajoutant un bloc Sous designer.

    Logguer les mails sortants au niveau de votre serveur SMTP

     

    Cordialement

    Thierry Buisson

    lundi 27 juin 2011 07:43
    Modérateur
  • Bonjour,

    Je n'ai qu'un seul serveur SMTP disponible, et je suis le seul administrateur du Sharepoint.

     

    Je ne vois pas comment logguer les informations dans le workflow.

    Les emails sont une liste texte (les comptes AD ne les contiennent pas) mise en dur dans le workflow.

    Chaque email est envoyer à l'ensemble de la liste. Je n'utilise pas de groupe ni sharepoint, ni email pour l'envoi.

    Je reçois bien les emails mais avec une liste tronqué de destinataire.

     

    Je n'ai pas accès au serveur SMTP, et je doute de pouvoir obtenir des logs à ce niveau.

     

    Cordialement,

    Eric OSI

    mercredi 13 juillet 2011 07:47
  • Bonjour,

    Est-ce que cela ne serait pas plutôt le fait que le serveur / relais SMTP n'accepte pas les emails avec les domaines xxxx.com et zzzz.xxxx.com ou n'accepte pas de relayer des mails depuis le serveur SharePoint.

    Pour débugguer ceci, il faut vérifier avec votre administrateur du serveur SMTP et faire des tests sans passer par sharepoint. Ex: utiliser telnet

    Cordialement,

    Pierre


    Pierre Vivier-Merle - MVP SharePoint Server
    http://blogs.developpeur.org/pierre
    Merci de valider les réponses qui correspondent à votre problème afin qu'il apparaisse comme résolu.
    dimanche 17 juillet 2011 09:31
    Modérateur
  • Bonjour,

     

    Le serveur SMTP est le serveur de mail hébergeant les domaines email xxxx.com et zzzz.xxxx.com. C'est un serveur de production utilisé par d'autres applications pour envoyer des mails SMTP.

    Le serveur Sharepoint est autorisé à envoyer de mail à ce serveur SMTP, d'ailleurs certains destinataires reçoivent des emails du workflow Sharepoint.

    L'envoi d'email depuis le serveur Sharepoint, fonctionne intégralement lors des testes avec une commande powershell. (liste de destinataire identique à celle du workflow.

     

    Cordialement,

    Eric OSI

    mardi 19 juillet 2011 15:04