locked
Problème "fichier ouvert dans un autre programme" RRS feed

  • Question

  • Bonjour à tous,

    Ne sachant pas si mon problème vient du serveur ou du client, je me permets de poster ici.

    Je vous décris mon problème :

    Nous avons nouvellement mis en réseau deux ordinateurs sous Win 7 Pro. Les autres sont sous XP.

    Lorsque mes utilisateurs de Win 7 essaient d'agir sur des dossier de lecteurs réseau (situés sur un serveur Win 2008 R2 local), que ce soit renommer, déplacer, supprimer, il arrive fréquemment que le message d'erreur apparaisse "Cette action ne peut pas être réalisée car le dossier ou l'un des fichiers est ouvert dans un autre programme". J'ai vérifié avec Process Explorer, aucun programme ne bloque le fichier.

    J'ai mis à jour mon 2008 server, mon antivirus (Trend Micro Worry Free Standard 6.0), mes deux Win7 Pro et mon logiciel de sauvegarde (Symantec Backup Exec) mais rien n'y fait. Le problème persiste.

    Je pensais également que cela puisse venir de l'explorateur windows qui mettrai du temps à quitter le fichier, mais je ne sais comment agir dessus.

    J'ai également essayé de mettre comme unique DNS mon serveur de fichier (la je tâtonne, c'était juste pour essayer) dans la config ip.

    Quelqu'un aurait-il une idée d'où creuser ? N'hésitez pas à me demander des précisions (pas trop poussé, je ne suis qu'un connaisseur "de base").

    Vous remerciant,

    Arnaud
    jeudi 21 octobre 2010 17:55

Réponses

  • LA SEULE SOLUTION EST BIEN CELLE CI :

    • Run gpedit.msc.
    • Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files


    lundi 5 mars 2012 03:20
  • Bonjour,

    As tu à toujours le probleme ? Ton probleme peut venir d'un logiciel quelconque sur ta machine.

    Et qu'est ce que ca donne meme apres un redémarrage. En général quand il y a ce probleme c'est vraiment parce que le fichier est vérouillé par un programme.

    Windows lui meme ne crée pas ce probleme.

    Tu peux faire le test en démarrant tes programmes les uns apres l'autre tout en utilisant ton fichier.

    Si tes essais n'aboutissent à rien, execute l'outil Fix It pour résoudre les problèmes liés aux fichiers.


    Blog Microsoft | Déployer Windows 7 | Améliorer les performances de Windows 7
    samedi 23 octobre 2010 22:33
  • Bonjour à tous,

     

    on a rencontré ce problème chez nous, et ça venait des fonctions de prévisualisation de l'explorateur windows (les petites infos dans la barre du bas qui indiquent la taille du fichier, le nom de l'auteur etc..... et la prévisualisation des fichiers)

    après 2 reinstall de serveur et de multiples tests, mon collègue, (gloire à toi OH grand gourou !!) a trouvé cette solution qui semble fonctionner... en fait il faut revenir à un affichage simple dans les options de l'explorateur.. c'est tout !!

     

    en espérant que ça vous aide....

     

    Cdlt.

    Thibaud

    • Proposé comme réponse Bricoleur vendredi 20 mai 2011 18:39
    • Marqué comme réponse Teodora Sharkova lundi 8 décembre 2014 12:02
    mardi 22 mars 2011 13:48
  • Bonsoir à tous,

     voulez-vous regarder ici:

    http://forum.wegotserved.com/index.php/topic/13542-renaming-moving-filesfolders-takes-2-minutes-before-starting/

    ou les lecteurs:

    - Barracuda 7200.11

    -  Western digital green power series.

    Sont mis en cause.

    Et pour ceux qui désirent effacer les dossiers-->

    this small workaround for the folder delete problem.

    Run gpedit.msc.

    Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    Quelques explications sur les lecteurs, ici:

    http://www.silentpcreview.com/Terabyte_Drive_Fix

     

    Support Western:

    http://support.wdc.c...sid=114&lang=en 

     

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT
    jeudi 17 mars 2011 13:14
  • Bonjour à tous,

    Server Message Block (SMB) Version 2 Protocol Specification

    Avez-vous essayer de désactiver SMB2 sur le serveur?

     Pour désactiver, ajouter  l'entrée REG_DWORD entry named Smb2 with a value of 0 à

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    Redémarrer le serveur.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT
    jeudi 17 mars 2011 04:27
  • j'avais le même problème depuis que je suis sur Windows 7
    j'ai trouvé qu'en désinstallant le programme winlocker,

    tout redevient normal

    dimanche 10 avril 2011 13:42
  • Organiser >> Disposition, décocher "Volet des détails".


    • gpedit.msc.
    • Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    J'ai effectué les 2 opérations et pour l'instant le problème est résolu.

    Le fait de tuer le processus "explorer.exe" permettait de débloquer la situation, mais pas vraiment pratique.  Encore merci aux utilisateurs de ce forum.   

    ps: merci à microsoft de nous faciliter le travail tous les jours en ne répondant pas aux mails.


    • Proposé comme réponse lanaine35 mardi 17 avril 2012 09:24
    • Modifié lanaine35 mardi 17 avril 2012 09:25
    • Marqué comme réponse Teodora Sharkova lundi 8 décembre 2014 12:03
    mardi 17 avril 2012 09:21

Toutes les réponses

  • Bonjour,

    As tu à toujours le probleme ? Ton probleme peut venir d'un logiciel quelconque sur ta machine.

    Et qu'est ce que ca donne meme apres un redémarrage. En général quand il y a ce probleme c'est vraiment parce que le fichier est vérouillé par un programme.

    Windows lui meme ne crée pas ce probleme.

    Tu peux faire le test en démarrant tes programmes les uns apres l'autre tout en utilisant ton fichier.

    Si tes essais n'aboutissent à rien, execute l'outil Fix It pour résoudre les problèmes liés aux fichiers.


    Blog Microsoft | Déployer Windows 7 | Améliorer les performances de Windows 7
    samedi 23 octobre 2010 22:33
  • Bonjour,

    J'ai le même problème sous Win7, je renome et déplace des fichiers de musique mp3, dans explorer. Les fichiers sont fermés partout et il marque ce défaut. Il faut attendre une minute ou deux et puis ca fonctionne, comme si ca prennait du temps quelque part pour vider la mèmoire.

    Sous XP je n'ai jamais rencotré ce problème. Je me suis dit que c'est un défaut de Win7 et que les gens de microsoft y travaillent et que cella va étre résolu avec une mise a jour mais en vain.

    Cella est trés énervant si on travaille peandant quelques heures, on avance pas.

    Merci pour un coup de main.

    samedi 18 décembre 2010 16:47
  • J'ai le même problème.

    Serveur : Windows 2008

    Poste : Windows 7

    Sur mes répertoires partagés lorsque je veux supprimer ou déplacer un répertoire le message "Cette action ne puex pas être réalisée car le dossier ou l'un des fichiers est ouvert dans un autre programme".

    j'attend entre 2 à 5 minutes et après je peux exécuter mon déplacement ou ma suppression.

    J'ai pas fait de recherche avancé pour trouver la solution, mais je crois bien que ca peux venir des "thumbs.db" qui sont caché.

     

    François.

     

    dimanche 2 janvier 2011 12:11
  • J'ai le même soucis.

    je men sors toujours pas...
    je refais pleins de tests et voici d'autres éléments.

    Avant avec ces PC je n'avais pas de soucis, je sais ce problème depuis que j'ai mis 2008R2...enfin sauf si c'est une coincidence malencontreuse...

    J'ai ouvert plusieurs sessions, plusieurs fichiers, bref je suis passé au dessus de ces 30 sessions affichés dans la gestion de partage et sessions, donc ce n'est pas cela car je n'ai pas eut ce soucis.

    Je refais des tests un soir, où il ny avait qu'1 utilisateur de connecter, moi, et j'ai un comportant tres bizarre.. je mexplique : ce PC est sous Win7, et j'arrive à reproduire le problème en quelques secondes => pour cela j'accède à partir de ce PC aux fichiers présent sur le serveur 2008R2 via un lecteur partagé. je renomme un répertoire sur ce serveur en supprimant tous le nom du répertoire et en mettant un autre nom.. et là, rapidement (1 fois sur 3 quasiment) j'ai l'erreur "Cette action ne peut pas être réalisé car le dossier ou l'un des fichiers est ouvert d'un autre programme". Evidemment aucun utilisateur n'est déjà dessus puisque je suis seul.. j'ai lancé le programme "Process explorer" pour vérifier s'il y avait un autre programme dessus et je trouve "explorer.exe"
    Une fois que ce process a disparu, j'ai au niveau acces en ecriture a ce repertoire.
    Ceci est vraiment etrange car que je fais la meme manip sur un PC sous XP, je n'ai pas reproduit ce soucis...
    je sèche..
    de l'aide s'il vous plait

    lundi 10 janvier 2011 08:36
  • Bonjour,

    je rencontre le même problème:

    user sous 7 Pro qui accede sur un lecteur réseau qui pointe vers un serveur 2008 ==> plusieurs fois lors de la manipulation de ce dossier, le message apparait, elle est obligée de réessayer plusieurs fois pour que ça marche (dès fois jusqu'à 5 fois!!)

    Si quelqu'un peut nous aider!!

     

    Le hic c'est qu'il y a une autre personne qui est sous 7 pro et elle n' a pas ce problème.

    j'ai donc pensé à son antivirus mais malgrès la désactivation de celui-ci toujours rien!!

    HELP

    jeudi 20 janvier 2011 09:33
  • Je me permet de remettre cette discussion up .. toujours le même soucis.

    D'autres personnes ont remarqués ce fonctionnement étrange d'un PC sous 7  avec un serveur 2008 ? et éventuellement s'il existe des solutions nous sommes preneurs..

     

    jeudi 3 février 2011 16:44
  • Salut,

     Même soucis sous deux PC sous win7 Pro dans mon entreprise.

     Les fichiers son sur un serveur et dès que quelqu'un sous windows 7 tente un renommage de répertoire, j'ai ce message.

     Il faut bien attendre 2-3 minutes avant de retenter l'opération pour que ça fonctionne...

     Impossible de savoir quel processus bloque ces fichiers...

    A+

    vendredi 4 février 2011 08:07
  • cest dingue, on a tous ce soucis qui est clairement identifié et aucune réponse, aucune solution...c'est quand même tres impactant comme dysfonctionnement

    vendredi 4 février 2011 10:10
  • >>> impactant
     
    ???
     
     
    "eleconte77" a écrit dans le message de news:28c89932-e831-4f43-a8b7-c679168526b8...

    cest dingue, on a tous ce soucis qui est clairement identifié et aucune réponse, aucune solution...c'est quand même tres impactant comme dysfonctionnement


    Azo4
    vendredi 4 février 2011 13:31
  • azo4, je dit très impactant, car les utilisateurs qui ont ce problème se retrouvent très souvent bloqués quand ils veulent enregistrer, modifier, effacer un fichier, donc très impactant pour leur utilisation quotidienne et leur productivité. Dire aux utilisateurs, attendez 2-3 minutes et recommencer ca fonctionnera, ce n'est pas concevable.. ;)

     

    lundi 7 février 2011 09:34
  • ;o))
     
    c'est le mot lui-même que je ne connais pas...
     
     

    Azo4
    lundi 7 février 2011 10:22
  • je vais craquer.. je remet un nouveau PC sous Seven où il y a un serveur 2008R2, et vlan pareil, pil poil la meme erreur...
    • Proposé comme réponse dguillaume1_5 mercredi 16 mars 2011 09:00
    • Non proposé comme réponse dguillaume1_5 mercredi 16 mars 2011 09:01
    mercredi 9 février 2011 06:40
  • Bonjour à tous!

     

    Rencontrant exactement le meme soucis, quelqu'un a t-il finalement réussi à trouver une solution pour ce pb??

     

    Un grand merci à celui qui aura trouvé ;-)

    mercredi 16 mars 2011 09:02
  • Bonjour à tous,

    Ne sachant pas si mon problème vient du serveur ou du client, je me permets de poster ici.

    Je vous décris mon problème :

    Nous avons nouvellement mis en réseau deux ordinateurs sous Win 7 Pro. Les autres sont sous XP.

    Lorsque mes utilisateurs de Win 7 essaient d'agir sur des dossier de lecteurs réseau (situés sur un serveur Win 2008 R2 local), que ce soit renommer, déplacer, supprimer, il arrive fréquemment que le message d'erreur apparaisse "Cette action ne peut pas être réalisée car le dossier ou l'un des fichiers est ouvert dans un autre programme". J'ai vérifié avec Process Explorer, aucun programme ne bloque le fichier.

    J'ai mis à jour mon 2008 server, mon antivirus (Trend Micro Worry Free Standard 6.0), mes deux Win7 Pro et mon logiciel de sauvegarde (Symantec Backup Exec) mais rien n'y fait. Le problème persiste.

    Je pensais également que cela puisse venir de l'explorateur windows qui mettrai du temps à quitter le fichier, mais je ne sais comment agir dessus.

    J'ai également essayé de mettre comme unique DNS mon serveur de fichier (la je tâtonne, c'était juste pour essayer) dans la config ip.

    Quelqu'un aurait-il une idée d'où creuser ? N'hésitez pas à me demander des précisions (pas trop poussé, je ne suis qu'un connaisseur "de base").

    Vous remerciant,

    Arnaud


    Bonjour balafoine,

     

    rencontrant le meme pb, avez vous trouver une solution pour palier à ce message d'erreur?

     

    par avance merci

    mercredi 16 mars 2011 09:08
  • Bonjour à tous,

    Server Message Block (SMB) Version 2 Protocol Specification

    Avez-vous essayer de désactiver SMB2 sur le serveur?

     Pour désactiver, ajouter  l'entrée REG_DWORD entry named Smb2 with a value of 0 à

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    Redémarrer le serveur.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT
    jeudi 17 mars 2011 04:27
  • Bonjour,

    Ayant le même problème que vous (Je ne peut pas renommer, sup etc un ficher sur un partage réseaux j'ai le message : "Cette action ne peut pas être réalisée car le dossier ou l'un des fichiers est ouvert dans un autre programme" ), j'ai donc fait la manipulation de "Bricoleur" qui était de créer une entrée dans le registre.

    Cela ne donne rien j'ai toujours le même problème qui commence a vraiment être ennuyant, avez vous une solution svp ???

    Le support en ligne microsoft n'a pas su me répondre.

    Cdt.

    jeudi 17 mars 2011 09:45
  • Bonsoir à tous,

     voulez-vous regarder ici:

    http://forum.wegotserved.com/index.php/topic/13542-renaming-moving-filesfolders-takes-2-minutes-before-starting/

    ou les lecteurs:

    - Barracuda 7200.11

    -  Western digital green power series.

    Sont mis en cause.

    Et pour ceux qui désirent effacer les dossiers-->

    this small workaround for the folder delete problem.

    Run gpedit.msc.

    Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    Quelques explications sur les lecteurs, ici:

    http://www.silentpcreview.com/Terabyte_Drive_Fix

     

    Support Western:

    http://support.wdc.c...sid=114&lang=en 

     

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT
    jeudi 17 mars 2011 13:14
  • Bonjour à tous,

     

    on a rencontré ce problème chez nous, et ça venait des fonctions de prévisualisation de l'explorateur windows (les petites infos dans la barre du bas qui indiquent la taille du fichier, le nom de l'auteur etc..... et la prévisualisation des fichiers)

    après 2 reinstall de serveur et de multiples tests, mon collègue, (gloire à toi OH grand gourou !!) a trouvé cette solution qui semble fonctionner... en fait il faut revenir à un affichage simple dans les options de l'explorateur.. c'est tout !!

     

    en espérant que ça vous aide....

     

    Cdlt.

    Thibaud

    • Proposé comme réponse Bricoleur vendredi 20 mai 2011 18:39
    • Marqué comme réponse Teodora Sharkova lundi 8 décembre 2014 12:02
    mardi 22 mars 2011 13:48
  • Bonjour,

    Nous avons exactement le même souci avec des stations en Windows 7 64 bits et un serveur de fichiers sous Windows 2003.

     

    Bonjour à tous,

     

    on a rencontré ce problème chez nous, et ça venait des fonctions de prévisualisation de l'explorateur windows (les petites infos dans la barre du bas qui indiquent la taille du fichier, le nom de l'auteur etc..... et la prévisualisation des fichiers)

    après 2 reinstall de serveur et de multiples tests, mon collègue, (gloire à toi OH grand gourou !!) a trouvé cette solution qui semble fonctionner... en fait il faut revenir à un affichage simple dans les options de l'explorateur.. c'est tout !!

     

    en espérant que ça vous aide....

     

    Cdlt.

    Thibaud

    Que veux-tu dire par revenir à un affichage simple?

    d'avance merci

    mercredi 6 avril 2011 09:24
  • j'avais le même problème depuis que je suis sur Windows 7
    j'ai trouvé qu'en désinstallant le programme winlocker,

    tout redevient normal

    dimanche 10 avril 2011 13:42
  • qqun à mise jour son serveur 2008R2 avec le SP1 ainsi que les clients Seven avec le SP1 ?

    Si oui, cela a t'il résolu ce problème ?

     

    Merci ;)

    jeudi 14 avril 2011 15:54
  • Pour reprendre la solution de Thibaud, on peut effectivement tout simplement désactiver l'affichage du "volet de détails" en bas de la fenêtre de l'explorateur.

    Pour cela, dans Organiser >> Disposition, décocher "Volet des détails".

    Cela règle définitivement le problème. Merci à Thibaud et son collègue ;)

    vendredi 20 mai 2011 15:39
  • Je re-up le post car celà ne resoud pas complètement le problème.

    Je ne comprend pas pourquoi personne ne s'en plaint. J'ai manqué une mise à jour quelque part?

    effectivement, désactiver le "volet des détails" règle provisoirement le problème. Mais dans mon cas, je suis entrain d'assainir mon HDD. J'ai besoin de ce volet pour ne pas avoir à ouvrir chaque fichier avant de le supprimer ou de le garder.

    Il n'y a pas d'autres solution? C'est vrai que même au temps de XP on pouvait très bien utiliser l'aperçu rapide dans l'exporateur. Et il est vraiment utile quand on s'y habitue.

     

    Merci.

    lundi 28 novembre 2011 16:56
  • Merci Thibault. ça dépanne bien !

    ça m'embête de ne pas voir le volet des détails. C'est contraignant ! mais bon, je peux finalement déplacer, supprimer les fichiers. S'il n'y a pas mieux, j'en suis contente.

    Le programe "Unlocker" parfois fait des bizzareries. Je m'en sers plus.

    mercredi 29 février 2012 10:57
  • LA SEULE SOLUTION EST BIEN CELLE CI :

    • Run gpedit.msc.
    • Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files


    lundi 5 mars 2012 03:20
  • Organiser >> Disposition, décocher "Volet des détails".


    • gpedit.msc.
    • Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    J'ai effectué les 2 opérations et pour l'instant le problème est résolu.

    Le fait de tuer le processus "explorer.exe" permettait de débloquer la situation, mais pas vraiment pratique.  Encore merci aux utilisateurs de ce forum.   

    ps: merci à microsoft de nous faciliter le travail tous les jours en ne répondant pas aux mails.


    • Proposé comme réponse lanaine35 mardi 17 avril 2012 09:24
    • Modifié lanaine35 mardi 17 avril 2012 09:25
    • Marqué comme réponse Teodora Sharkova lundi 8 décembre 2014 12:03
    mardi 17 avril 2012 09:21
  • Bonjour ,

    J'ai chercher pendant quelque nuit un moyen de supprimer un fichier qui me disais a chaque fous que j'essayais ,le même message que vous . Et j'ai découvert Unlocker ,et ... ca a marché !

    Essayer , en espérant que je vous aurais aider .

    Lastexil

    mardi 3 juillet 2012 13:23
  • MERCI! 

    Enfin une solution qui fonctionne à 100%.

    Ca va me faciliter la vie.

    vendredi 23 août 2013 09:20
  • Merci, ceci a parfaitement résolu mon problème!

    Bizarre tout de même que de tels fonctionnement soient toujours présents dans Windows 7, 8 , ...

    Alain

    samedi 30 novembre 2013 12:05
  • Même soucis.

    C'est l'explorateur de la machine cliente qui bloque.

    Malgré avoir désactivé la mise en cache des thumbs.db le problème est toujours là.

    -Alors qu'en utilisant un gestionnaire de fichier alternatif tel freecommander ou total commander le problème n'est plus.

    -Aussi l'ouverture du fichier à partir de l'invite de commande ne provoque pas de blocage.

    De même, dans les 2 cas l'ouverture du fichier est accéléré.

    vendredi 29 août 2014 09:27
  • PB résolu pour moi.

    Les fichiers en question sont des fichiers bureautique, le pb est lié a libreoffice et l'explorateur de windows.

    Pour le corriger il faut désinstaller le composant optionnel "Extension de Windows Explorer" de libreoffice.

    Bug signalé ici: http://nabble.documentfoundation.org/Mimo-2014-td4075584.html

    vendredi 29 août 2014 10:35