locked
PB WDS conserver le computername RRS feed

  • Question

  • Bonjour a tous,

    je suis chargé d'automatiser WDS pour un déploiement d'image toutes les fin de mois pour une dizaines de postes.

    Tout est automatisé...sauf le nom d machine!

    je dois lui dire de conserver le nom de la machine car les postes sont dans un domaines et sont deja en prod!

    donc si le nom du poste change tous es mois..je vous laisse imaginer l'anarchie au sein du service de la boite...lol

    coment puis-je proceder? existe-t-il une variable pour  dire de conserver le nom? genre %computername%?

    après de nombreuse et infructueuses recherche, je me tourne vers vous....

    please HELLPPP!!!!!


    Bastien
    lundi 17 octobre 2011 13:47

Réponses

Toutes les réponses

  • Bonjour,

    Tu peux utiliser la variable %MACHINENAME% dans ton fichier imageunattend.xml pour conserver le nom du PC dans Active Directory,

    Si tu fais un prestage computer, c'est la meme variable.


    Revue du Geek | Déployer Windows 7 avec MDT 2010
    lundi 17 octobre 2011 14:35
  • En complément: http://technet.microsoft.com/en-us/library/cc771508%28WS.10%29.aspx

    Tu trouveras les variables WDS que tu peux utiliser dans le fichier de réponse pour automatiser ton déploiement


    Revue du Geek | Déployer Windows 7 avec MDT 2010
    lundi 17 octobre 2011 14:40
  • OK merci de ta réponse rapide :)

    J'avais déja essayé, mais aucun résultat...enfin je vais retester maintenant que je sais que cela devrait fonctionner^^

    je te tiendrais au courant! surement demain car là la journée se termine ;)


    Bastien
    lundi 17 octobre 2011 14:40
  • Juste une petite question vu que tu a l'air assez calé sur le sujet :)

    Je le met dans quelle phase?

    actuellement je l'ai mise dans la phase 4 : specialize

    mais cela n'est pas pris en compte... l'ai-je mal placé? dois-je le mettre a un autre emplacement pour qu'il soit pris en compte?

    aussi je l'ai peut etre mis dans le mauvais xml???

    car j'en ai deux : AutoUnattend.xml pour le serveur

    et Unattend.xml pour l'image

    Actuellement, il est placé dans la phase 4 du XML pour le serveur! peut etre dois-je le mettre dans le xml de l'image???


    Bastien
    • Modifié Bastien08 lundi 17 octobre 2011 14:53
    lundi 17 octobre 2011 14:51
  • Tu dois le mettre dans le fichier de réponse de l'image pas du serveur.

    Phase Specialize | Microsoft-Windows-Shell-Setup

            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral"

    versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ProductKey>12345-12345-12345-12345-12345</ProductKey>
                <RegisteredOrganization></RegisteredOrganization>
                <RegisteredOwner></RegisteredOwner>
                <ComputerName>%MACHINENAME%</ComputerName>
            </component>

    Installation automatisée de Windows 7 avec WDS

    Jete un oeil à l'article, j'y ai mis 2 exemples de fichier de réponses.


    Revue du Geek | Déployer Windows 7 avec MDT 2010
    • Proposé comme réponse Florin Ciuca mardi 18 octobre 2011 14:42
    • Marqué comme réponse Bastien08 mardi 18 octobre 2011 14:47
    lundi 17 octobre 2011 15:01
  • OK OK merci bcp je vais voir a tout ça.

    je tien au courant surement demain dans l'après-midi

    Bonne soirée

    cdlt


    Bastien
    lundi 17 octobre 2011 15:12
  • Bon bah ça fonctionne :)

    merci beaucoup l'ami^^

    bonne continuation

     


    Bastien
    mardi 18 octobre 2011 14:48