none
[WS2019] Upgrade Exchange 2016 sur WS2008R2 vers 2019 non compatible RRS feed

  • Question

  • Bonjour à tous,

    je viens de migrer un serveur 2012R2 vers 2019 Datacenter, tout s'est bien passé, pas de message d'erreur.

    Le serveur est opérationnel, mais IMPOSSIBLE de saisir la cle de produit.

    Quand je clique sur "Dépanner" ren ne se passe, idem quand je clique sur "Modifier la clé de produit"

    Je ne peux pas non plus lancer PowerShell ...

    Merci de votre aide


    Arnaud BAROUX - Theradiag


    vendredi 13 mars 2020 06:53

Réponses

Toutes les réponses

  • Bonjour Arnaud BAROUX,

    Votre serveur 2012R2 était en édition Datacenter ou Standard?

    Merci d'avance pour votre retour.

    Cordialement,

    Biliana

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votreproblème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 13 mars 2020 14:35
  • DATACENTER of course, sinon je n'aurai pas pu le migrer ...

    Arnaud BAROUX - Theradiag

    vendredi 13 mars 2020 17:04
  • Salut,

    ton serveur à acces à internet ? tu peux ouvrir le cmd au moins ? sinon c'est un problème sur ton profil si tu peux meme pas lancer Powershell, essaies de l'ouvrir avec un autre compte.

    quand tu dis migrer tu parles de mis à niveau ?? de la meme machine ou une autre ? expliques nous un petit peu le scénario ça sera plus facile.

    slmgr /ipk "ta clé"

    vendredi 13 mars 2020 18:59
  • DATACENTER of course, sinon je n'aurai pas pu le migrer ...

    Arnaud BAROUX - Theradiag

    Biliana Mouzaphirova a raison, au contraire tu peux bien passer d'une version standard vers une version datacentre. 

    https://docs.microsoft.com/fr-fr/windows-server/get-started/supported-upgrade-paths

    nous ne connaissons pas comment tu as procédé à la migration ou mis à niveau, et si les bonnes pratiques été respectées. (comme le powershell ne se lance pas) je pense que tu as du louper quelque chose. 

    vendredi 13 mars 2020 19:07
  • Bonjour,

    désolé pour le delai de reponse, mais COVID oblige ...

    pour te repondre, c'est une upgrade in-situ, c'est a dire la meme VM … 

    setup executé à partir de l'ISO de 2019 DATACENTER sur un 2008R2 Datacenter aussi ...

    Pas de panique, j'ai finalement restauré ma VM en 2008R2 ... accessoirement cette VM est un serveur Exchange 2016.

    Je continue les tests sur d'autres machines moins critiques ...

    a l'occasion, je clonerai la VM Exchange pour tester sans déranger la production ...

    Merci à tous de vos retours.


    Arnaud BAROUX - Theradiag

    jeudi 19 mars 2020 14:08
  • Bonnes pratiques repectées, 

    pas compliqué puisque j'ai juste exécuter SETUP.EXE à partir d'un ISO 2019 Datacenter pour upgrader un 2008R2, tout en DATACENTER x64 FR, puis [Suivant][Suivant][Suivant] .....

    je resterai plus tard ...


    Arnaud BAROUX - Theradiag

    jeudi 19 mars 2020 14:10
  • rebonjour,

    et oui ce covid nous oblige à faire des concessions, pourvu que ça se termine vite et bien.

    pour te répondre les bonnes pratiques ce n'est pas du suivant suivant, mais des versions et exigences.

    si tu upgrades un DC en 2008 r2 en 2019 par exemple avec du suivant suivant.. tu risques de tout planter par la suite. (sinon ça sera d'etre l'administrateur systeme et pourquoi y a t-il des architectes infras et systemes, si tout le monde peut mettre un iso et faire suivant suivant :) )

    idem pour ton cas : (on ignore ta version d’exchange, mais y a des versions d'exchanges qui ne sont pas compatibles avec Server 2019 ) comme le montre ce tableau, et le lien ci-dessous.

    https://docs.microsoft.com/fr-fr/exchange/plan-and-deploy/supportability-matrix?view=exchserver-2019

    • Modifié M dakhama jeudi 19 mars 2020 14:23
    • Proposé comme réponse M dakhama jeudi 19 mars 2020 17:02
    jeudi 19 mars 2020 14:21
  • autant pour moi ...

    effectivement il semblerait qu'Exchange 2016 CU15 ne soit pas compatible avec Windows Server 2019 ...

    Donc je remballe !

    Merci beaucoup.


    Arnaud BAROUX - Theradiag

    jeudi 19 mars 2020 14:25
  • Pas de souci, nous sommes la pour ca, si tu peux changer le type de discussion en question et marquer comme résolu ca sera gentil.

    En souhaitant à tous bon courage dans cette épreuve.

    jeudi 19 mars 2020 15:32
  • euh … scuse, mais comment on marque comme résolu ?

    Arnaud BAROUX - Theradiag

    jeudi 19 mars 2020 15:52
  • C'est pas grave, change juste en haut le type de sujet : de discussion générale à question. Si tu n'arrives pas les modérateurs le feront.
    jeudi 19 mars 2020 15:56