none
FENETRE INFORMATION D'IDENTIFICATION MICROSOFT - outlook 2010 SP2 RRS feed

  • Question

  • Bonjour,

    LE problème :  fenêtres intempestive : INFORMATION D'IDENTIFICATION MICROSOFT.

    La hiérarchie client-serveur :

    - SBS/FOUNDATION 2008 ou sup avec EXCHANGE 2007 ou sup d'installé et de correctement configuré.

    - CLIENT WIN XP et WIN 7, MS OFFICE 2007 et 2010.

    au départ tout marche très bien jusqu'au jour ou microsoft nous trouve la gentillesse de sortir une mise à jour corrective...

    Je veux bien mais voila le nombre de mise à jour que je me trouve obligé de supprimer pour éviter les problèmes de blocage outlook (merci WSUS pour le gain de temps).

    OFFICE 2007 :

    - KB2687404 (installé x2)

    - KB2412171

    - KB2509470

    OFFICE 2010 :

    - KB 2553248 (installé x2)

    - KB 2687623 (installé x2)

    - KB 2597090

    C'est magique comme du jour au lendemain une mise à jour peux ne plus faire fonctionner un logiciel, ce n'est pas trop grave vu que ce ne sont que des correctifs mineur. Juste une perte de temps...

    Par contre Aujourd'hui je me rends compte que office 2010 Service Pack 2 vient de sortir et comme par magie une fichue fenêtre viens de s’afficher après la màj !!!

    Bon ça me fait moins rire car SP2 à désinstaller c'est :

    - Supprimer office - Redémarrer - Réinstaller office - redémarrer - mise a jour - redémarrer - mise à jours ... Je vous passe les détails et le nombres de machines sous exchange serveur (chui pas prêt de partir en vacances à cette allure ...).

    Vous comprendrez donc que c'est un peu rebutant. Si quelqu’un à une idée (j'ai déjà foir'fouillé pas mal de solution...)?

    Je suis à la recherche d'une idée, d'une solution ?

    D'avance merci :)




    • Modifié ekodante jeudi 25 juillet 2013 15:17
    jeudi 25 juillet 2013 14:01

Réponses

  • Bonjour,

    J'ai vérifié la liste des KB Outlook 2010, et elle ne semble pas avoir de lien avec la méthode d'authentification d'Outlook. Par contre lors de l'installation d'une KB, il arrive que celle ci reset certaines modifications antérieures.

    Plutôt que de tenter de désinstaller les KB Outlook, il serait plus judicieux de vérifier pourquoi vous avez une fenêtre d'authentification.

    -> Vous utilisez bien un compte Exchange, et pas un compte POP ou IMAP?

    -> Si vous créez un nouveau profil vierge sur un poste, vous avez quand même ce popup?

    -> celui ci se lance à la connexion ou de façon pseudo aléatoire?

    Pouvez-vous lancer cette cmdlet de diagnostique :

    test-outlookwebservices | fl
    

    et poster le résultat ici (en masquant si vous le souhaitez les noms de domaine)


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    • Marqué comme réponse ekodante mardi 20 août 2013 10:09
    mardi 30 juillet 2013 09:00
    Modérateur
  • La cmdlet est a lancer sur le serveur Exchange

    Autre piste, lié au smartcard logon : dans la console IIS, sur chaque répertoire virtuel, vérifier dans la partie Sécurité SSL que l'option "Client certificate" est sur Ignore (et pas require).

    De même, est-ce que vous avez un internalURL positionné sur les différents VDir, et si oui, est-ce une URL qui renvoi vers un pare-feu, routeur, proxy ou autre?

    Pour la partie RPC over HTTP, elle est activée par défaut sur Exchange, vous pouvez la désactiver de différentes façons selon que la désactivation est globale ou spécifique à des personnes.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    mardi 30 juillet 2013 09:34
    Modérateur
  • CLient certificat coché sur accepté : il faut le mettre sur ignore

    Eventuellement faire un iisreset /noforce (mais cela va couper la partie Web)

    Je pense que cela devrait résoudre le problème des popup (au moins en partie), la partie IE ne devrait plus demandé d'authentification.

    Et tu peux relancer la cmdlet pour vérifier les paramètres.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    mardi 30 juillet 2013 10:13
    Modérateur

Toutes les réponses

  • Bonjour,

    Désinstaller les correctifs n'est pas une solution. Vous devriez regarder dans les journaux d'évenement d'Outlook pourquoi une demande d'authentification est nécessaire.

    Essayer ceci pour troobleshooter : http://demazter.wordpress.com/2010/02/09/outlook-continually-prompting-for-username-and-password-2/

    jeudi 25 juillet 2013 14:17
  • Bonjour,

    Merci de votre réponse mais les journaux Windows sont mes premiers amis :) et aucunes traces ... malheureusement!

    Pour ces vieux correctifs cela ne m'importe peu puisque je les ai bloqué...

    Mais pour le SP2 la ça me gène un peu :/ point de vu sécurité et correctif bug c'est pas top ... mais si ça m'en rajoute ça me met mal a l'aise.

    Je me penche sur lien et vous tiens au courant au plus tard demain aprem. Je dois mettre de coté ce problème.

    Pour info j'ai vite fais un tour sur le site et peux déjà répondre à certaine étape :

    Exchange 2007 Service Pack : PASSED :) aucun changement.

    Autodiscover : PASSED correctement configuré.

    J'ai mis en ligne une petite image du popup indésirable ( CF : Pas de demande de carte à puce ou de mot de passe come les correctif :))

    Merci à demain.

    jeudi 25 juillet 2013 15:13
  • J'ai eu le problème sur un SBS2011 : à l'époque j'ai résolu le soucis en adaptant le driver de la carte réseau (matériel Dell Optiplex). Regardez aussi par là !
    • Modifié LoicVeirman jeudi 25 juillet 2013 20:38 fautograf
    • Proposé comme réponse LoicVeirman mardi 30 juillet 2013 07:33
    jeudi 25 juillet 2013 20:37
  • Bonjour

    sur mon infra surtout les laptop ( déconnexion et reconnexion) la fenêtre d’authentification après chaque matin ou sur des pc ou nous avons une perte de réseau

    la solution été de désactivé http sur outlook anywhere vu qu’il n’est pas activé sur notre infra maybe je ne sais pas si c'est le meme pb

    voila


    Partager c'est avancer : Votez!SVP

    • Proposé comme réponse LoicVeirman mardi 30 juillet 2013 07:33
    lundi 29 juillet 2013 10:25
  • Bonjour,

    Désolé de ne pas avoir pu répondre plus tôt, les vacances et son manques d'effectif me font un peu courir. En plus des orages qui cassent tout sur leur passage...

    @ LV.Bulldog : J'ai vérifié la configuration de mon serveur, comme je le répète tout est bien configuré. j'ai vérifié avec un autre admin réseau aucun problème tout fonctionne bien sauf quand MS sortent des mise à jours qui font buger les clients EXCH.

    Adapter le driver de ta carte réseau ??? Qu'entends tu par la ? veux-tu que je vérifie la config de ma carte réseau ? que je mette à jour firmware et driver ? (J'ai principalement du HP PROLIANT)

    @Nabil-IT : Les client interne n'ont pas le RCP/HTTP d'activé dans leur client outlook (suffi de juste bien régler son DNS...), je ne l'active que pour les portables qui sortent des bureaux. de ce point de vu la je n'ai pas de problème. Par contre tu as raison sur un point! typiquement les mises à jours que j'ai décrites dans mon article plus haut (kb2687... et autres) activent automatiquement le RCP/HTTP et fait buger l'identification client ex! Et cela même si je le désactive (à chaque lancement d'outlook il se réactive, si c'est pas du bug de config MS ça...)

    D'avance merci de vos réponse :)

    PS: Désactivation du SP2 dans WSUS ça sauve une vie ;)

    mardi 30 juillet 2013 08:07
  • Bonjour,

    J'ai vérifié la liste des KB Outlook 2010, et elle ne semble pas avoir de lien avec la méthode d'authentification d'Outlook. Par contre lors de l'installation d'une KB, il arrive que celle ci reset certaines modifications antérieures.

    Plutôt que de tenter de désinstaller les KB Outlook, il serait plus judicieux de vérifier pourquoi vous avez une fenêtre d'authentification.

    -> Vous utilisez bien un compte Exchange, et pas un compte POP ou IMAP?

    -> Si vous créez un nouveau profil vierge sur un poste, vous avez quand même ce popup?

    -> celui ci se lance à la connexion ou de façon pseudo aléatoire?

    Pouvez-vous lancer cette cmdlet de diagnostique :

    test-outlookwebservices | fl
    

    et poster le résultat ici (en masquant si vous le souhaitez les noms de domaine)


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    • Marqué comme réponse ekodante mardi 20 août 2013 10:09
    mardi 30 juillet 2013 09:00
    Modérateur
  • bonjourBruceJDC

    merci pour la commande :)

    slts


    Partager c'est avancer : Votez!SVP

    mardi 30 juillet 2013 09:06
  • "Adapter le driver de ta carte réseau ??? Qu'entends tu par la ? veux-tu que je vérifie la config de ma carte réseau ? que je mette à jour firmware et driver ? (J'ai principalement du HP PROLIANT)"

    Oui, mettre à jour les firmware et driver, voir même essayer un downgrade (c'est ce que j'ai du faire sur les optiplex Dell).

    mardi 30 juillet 2013 09:07
  • Bonjour BRUCEJDC,

    -> Vous utilisez bien un compte Exchange, et pas un compte POP ou IMAP?

    OUI PROFIL EXCHANGE PAS D'IMAP ou de POP (sauf pour les users qui ont un MAC avec juste appli mail... mais ça c'est une autre histoire, par défaut les services sont désactivé sur nos servuer par inutilisation...)

    -> Si vous créez un nouveau profil vierge sur un poste, vous avez quand même ce popup?

    Création d'un profil neuf déjà testé : même résultat.

    -> celui ci se lance à la connexion ou de façon pseudo aléatoire?

    Je ne comprends pas trop ce que tu veux dire par là mais en gros les symptômes sont toujours les mêmes :

    -Lancement d'outlook Connexion à exchange ok-Attentent de 5seconde à 1min et les messages apparaissent suivant la mise à jour :

    *Carte à puce

    *Authentification à remote.....com (RCP/http alors qu'il n'etait pas config avant désactivation de l'option mais se réactive toute seule après redemarrage d'outlook)

    *Connexion à a....@domaine.com (avec la SP2 office 2010)

    Je vais voir pour installer le SP2 sur un poste de test et lancer la cmdlet et vous envoie le raport.

    Cdlt

    mardi 30 juillet 2013 09:22
  • vous pourriez peut-être gagner du temps en lançant une capture de tram réseau avec wireshark ou Network Monitor sur un des postes ayant le soucis : nous devrions pouvoir récupérer les paquets et voir les communication d'authentification partant depuis le client et résultant en un échec.

    mardi 30 juillet 2013 09:26
  • La cmdlet est a lancer sur le serveur Exchange

    Autre piste, lié au smartcard logon : dans la console IIS, sur chaque répertoire virtuel, vérifier dans la partie Sécurité SSL que l'option "Client certificate" est sur Ignore (et pas require).

    De même, est-ce que vous avez un internalURL positionné sur les différents VDir, et si oui, est-ce une URL qui renvoi vers un pare-feu, routeur, proxy ou autre?

    Pour la partie RPC over HTTP, elle est activée par défaut sur Exchange, vous pouvez la désactiver de différentes façons selon que la désactivation est globale ou spécifique à des personnes.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    mardi 30 juillet 2013 09:34
    Modérateur
  • @BRUCE JDC :

    Voici la commande executé :

    [PS] C:\Users\admin\Desktop>test-outlookwebservices | fl


    Id      : 1003
    Type    : Information
    Message : Test imminent d'AutoDiscover avec l'adresse de messagerie admin@cabin
              et-mer.net.

    Id      : 1007
    Type    : Information
    Message : Serveur de test SRVEX.merex.local avec le nom publié https://remo
              te.cabinet-mer.net/EWS/Exchange.asmx & https://remote.cabinet-mer.net/EWS/Exchange.asmx.

    Id      : 1019
    Type    : Information
    Message : Point de connexion de service AutoDiscover valide trouvé. L'URL d'Aut
              oDiscover sur cet objet est https://remote.cabinet-mer.net/Autodi
              scover/Autodiscover.xml.

    Id      : 1013
    Type    : Error
    Message : Réception de l'erreur Le serveur distant a retourné une erreur : (401
              ) Non autorisé. lors du contact de https://remote.cabinet-mer.net
              /Autodiscover/Autodiscover.xml.

    Id      : 1006
    Type    : Error
    Message : Impossible de contacter le service de découverte automatique.



    [PS] C:\Users\admin\Desktop>

    mardi 30 juillet 2013 09:37
  • oui cmdlet se lance sur pwshell. Je réinstalle un SP2 sur un poste pour refaire des tests. :)

    Désolé je m'exprime mal des fois, et ne suis pas très précis sur certaine chose (mais j'essaie ;))

    • Modifié ekodante mardi 30 juillet 2013 09:40 modif
    mardi 30 juillet 2013 09:39
  • vous pourriez peut-être gagner du temps en lançant une capture de tram réseau avec wireshark ou Network Monitor sur un des postes ayant le soucis : nous devrions pouvoir récupérer les paquets et voir les communication d'authentification partant depuis le client et résultant en un échec.

    Laisser tombez la capture, la commande de JDC donne l'erreur qui nous aurait également été retourné.

    mardi 30 juillet 2013 09:42
  • Et bien voila déjà un problème à résoudre :) PS le post du dessus est partie tronqué, il y a d'autres informations.

    Le SCP pointe sur https://remote.xxx.net/Autodiscover/Autodiscover.xml

    Non autorisé : essayer de voir les méthodes d'authentification du VDir Autodiscover, la partie certificat client, certificat serveur etc. Idem si vous avez un reverse proxy ou un parefeu.

    Pour info vous pouvez entrer l'URL directement dans IE, le retour "normal" est une page error 600 invalid request.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    mardi 30 juillet 2013 09:43
    Modérateur
  • Alors sur les Vdir les racines sont toutes sur ignoré par contre sur autodiscover tu as raison j'ai un cert SSL + CLient certificat coché sur accepté.

    ---------------------------------------------------------

    Pour les la methode auth sur l'autodiscover :

    ANON / DIGEST / PAR FORMULAIRE / id ASP .NET: desactivé

    DE BASE / WINDOWS : activé

    Pas de reverse proxy, parfeu activé.

    Certi serveur ? Tu veux que j'aille vérifier quoi ?

    Pour l'url dans IE j'ai une joli demande d'identifiaction. :) à remote.XXX.net


    • Modifié ekodante mardi 30 juillet 2013 10:16 modif
    mardi 30 juillet 2013 10:08
  • CLient certificat coché sur accepté : il faut le mettre sur ignore

    Eventuellement faire un iisreset /noforce (mais cela va couper la partie Web)

    Je pense que cela devrait résoudre le problème des popup (au moins en partie), la partie IE ne devrait plus demandé d'authentification.

    Et tu peux relancer la cmdlet pour vérifier les paramètres.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    mardi 30 juillet 2013 10:13
    Modérateur
  • De même, est-ce que vous avez un internalURL positionné sur les différents VDir, et si oui, est-ce une URL qui renvoi vers un pare-feu, routeur, proxy ou autre?

    Je ne vois pense pas avoir d'internalURL ou puis-je le vérifier ?

    Pour la partie RPC over HTTP, elle est activée par défaut sur Exchange, vous pouvez la désactiver de différentes façons selon que la désactivation est globale ou spécifique à des personnes.

    Je ne préfère pas faire de configuration spécifique. A mon avis ça dois marcher sans avoir à faire ça .

    mardi 30 juillet 2013 10:13
  • le plus simple est déjà de corriger la partie autodiscover, refaire le test-outlookwebservices et vérifier si cela corrige votre problème.

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 30 juillet 2013 10:25
    Modérateur
  • Haaaaa ça semble être pas mal, je m'explique.

    Premièrement l'erreur avec la cmdlet est toujours apparente... Mais bon ça semble être moins grave que ça en parait ;). (Le site demande toujours l'identification)

    Deuxièmement, le problème de message d'identification avec la SP2 n'apparait plus :) Je viens de tester chez deux de mes clients :)

    Je vais voir si ce réglage règle le problème avec les autres màj sur les nouveau poste qu'on installera.

    En tout cas un GRAND MERCI à tous pour ce temps passé ;)

    mardi 30 juillet 2013 13:02
  • Tenez nous au courant si cela fonctionne correctement. Et merci de signaler les posts qui vous ont aidé via "Marquer comme réponse" ou un vote :)

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 30 juillet 2013 13:16
    Modérateur
  • Pas de problème, j'attends quelques jours pour voir les retombés de cette action et je marquerai les messages qui ont résolu le problème ;)
    mardi 30 juillet 2013 13:21
  • Bonjour,

    Je me joins à cette discussion puisque je suis dans le même cas depuis quelques jours, suite à la mise à jour du SP2 d'office 2010.

    Ma config est la même :

    Office 2010 - Exchange 2007 - SBS 2008

    Paradoxalement, je n'ai pas d'erreur lorsque je fais le cmdlet. J'ai cherché une piste vainement depuis 2 jours, sans le moindre résultat.

    Quand il s'agit d'une petite kb spécifique outlook qui est en cause, je désinstalle, mais là, c'est le SP2 d'office tout entier, je préfère le laisser.

    Paradoxalement, lorsque la fenêtre "connexion à ...." s'affiche et que je la ferme, j'ai le message "mot de passe requis" en bas d'outlook.

    Mais, et c'est là le paradoxe, je reçois toujours mes emails, je peux toujours en envoyer, etc. Si j'envoie un email, outlook se reconnecte automatiquement à exchange. C'est à n'y rien comprendre.

    Une idée ?

    mercredi 31 juillet 2013 14:32
  • Bonjour,

    Quand il s'agit d'une petite kb spécifique outlook qui est en cause, je désinstalle, mais là, c'est le SP2 d'office tout entier, je préfère le laisser.

    -> TOUT A FAIT D'ACCORD c'est pour ça que j'ai sollicité des gens sur ce forum!!!

    Paradoxalement, lorsque la fenêtre "connexion à ...." s'affiche et que je la ferme, j'ai le message "mot de passe requis" en bas d'outlook.

    Mais, et c'est là le paradoxe, je reçois toujours mes emails, je peux toujours en envoyer, etc. Si j'envoie un email, outlook se reconnecte automatiquement à exchange. C'est à n'y rien comprendre.

    -> J'AI EU EXACTEMENT LE MÊME SYMPTÔME, fermeture du message et la demande de mot de passe à la place de "connecté à MS exchange" mais pourtant les mails arrivaient par rapport au autre KB qui bloque tout trafic avec le serveur.

    Une idée ?

    OUI, As-tu vérifié dans le manager IIS -> Web application -> autodiscover -> client certificat soit sur ignore et non activé comme moi j'ai pu l'avoir ?

    Vérifie tes Vdir comme me l'a conseillé BRUCEJDC

    Cordialement

    mercredi 31 juillet 2013 14:56
  • Autodiscover est paramétré de la façon suivante :

    Exiger SSL : Non coché.

    Certificat clients : ignorer

    Mes Vdir fonctionnement très bien depuis toujours, pas de souci là-dessus, et le DNS pointe impeccablement (vérifié notamment avec l'OAB)

    mercredi 31 juillet 2013 15:17
  • Bon, je viens de voir qu'il manquait les rollup 8/9/10 d'exchange SP3.

    J'ai validé les MAJ, on verra demain.

    mercredi 31 juillet 2013 15:21
  • Bon, les rollup sont à jour, pas de changement, le problème est toujours là.
    • Proposé comme réponse pfm79 dimanche 25 août 2013 18:45
    jeudi 1 août 2013 06:07
  • Bon, j'ai changé les réglages dans IIS :

    Autodiscover : SSL non exigé - Ignorer certificat
    EWS : Exiger SSL 128 bits - Ignorer certificat
    Exchange : Exiger SSL 128 bits - Ignorer certificat
    Exchweb : Exiger SSL 128 bits - Ignorer certificat
    OWA : Exiger SSL 128 bits - Ignorer certificat
    Remote : Exiger SSL 128 bits - Ignorer certificat
    RPC : SSL non exigé - Ignorer certificat
    RPCWithCert : Exiger SSL 128 bits - Ignorer certificat

    A priori, cela semble fonctionner, je n'ai plus eu d'alerte depuis plus de 3 heures.

    • Proposé comme réponse pfm79 dimanche 25 août 2013 18:45
    jeudi 1 août 2013 11:51
  • Bonjour PFM79

    merci pour le retour, j'aimerais savoir svp le menu de ews, exchange sur la console iis avec imprime ecran pour info svp

    je trouve bien ssl , rpc et rpc withcert plus owa mais les autres nada

    merci d'avance


    Partager c'est avancer : Votez!SVP

    jeudi 1 août 2013 12:01
  • Désolé, je suis en congé, j'ai délégué à quelqu'un d'autre.

    Je vous fais ça au retour.

    lundi 5 août 2013 21:54
  • Désolé, je ne parviens pas à poster le printscreen.

    J'ai le message suivant : "Body text cannot contain images or links until we are able to verify your account", et je ne trouve pas de message d'activation...

    mardi 6 août 2013 15:40
  • Voici le printscreen

    mercredi 7 août 2013 06:55
  • Bonjour,

    J'ai cité les messages qui m'ont apporté de l'aide.

    PFM79, as tu eu réponse à ton problème?

    Cordialement


    Ps: Ça sent les vacances qui sont passées par là :)
    • Modifié ekodante mardi 20 août 2013 10:14 ttttt
    mardi 20 août 2013 10:12
  • Ouep, de mon côté c'est réglé.

    Mise à jour forcée des roll-up d'exchange, puis config de IIS comme indiqué plus haut.

    dimanche 25 août 2013 18:46