locked
Migration AD Windows 2003 R2 SP2 vers Windows 2008 R2 - DNS-Server-Service - Event ID 4013 RRS feed

  • Question

  • Bonjour à tous,

    Je me permets de poser une question déjà posée (voir ci-dessous) mais sans réponses à l'époque.

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008fr/thread/b2725dbb-4f24-44a5-89ab-85f7094694d7

    Infra sous VMware v5.0

    Domaine : xxxx.INTRA

    Anciens serveurs AD : 2 serveurs sous Windows 2003 R2 SP2 x64 (SRV2003-AD1 et SRV2003-AD2)

    Ajout des 2 nouveaux DC sous Windows 2008 R2 (SRV2008-AD1 et SRV2008-AD2),

    Rôles FSMO : transfert de SRV2003-AD1 vers SRV2008-AD1 (aucun soucis)

    GC : SRV2008-AD2

    Suppression de l’AD de SRV2003-AD2 (aucun soucis avec DCPROMO, pas besoin d'utiliser NTDSUTIL) + reboot

    La réplication AD dans Sites et Services se passe sans soucis.

    La réplication NTFRS de NETLOGON se passe sans soucis.

    DNS

    SRV2008-AD1 : DNS1 à SRV2008-AD1 et DNS2 à SRV2008-AD2

    SRV2008-AD2 : DNS1 à SRV2008-AD2 et DNS2 à SRV2008-AD1

    SRV2003-AD1 : DNS1 à SRV2008-AD1 et DNS2 à SRV2008-AD2

    Au redémarrage de SRV2008-AD1 seul, le serveur ne retrouve pas le domaine "xxxxx.INTRA"

    SOLUTION : le SRV2008-AD1 trouve le domaine uniquement lorsque le serveur SRV2003-AD1 est en ligne.

    L’outil Microsoft IT Environnement Health Scanner ne trouve rien lorsqu’il est lancé sur les 3 serveurs.

    C'est la première fois que j'ai ce cas. Si vous avez des pistes je suis preneur, nous devons déménager en Septembre et l'idée d'arrêter l'archi sous WMware me donne des sueurs froides !!!

    Merci d'avance

    FP


    FP

    lundi 17 juin 2013 13:20

Réponses

  • Bonsoir,

    La seule solution que j'ai trouvé est de :

    1. VMware, vcenter, désactiver la carte réseau du DC FSMO

    2. Démarrer le DC FSMO

    3. Une fois démarré, ouvrir une session et bien vérifier que les consoles (DNS, Users et Computers AD, Domain & approbation) fonctionnent. Ce qui est mon cas

    4. VMware, vcenter, réactiver la carte réseau du DC FSMO

    5. Démarrer les autres DC

    Voilà j'espère que cette solution vous dépannera

    FP


    FP

    lundi 2 septembre 2013 18:27

Toutes les réponses

  • Bonjour

    est ce que les nouveaux dc sont GC? aussi sur les cartes reseaux, la config du DNS est ce qu'elle est en place ( primaire et secondiare , il point sur dc 2003 ou 2008)?

    le niveau fonctionnel aussi ?

    slts


    Partager c'est avancer : Votez!SVP


    • Modifié Nabil-IT mardi 18 juin 2013 12:48 add question
    mardi 18 juin 2013 12:46
  • Au redémarrage de SRV2008-AD1 seul, le serveur ne retrouve pas le domaine "xxxxx.INTRA"

    Configuration IP ? Quel DNS est configuré est dans quel ordre ?

    repadmin /replsummary  et /showrepl pour être sur que la réplication AD fonctionne.

    mardi 18 juin 2013 13:20
  • Bonjour,

    Merci pour la réponse.

    J'ai uniquement mis SRV2008-AD2 et SRV2003-AD1 comme GC puisque SRV2008-AD1 à le rôle PDC.

    D'après Microsoft, c'est la configuration recommandée

    Qu'en penses-tu ?

    FP


    FP

    mercredi 19 juin 2013 08:11
  • Bonjour,

    Merci pour la réponse.

    Comme je le disais :

    SRV2008-AD1 : DNS1 à SRV2008-AD1 et DNS2 à SRV2008-AD2

    SRV2008-AD2 : DNS1 à SRV2008-AD2 et DNS2 à SRV2008-AD1

    SRV2003-AD1 : DNS1 à SRV2008-AD1 et DNS2 à SRV2008-AD2

    Tes commandes repadmin ne renvoient aucune erreur. Comme je le disais quand tout mes serveurs sont connectés, il n'y a aucun soucis de réplication (AD et NTFRS). Très bizarre.

    Si tu as d'autres pistes. Merci d'avance

    FP


    FP

    mercredi 19 juin 2013 08:15
  • Si c'est une forêt mono domaine on met le GC sur tout les DC, maintenant la facon dont tu la fais ne doit pas générer d'erreur.

    http://pbarth67.free.fr/?q=node/78

    Pourquoi le serveur SRV2003-AD1 n'est pas dans sa liste de serveur DNS ?

    Les zones DNS sont bien intégrés AD ?

    Met en 3ème position sur tous les DC tu l'enleveras à la suppression du 2003.

    si tu fais un nslookup sur chaque DC il arrive à résoudre le nom FQDN des autres ?

    Ton nom de domaine a juste .intra et pas .intra.local au autre chose ...

    LEs sufixes en 1 partie c'est pas très beau.

    http://pbarth67.free.fr/?q=node/4


    mercredi 19 juin 2013 09:29
  • Bonjour

    concernant la config dns sur les cartes reseaux ? qui est en premiere position ?

    il faut mettre celui du DC 2008 en Pemier

    slts


    Partager c'est avancer : Votez!SVP

    • Proposé comme réponse Nabil-IT mardi 3 septembre 2013 14:26
    mercredi 19 juin 2013 10:11
  • Bonsoir,

    merci pour toutes les pistes.

    Pour le GC, au début les 3 serveurs l'étaient. Je l'ai enlevé du serveur PDC pensant que cela aurait pu être une source d'erreur. Donc à priori, le problème ne vient pas de la.

    Pour le SRV2003-AD1 en 3eme position, je vais le rajouter. Malheureusement, je pourrais faire de test avant samedi prochain, il y a de la prod sur SRV2003-AD1 (c'est pour ça que je voudrais enlever l'AD).

    INTRA, j'ai déjà monté des domaines avec ce suffixe. Je ne pense pas que ce soit si problématique. Je note ta remarque et ton site pour les prochains.

    Je te tiens au courant

    FP


    FP

    mercredi 19 juin 2013 15:57
  • Bonsoir,

    Merci, pour le retour.

    Ce que j'ai mis n'est pas bon ???

    SRV2008-AD1 : DNS1 à SRV2008-AD1 et DNS2 à SRV2008-AD2

    SRV2008-AD2 : DNS1 à SRV2008-AD2 et DNS2 à SRV2008-AD1

    SRV2003-AD1 : DNS1 à SRV2008-AD1 et DNS2 à SRV2008-AD2

    Je vais tenir compte de la remarque de PBARTH67 en rajoutant SRV2003-AD1 en 3eme position

    FP


    FP

    mercredi 19 juin 2013 15:59
  • Ne laisser pas vos DC sans réplication trop lontemps, la réplication AD et l'état de santé de son domaine est primordiale en prod ...

    Il n'y a pas de risques à ajouter le 3ème DC, et à faire un test de nslookup sur chaque DC pour vérifier s'il retrouve les autres ...

    Si la résolution ne marche pas la prod pourrait être rapidement perturbé.

    mercredi 19 juin 2013 16:01
  • Bonsoir,

    Désolé pour les retours d'info découpés, la vie continue ...

    J'ai le constat aujourd'hui, vraiment très bizarre ...

    Lorsque je coupe le réseau sur SRV2008-AD1 (FSMO, GC, DNS, AD), le serveur retrouve le domaine sans soucis (console DNS, users and computers AD, etc ...)

    Lorsque je laisse le réseau sur SRV2008-AD1 et que je coupe le réseau sur SRV2003-AD1 et SRV2008-AD2, c'est là qu'il ne trouve pas le domaine.

    Merci de vos retours

    FP


    FP

    lundi 24 juin 2013 18:42
  • C'est à dire il ne trouve pas le domaine ?

    Ce n'est pas votre console qui se connecte au serveur distant plutôt que local.

    PAr exemple la console GPMC se connecte par défaut sur le DC qui est emulateur PDC de mémoire, si celui ci n'est pas dispo il faut manuellement sélectionner un autre DC.

    lundi 24 juin 2013 18:47
  • Bonsoir,

    Effectivement, dès que je coupe le réseau des serveurs SRV2003-AD1 et SRV2008-AD2 et que je redémarre SRV2008-AD1 (FSMO, GC, DNS, AD) avec le réseau, celui-ci ne trouve pas le domaine avec les consoles locales DNS, Users and Computers AD, Domaine et approbations, etc ...

    Dès que je remets le réseau sur ces serveurs et que le reboot SRV2008-AD1, plus de soucis ...

    Première fois que je tombe sur ce cas

    FP


    FP

    lundi 24 juin 2013 19:16
  • Et si depuis la console vous essayer l'option changer de DC et vous sélectionner le DC local ?

    mardi 25 juin 2013 12:47
  • bonjour

    je commence a me perdre dans votre pb :(

    je vous prie de deplacer all fsmo role sur les nouveaux dc

    faire une bone config des cartes reseaux sur l'enssembles des nouveaux dc et old dc ! il faut que all dc poinent sur le nouveau DC 2008

    Merci de nous informer ;) il faut pas oublié de patienter des fois pb de commnication dans les lab virtuel ( et verifier aussi les configs network de vos machines de tests )

    slts


    Partager c'est avancer : Votez!SVP

    mardi 25 juin 2013 13:06
  • Bonsoir,

    merci pour votre aide

    Déjà fait. ça ne change rien.

    FP


    FP

    mardi 25 juin 2013 20:02
  • Bonsoir,

    Merci à tous pour vos pistes. Le problème persiste.

    Je vais demander à notre prestataire s'il ne peut pas escalader le pb chez Microsoft.

    FP


    FP

    mardi 25 juin 2013 20:03
  • Bonjour

    est ce que vous avez verifier les entrées sur la config du dns et aussi le SOA COMME indiqué sur l'imprime ecran et verifier sur les config du reverse dns est ce que les nouveaux dc sont créer, et sur les proprietes du dns est ce que les name servers sont tous ajoutés autan-que server dns de dans

    verifies aussi ipv6 a desactivé svp ;)

    j'espre que cela pourra vous aidez


    Partager c'est avancer : Votez!SVP

    • Proposé comme réponse Nabil-IT mardi 3 septembre 2013 14:26
    mercredi 26 juin 2013 06:52
  • Vous êtes certain que quand vous lancer une console comme utilisateur et ordinateur elle n'a pas été configuré pour se connecter sur un autre DC, dans ce cas il est normal que si ce serveur est éteint la console ne fonctionne pas. Il suffirait de se connecter sur la bonne console.

    C'est le cas par exemple de la console de stratégie de groupe qui par défaut ne s'ouvre pas sur lui même mais sur l'emulateur PDC.

    mercredi 26 juin 2013 10:31
  • Bonsoir,

    Tout est bon pour le DNS par rapport à ce que tu mets.

    La commande "dnslint /ad srv2008-dc1 /s srv2008-dc1" ne renvoit aucune erreur ainsi que l'outil "Microsoft IT Environment Health Scanner".

    Par contre pour IPv6, je ne sais plus quoi penser, j'ai tous les avis "activer" / "désactiver". J'ai cru comprendre que désactiver IPv6 sur la carte réseau ne suffit pas.

    Merci pour plus de détails

    FP


    FP

    mercredi 26 juin 2013 19:42
  • Bonsoir,

    D'ailleurs ma console MMC ne se lançait pas car trop d'outils étaient plantés. En lançant juste la console "Utilisateurs et Ordinateurs AD" me renvoit rien assez "rapidement".

    Le serveur SRV2008-AD1 est FSMO, il a tout !!!

    Je remonte mes 3 serveurs sur un ESXi demain et essaie d'enlever l'AD SRV2003-AD1. Je verrais ce que ça donne sur SRV2008-AD1 au redémarrage et vous tient au courant

    FP


    FP

    mercredi 26 juin 2013 19:45
  • Bonjour

    J'ai le meme probleme que vous. A priori cela vient de la première synchro qu démarrage du DC.

    Avez-vous pu avancé ? Trouver une solution ?

    lundi 2 septembre 2013 12:48
  • Bonsoir,

    La seule solution que j'ai trouvé est de :

    1. VMware, vcenter, désactiver la carte réseau du DC FSMO

    2. Démarrer le DC FSMO

    3. Une fois démarré, ouvrir une session et bien vérifier que les consoles (DNS, Users et Computers AD, Domain & approbation) fonctionnent. Ce qui est mon cas

    4. VMware, vcenter, réactiver la carte réseau du DC FSMO

    5. Démarrer les autres DC

    Voilà j'espère que cette solution vous dépannera

    FP


    FP

    lundi 2 septembre 2013 18:27
  • merci pour votre retour rapide. Pour ma part cela fait plusieurs semaines que je cherche il a priori c'est un fonctionnement normal d'Active Directory. En effet, le DC essaye de faire une synchro initial avant de démarrer le serveur DNS. Si pas DC sont dispo il attend. Le time out est de 20 minutes a priori. Au bout de 20 minutes le serveur DNS devrait démarrer et le serveur etre OK.

    Avez vous déjà attendu 20 minutes ?

    De votre coté avez vous enlever le DC en 2003 ?

    Depuis avez-vous toujours le problème ?

    Car normalement si le DC 2003 est enlevé proprement et que les synchros n'apparaissent plus, le problème ne doit plus etre présent.

    En tout cas je confirme qu'en coupant la carte réseau au démarrage le serveur démarre bien et rapidement.

    Merci par avance pour votre retour


    mardi 3 septembre 2013 17:10
  • Bonjour,

    Merci pour l'info des 20 mn. Non je n'ai pas attendu ce délai. Vous avez un lien où vous avez eu cette info ?

    La manipulation de "couper la carte réseau" me va bien. Nous déménageons dans 15j, nous devrons refaire la procédure (pourvu que ça fonctionne !!!).

    Enlever le DC2003, j'y ai pensé. Mais comme vous dites "car normalement ...", j'aime pas trop les normalement chez Microsoft. Nous avons prévu de migrer notre AD en 2014, on patientera donc pour enlever l'AD sur le DC2003 qui est également serveur de Bdd SQL.

    Merci pour votre retour également

    FP


    FP

    samedi 7 septembre 2013 06:47
  • Bonjour

    Ou en etes vous par rapport à votre poblème. Pour ma part j'ai supprimé le DC2003 du réseau avec la commande dcpromo. Maintenant tout fonctionne convenablement bien que le service DNS met un peu de temps à démarrer.

    Il me reste encore un DC2003 à dépromotionner et j'aurais plus que des 2008.

    jeudi 16 janvier 2014 17:02