none
Event ID 2159 - Event 45 and 223

    Question

  • We are getting this error: Sorry, something went wrong :-) 

    Log comes with error 45 - 223 (Event ID  2159) but Crawl is working and Search is running. 


    mardi 2 janvier 2018 10:57

Réponses

  • The error was Index. 

    Solution was:

    http://www.sharepointdiary.com/2015/05/reset-search-index-in-sharepoint-2013-using-powershell.html 

    Basically it appears the search index partition becomes corrupted. In this event the link becomes dead, the following steps resolved the issue:

    1. Stop the Timer Service
    2. Clear the configuration cache - Find in %ProgramData%Microsoft\SharePoint\Config the folder where the file cache.ini exists
    3. Delete every file from this folder EXCEPT cache.ini
    4. Open cache.ini, delete the content and put '1' (without the quotes) in it and save the file
    5. Restart the Timer Service
    6. Index reset
    7. Full crawl

     
    mercredi 3 janvier 2018 13:17

Toutes les réponses

  • Hi Henrik_M_Hansen,

    Please provide more information about how do you meet this error for helping solving your issue.

    Check if Named Pipes is enabled in SQL configuration. If it is, then proceed to the step in below article. If not, then enable Named Pipes and once that is done restart the services.

    https://social.technet.microsoft.com/wiki/contents/articles/26734.sharepoint-2013-event-id-2159.aspx 

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    mercredi 3 janvier 2018 06:15
  • The named pipes is enabled in the SQL configuration, and I have tried the SQL fix. 



    mercredi 3 janvier 2018 07:26
  • The error was Index. 

    Solution was:

    http://www.sharepointdiary.com/2015/05/reset-search-index-in-sharepoint-2013-using-powershell.html 

    Basically it appears the search index partition becomes corrupted. In this event the link becomes dead, the following steps resolved the issue:

    1. Stop the Timer Service
    2. Clear the configuration cache - Find in %ProgramData%Microsoft\SharePoint\Config the folder where the file cache.ini exists
    3. Delete every file from this folder EXCEPT cache.ini
    4. Open cache.ini, delete the content and put '1' (without the quotes) in it and save the file
    5. Restart the Timer Service
    6. Index reset
    7. Full crawl

     
    mercredi 3 janvier 2018 13:17
  • Hello ,

    Everyone says to make  index reset or remove and recreate new SSA  but nobody explain if you have 20000000 files indexed how to not lost them after index reset .

    Index reset  remove all files from index and neither users can found them

    what the real solution ?


    jeudi 12 juillet 2018 09:33