none
BranchCache test RRS feed

  • Question

  • Bonjour,

    Sur mon serveur 2012 j'ai mis en place BrancheCache en mode distribué en suivant une vidéo tutoriel sur youtube.

    J'ai mis les exceptions dans mon pare feu, créé les GPO pour mes clients, bref exactement tous comme dans la vidéo. Mais au moment de tester ça ne fonctionne pas.

    Pour tester j'ouvre une fenêtre d'analyse de performance j'y ajoute branchcache et j'essaye de copier un fichier depuis serveur sur mon client. Mais là rien ne bouge au niveau du cache.

    Je voulais savoir si vous aviez des idées ? d'ou peut venir ce problème ?

    Merci bonne fin d'après-midi

    mardi 13 mai 2014 13:31

Réponses

  • Votre config est OK pour moi.

    On va faire la chose suivante pour essayer de cerner le problème.

    1.Télécharger NetMon à cet URL : http://www.microsoft.com/en-us/download/details.aspx?id=4865 (télécharger la version approprié).

    Normalement il est compatible W2012 & W2012 R2.

    2. Ouvrez NetMon et laisser la console ouverte 

    3.Essayez de copier /récupérer des fichiers depuis le serveur sur votre poste.

    4.Vérifiez si des paquets UDP normalement sur le port 3702 transitent entre l'IP du client & IP du serveur.

    Il y'a aussi une autre piste, je sais que les compteurs à ajouter sur le perf mon sont présents dans une clé de registre, si l'analyseur de perf n'arrive pas à remonter des infos sur un ou plusieurs compteurs c'est qu'ils sont pas présents dans la clé de registre : 

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009 & HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\00C

    Tenez moi informé.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy


    jeudi 15 mai 2014 11:08

Toutes les réponses

  • Bonjour,

    Je ne sais pas ce que vous avez suivi comme vidéo pour mettre en place BranchCache, mais pourriez-vous me lister /enumérer les étapes de mise en place et de config via GPO pour voir si vous n'avez rien loupé.

    A+

    HK 


    Hicham KADIRI | Just Another IT Guy

    mardi 13 mai 2014 18:33
  • Bonjour,

    Je ne sais pas ce que vous avez suivi comme vidéo pour mettre en place BranchCache, mais pourriez-vous me lister /enumérer les étapes de mise en place et de config via GPO pour voir si vous n'avez rien loupé.

    A+

    HK 


    Hicham KADIRI | Just Another IT Guy

    Oui bien évidemment :

    1. J'ai commencé par créer une GPO pour les clients avec ces paramètres : -Activer BranchCache, -Configurer BranchCache pour les fichiers réseau (0 milliseconde), -BranchCache en mode distribué, -Pourcentage d'espace disque alloué pour la mémoire cache 20 %. 

    Et comme règles du trafic entrant ceci :

    J'ai utilisé les règles prédéfinies, -Découverte d'homologue de BranchCache (WSD), -Extraction du contenu de BranchCache(HTTP).


    Ensuite j'ai créé une GPO pour mon serveur, qui autorise la publication de hachages uniquement pour les dossier partagés dans les BranchCache est activé. J'ai par la suite effectuer la commande : hashgen –f d : \BranchCache, pour forcer le hachage sur mon dossier partager.

    Dites moi s'il vous faut plus d'informations.

    Bonne journée

    mercredi 14 mai 2014 07:34
  • Votre config est OK pour moi.

    On va faire la chose suivante pour essayer de cerner le problème.

    1.Télécharger NetMon à cet URL : http://www.microsoft.com/en-us/download/details.aspx?id=4865 (télécharger la version approprié).

    Normalement il est compatible W2012 & W2012 R2.

    2. Ouvrez NetMon et laisser la console ouverte 

    3.Essayez de copier /récupérer des fichiers depuis le serveur sur votre poste.

    4.Vérifiez si des paquets UDP normalement sur le port 3702 transitent entre l'IP du client & IP du serveur.

    Il y'a aussi une autre piste, je sais que les compteurs à ajouter sur le perf mon sont présents dans une clé de registre, si l'analyseur de perf n'arrive pas à remonter des infos sur un ou plusieurs compteurs c'est qu'ils sont pas présents dans la clé de registre : 

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009 & HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\00C

    Tenez moi informé.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy


    jeudi 15 mai 2014 11:08
  • Bonjour, merci de votre réponse.

    J'étais absent jusqu'à maintenant ! dsl, je vais tester tout ça.

     

    lundi 19 mai 2014 12:29