locked
Partage impossible après un changement de mot de passe RRS feed

  • Question

  • Bonjour,

    J'ai 2 PC en workgroup sous Vista Business. Sur le PC 1, j'ai créé l'utilisateur A et l'utilisateur B. Sur le PC 2, seul l'utilisateur B est créé.

    Sur le PC 1, j'ai créé 1 répertoire, que j'ai partagé pour l'utilisateur A (propriétaire) et pour l'utilisateur B (copropriétaire). Tout allait bien, l'utilisateur B accédait bien au répertoire du PC 1.

    Mais ce matin... j'ai changé le mot de passe de l'utilisateur B, aussi bien sur le PC 2 que sur le PC 1. Et depuis... impossible de se connecter sur le répertoire du PC1 depuis le PC2 avec l'utilisateur B. Et je pense avoir tout essayé :

    J'ai vérifié le partage, les droits NTFS. J'ai rebooté plusieurs fois les 2 PC. J'ai supprimé et recréé l'utilisateur B sur le PC1. J'ai créé un autre répertoire. J'ai toujours le même message : Code d'erreur 0x80070005 - Accès refusé ; "<repertoire> est disponible mais le compte d'utilisateur sous lequel vous êtes connecté s'est vu refuser l'accès. Windows ne peut pas diagnostiquer le problème car les diagnostics du réseau ne connaissent pas le nom d'utilisateur et le mot de passe nécessaires pour se connecter au dossier partager".

    Sinon, pour info, depuis le PC2, avec l'utilisateur B, j'arrive à me connecter à un autre répertoire du PC 1 pour lequel j'ai spécifié "tout le monde" en copropriétaire. J'arrive aussi à me connecter en "connexion bureau à distance" au PC2 depuis le PC1 avec le login/password de l'utilisateur B.

    Est-ce que quelqu'un aurait une solution ?

    Merci d'avance
    jeudi 14 mai 2009 17:04

Réponses

  • Merci pour tes réponses drope2a. Alors effectivement, en mettant le mot de passe initial, ça ne marchait pas mieux, et ton lien est intéressant, et avec la modif, ça marchait, mais ce n'était pas ce que je cherchais, parce qu'avec cette manip, tous les utilisateurs du workgroup accèdent au répertoire. Or, je ne voulais que seulement les utilisateurs A et B y accèdent.

    Alors j'ai fini par trouver, et c'est assez incroyable. Je me suis souvenu qu'il y a 2-3 mois, bien avant ce créer ces répertoires, j'avais changé le nom de l'utilisateur B. Son ancien nom était, disons C. Eh bien j'ai créé un utilisateur C sur le poste A, avec le nouveau mot de passe ET CA MARCHE !

    Il y a donc une règle (que je vais appeler modestement "Règle Liégois" ^^) qui dit : "Lorsqu'on change le nom et le mot de passe d'un utilisateur en workgroup, il faut utiliser l'ancien nom sur les ordinateurs distants". C'est au moins aussi fort que "Tout corps plongé dans un liquide finit par avouer", non ?

    Bon désolé pour ce petit délire, mais franchement, je suis drôlement soulagé d'avoir trouvé.
    • Marqué comme réponse JP Liegeois mercredi 20 mai 2009 17:12
    mercredi 20 mai 2009 17:12

Toutes les réponses

  • Juste pour test, si tu remets le mot de passe initial est-ce que ça fonctionne ?
    lundi 18 mai 2009 20:26
  • Merci pour tes réponses drope2a. Alors effectivement, en mettant le mot de passe initial, ça ne marchait pas mieux, et ton lien est intéressant, et avec la modif, ça marchait, mais ce n'était pas ce que je cherchais, parce qu'avec cette manip, tous les utilisateurs du workgroup accèdent au répertoire. Or, je ne voulais que seulement les utilisateurs A et B y accèdent.

    Alors j'ai fini par trouver, et c'est assez incroyable. Je me suis souvenu qu'il y a 2-3 mois, bien avant ce créer ces répertoires, j'avais changé le nom de l'utilisateur B. Son ancien nom était, disons C. Eh bien j'ai créé un utilisateur C sur le poste A, avec le nouveau mot de passe ET CA MARCHE !

    Il y a donc une règle (que je vais appeler modestement "Règle Liégois" ^^) qui dit : "Lorsqu'on change le nom et le mot de passe d'un utilisateur en workgroup, il faut utiliser l'ancien nom sur les ordinateurs distants". C'est au moins aussi fort que "Tout corps plongé dans un liquide finit par avouer", non ?

    Bon désolé pour ce petit délire, mais franchement, je suis drôlement soulagé d'avoir trouvé.
    • Marqué comme réponse JP Liegeois mercredi 20 mai 2009 17:12
    mercredi 20 mai 2009 17:12
  • Et bien tu viens de m'apprendre quelque chose ;)
    garder les anciens noms sur les ordinateurs distants !!! (bon à savoir !), je n'étais pas parti là-dessus du tout !

    heureux que ton problème soit résolu et merci pour l'info !!!

    ++

    mercredi 20 mai 2009 18:11