locked
Problème déploiement GPO sur Windows 8 RRS feed

  • Question

  • Bonjour,

    J'ai lu sur différents forum des problèmes de déploiement via GPO sur des postes Windows 8, Windows 8.1

    j'ai lu également une solution de contournement comme rajouter une clé dans le registre EnableLinkedConnections = dword:00000001

    sauf que ça ne marche pas même avec ça...le compte est en admin local et uac désactivé

    ça m’étonne que MS n'est toujours pas trouvé de solution.....?

    merci de m’éclairer !

    PS : les GPO sont sur un W2008R2


    jeudi 8 mai 2014 15:08

Réponses

  • Ok parfait, donc ce n'est pas un problème côté paramètres GP.

    peux tu ouvrir PowerShell en tant qu'Admin et saisir :

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

    tu peux faire un copier /coller directement dans PowerShell.

    cette commande permet de désactiver la négociation de la sécurité 'signature de sécurité', fonctionnalité apparue avec Windows 2012 Server & Windows 8.

    Windows 8 va chercher une signature de sécurité d'accès aux partages SMBv2 qui n'est pris en charge que par Windows 8 & Windows 2012.

    Tenez moi au courant.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse lolitazzz dimanche 11 mai 2014 00:17
    samedi 10 mai 2014 13:46
  • si je comprends bien la GPO fonctionne sans cette commande qu'avec W2012 ?

    => W2012 support SMBv2, donc s'il fait office de serveur de fichiers, toute machine sous W8 ou W8.1 pourront négocier la sécurité auprès de ce serveur, ce n'est pas les cas pour les versions antérieures. donc pour répondre à votre OUI.

    Ou faut il modifier pour que cette commande fonctionne même apres un reboot de la machine ? 

    => la commande PowerShell est à exécuter sur toute machine exécutant W8 ou W8.1 et devant accéder à un partage sur un NAS ou un serveur de fichiers, type 2003 ou 2008.

    via l'interface graphique il n'y a rien ?

    => (à ma connaissance) L'équivalent de la commande PS en interface graphique n'est pas possible en mode GUIMais je sais que des fois, j'ai résolu ce genre de problème en changement le type de chiffrement, voir image ci-après

    Cette option est accessible depuis le centre de réseau et de partage => modifier les paramètres de partage avancés.

    Merci de voter /marquer les réponses que vous jugez utiles.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse lolitazzz dimanche 11 mai 2014 00:17
    samedi 10 mai 2014 15:28
  • Normalement après l'exécution de la commande, la valeur de la clé RequireSecureNegotiate est toujours à 0

    Donc vous n'avez pas à re lancer la commande à chaque démarrage. la valeur est modifiée une bonne fois pour toute.

    Les lecteurs réseaux ne sont pas montés au démarrage parce que je pense qu'ils ne sont pas "persistent".

    Si vous utilisez un script net use pour mapper les lecteurs à l'ouverture de session de vos users, vérifiez que l'instruction "/PERSISTENT:YES" est spécifiée.


    A+

    HK.


    Hicham KADIRI | Just Another IT Guy


    samedi 10 mai 2014 20:51
  • Avec Windows 8 et Windows 8.1, des nouveaux paramètres de stratégies de groupe sont apparus.

    Désormais on peut contrôler le délai d'exécution des scripts de démarrage après l'ouverture de session.

    Merci de suivre les instructions suivantes et me tenir informé du résultat:

    1. Ouvrez l'éditeur de stratégie de groupe et naviguez jusqu'au :

    2. Double-cliquez sur le paramètre "Configurer le délai des scripts d'ouverture de session", (voir img ci-après)

    3. Cliquez sur "Activé" et spécifiez la valeur 0 dans "minute", comme montré ci-dessus:

    Vous constatez le bon timing d'attente avant exécution de votre script après l'ouverture de session :).

    C bel et bien 5min, donc en mettant la valeur minute à 0, votre ou vos scripts d'ouverture de session seront exécutés dès l'ouverture de la session.

    J'espère avoir répondu à vos questions.

    Tenez moi au courant.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse lolitazzz dimanche 11 mai 2014 00:17
    samedi 10 mai 2014 23:39

Toutes les réponses

  • Bonjour,
    Quel est le problème exactement ?

    Blog

    jeudi 8 mai 2014 15:29
  • Vous parlez de déploiement via GPO et de l'update Windows 8.1

    Just FYI:

     

    L'update Windows 8.1 est récupérable depuis soit :

    Windows Update : dans le cas ou aucune solution de gestion des mises à jour interne n'est présente (e.i WSUS)

    WSUS : dans le cas ou vos machines Windows 8 sont des clients WSUS récupérant leurs updates auprès d'un serveur WSUS accessible via réseau.

    Donc, GPO + déploiement Update Windows 8.1 = ## ERROR ## 

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy


    jeudi 8 mai 2014 21:14
  • ah non je parle pas de ca je me suis mal exprimé

    mon but est de deployer automatiquement des lecteurs réseaux via GPO

    sous windows XP, 7 ca fonctionne nikel, sous windows 8, 8.1, aucun lecteur ne monte même avec les actions que j'ai décrite ci dessus

    vendredi 9 mai 2014 18:49
  • Bonjour,

    Pourriez-vous configurer les mêmes paramètres de stratégie de groupe via GPEDIT.MSC (depuis la machine locale) et me tenir informé du résultats ?

    C'est pour cerner le problème et voir si c lié aux GPOs, réseau, paramètres centre de partage et réseau ..

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    vendredi 9 mai 2014 19:48
  • bon j'ai refait une maquette en dehors du boulot, ca fait le meme resultat, j'ai testé via gpedit.msc sur le poste local, ca ne monte pas non plus....je test le script manuellement ca monte bien

    le windows 8 est bien admin local, par feu desactivé ...je comprends pas la ou ca bloque (je precise que sous xp, 7 aucun soucis de déploiement)

    samedi 10 mai 2014 10:53
  • Je vois, la machine sur laquelle vous avez fait le test via GPEDIT.MSC avait déjà la clé EnableLinkedConnections = dword:00000001 ? ou s'agit il d'une nouvelle machine fraichement installée ?


    Hicham KADIRI | Just Another IT Guy

    samedi 10 mai 2014 12:38
  • oui la machine avait deja la clé rajoutée
    samedi 10 mai 2014 13:16
  • Ok parfait, donc ce n'est pas un problème côté paramètres GP.

    peux tu ouvrir PowerShell en tant qu'Admin et saisir :

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

    tu peux faire un copier /coller directement dans PowerShell.

    cette commande permet de désactiver la négociation de la sécurité 'signature de sécurité', fonctionnalité apparue avec Windows 2012 Server & Windows 8.

    Windows 8 va chercher une signature de sécurité d'accès aux partages SMBv2 qui n'est pris en charge que par Windows 8 & Windows 2012.

    Tenez moi au courant.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse lolitazzz dimanche 11 mai 2014 00:17
    samedi 10 mai 2014 13:46
  • ca fonctionne apres avoir fait la commande !

    si je comprends bien la GPO fonctionne sans cette commande qu'avec W2012 ?

    Ou faut il modifier pour que cette commande fonctionne même apres un reboot de la machine ? via l'interface graphique il n'y a rien ?

    samedi 10 mai 2014 15:01
  • si je comprends bien la GPO fonctionne sans cette commande qu'avec W2012 ?

    => W2012 support SMBv2, donc s'il fait office de serveur de fichiers, toute machine sous W8 ou W8.1 pourront négocier la sécurité auprès de ce serveur, ce n'est pas les cas pour les versions antérieures. donc pour répondre à votre OUI.

    Ou faut il modifier pour que cette commande fonctionne même apres un reboot de la machine ? 

    => la commande PowerShell est à exécuter sur toute machine exécutant W8 ou W8.1 et devant accéder à un partage sur un NAS ou un serveur de fichiers, type 2003 ou 2008.

    via l'interface graphique il n'y a rien ?

    => (à ma connaissance) L'équivalent de la commande PS en interface graphique n'est pas possible en mode GUIMais je sais que des fois, j'ai résolu ce genre de problème en changement le type de chiffrement, voir image ci-après

    Cette option est accessible depuis le centre de réseau et de partage => modifier les paramètres de partage avancés.

    Merci de voter /marquer les réponses que vous jugez utiles.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse lolitazzz dimanche 11 mai 2014 00:17
    samedi 10 mai 2014 15:28
  • Bonjour,

    Ok, merci pour les réponses.
    Pas de changements apres avoir activé le partage de fichiers avec le chifferements 40 ou 56 bits.

    Après le reboot de la machine, les lecteurs ne montent pas, je suis obligé de refaire la commande a chaque fois...Je ne peux pas modifier le registre pour que le changement soit définitif ?

    • Modifié lolitazzz samedi 10 mai 2014 19:37
    samedi 10 mai 2014 19:07
  • Normalement après l'exécution de la commande, la valeur de la clé RequireSecureNegotiate est toujours à 0

    Donc vous n'avez pas à re lancer la commande à chaque démarrage. la valeur est modifiée une bonne fois pour toute.

    Les lecteurs réseaux ne sont pas montés au démarrage parce que je pense qu'ils ne sont pas "persistent".

    Si vous utilisez un script net use pour mapper les lecteurs à l'ouverture de session de vos users, vérifiez que l'instruction "/PERSISTENT:YES" est spécifiée.


    A+

    HK.


    Hicham KADIRI | Just Another IT Guy


    samedi 10 mai 2014 20:51
  • bonjour,

    effectivement, ils n'étaient pas persistants, j'ai donc modifié les scripts mais j'ai un petit soucis, on y est presque.

    Après chaque reboot de la machine, les lecteurs réseaux remontent bien sous W8 mais au bout de 5min bizarrement....(j'ai pas ce problème non plus sous W7)

    une idée ? pas d'erreur dans les events

    samedi 10 mai 2014 23:10
  • Avec Windows 8 et Windows 8.1, des nouveaux paramètres de stratégies de groupe sont apparus.

    Désormais on peut contrôler le délai d'exécution des scripts de démarrage après l'ouverture de session.

    Merci de suivre les instructions suivantes et me tenir informé du résultat:

    1. Ouvrez l'éditeur de stratégie de groupe et naviguez jusqu'au :

    2. Double-cliquez sur le paramètre "Configurer le délai des scripts d'ouverture de session", (voir img ci-après)

    3. Cliquez sur "Activé" et spécifiez la valeur 0 dans "minute", comme montré ci-dessus:

    Vous constatez le bon timing d'attente avant exécution de votre script après l'ouverture de session :).

    C bel et bien 5min, donc en mettant la valeur minute à 0, votre ou vos scripts d'ouverture de session seront exécutés dès l'ouverture de la session.

    J'espère avoir répondu à vos questions.

    Tenez moi au courant.

    A+

    HK.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse lolitazzz dimanche 11 mai 2014 00:17
    samedi 10 mai 2014 23:39
  • nikel, tout fonctionne au poil ! merci enormement ! j'en aurais appris sur les nouveautés W2012 et W8 !

    dimanche 11 mai 2014 00:17
  • Je vous en prie, content que votre problème est résolu :).

    ++
    HK.


    Hicham KADIRI | Just Another IT Guy

    dimanche 11 mai 2014 09:09