none
Pb communication management point avec serveur SQL RRS feed

  • Question

  • Bonjour,

    L'architecture SCCM au sein de laquelle le problème survient est la suivante :

    SCCM 2007 SP2

    Un serveur qui héberge un site primaire ainsi que les rôles SCCM de bases : point de distribution, point de gestion, etc. Une frontière a été définie pour ce site qui gère les machines du siège de l'entreprise.

    Un serveur qui héberge un site secondaire, site enfant du site primaire cité ci dessus. Ce serveur héberge les rôles de proximité suivant : point de distribution, point de gestion. Une frontière a été définie pour ce site qui gère les machines d'un emplacement géographique distant. Le site secondaire ainsi que les rôles SCCM ont été déployés depuis la console du site primaire. Le système d'exploitation du serveur est Windows 2003 SP2.

    Le problème recontré est le suivant : le point de gestion du site secondaire émet les messages d'erreur suivant :

     Gravité            Type     Code du site   Date/Heure     Système           Composant     ID de message            Description
    Erreur   Marque           PTG      26/05/2010 09:41:02     Nom du serveur           SMS_MP_CONTROL_MANAGER          5436    
    Le Gestionnaire de contrôle de point de gestion a détecté que le point de gestion ne répond pas aux requêtes HTTP. Le code d'état et texte HTTP est 500, Internal Server Error.   

    Cause possible : le point de gestion a rencontré une erreur lors de la connexion à SQL Server.  Solution : vérifiez que le serveur SQL est configuré correctement pour autoriser l'accès au point de gestion. Vérifiez que le compte de l'ordinateur du point de gestion ou le compte de connexion à la base de données du point de gestion est membre du rôle Point de gestion SMS (msdbrole_MP) dans la base de données SQL Server   

    Cause possible : les noms principaux de services SQL Server (SPN) ne sont pas enregistrés correctement dans Active Directory.  Solution : vérifiez que les noms principaux SPN SQL Server sont enregistrés correctement. Consultez l'article Q829868.   

    Cause possible : les services Internet (IIS) ne sont pas configurés pour écouter les ports via lesquels SMS communique.   Solution : vérifiez que le site Web désigné est configuré de sorte à utiliser les mêmes ports que SMS.   

    Cause possible : le site Web désigné est désactivé dans les services Internet.  Solution : vérifiez que le site Web désigné est activé et qu'il fonctionne correctement.   

    Cause possible : l'identité d'application ISAPI SMS ne dispose pas des privilèges d'ouverture de session requis.  Solution : vérifiez que les droits d'ouverture de session par lot n'ont pas été refusés par une stratégie de groupe au compte pour lequel l'interface ISAPI SMS est configurée.    Pour plus d'informations, reportez-vous à l'article 838891 de la Base de connaissances Microsoft

     

    Sur le serveur SQL, on observe le message d'erreur suivant :

     Type de l’événement :            Audit des échecs
    Source de l’événement :        MSSQL$SCCM
    Catégorie de l’événement :   (4)
    ID de l’événement :    18456
    Date :              26/05/2010
    Heure :            10:06:05
    Utilisateur :                   AUTORITE NT\ANONYMOUS LOGON
    Ordinateur :     Nom serveur SQL

    Description :
    Échec de l'ouverture de session de l'utilisateur 'AUTORITE NT\ANONYMOUS LOGON'. [CLIENT : Adresse IP du serveur du site secondaire]

    L'observation de la configuration du serveur SQL montre que le compte machine du serveur du site secondaire est bien défini dans les connexion à la base de données et qu'il bénéficie bien du rôle SQL smsdbrole_MP.

    A noter également que nous avons constaté le même problème lors du déploiement du point de rapport sur un autre serveur (pb de connexion anonyme sur le serveur SQL), problème contourné en utilisant un compte de service.

    Le problème n'existe pas pour un autre site secondaire avec point de gestion hébergé sur un serveur Windows 2008.

    Tout aide sera appréciée, n'hésitez pas à nous demander des informations complémentaires.

    Par avance, merci.

     

    mercredi 26 mai 2010 08:58

Réponses

  • Désolé pour la latence de ma réponse, nous poursuivons d'autres tests en parallèle.

    La réinstallation du point de gestion n'a pas corrigé le problème.

    La première URL que vous nous avez demandé de tester retournait un code HTTP 500.

    La seconde retournait le certificat du site au format XML.

    Quoiqu'il en soit, il semble que nous ayons résolu le problème, il s'agissait bien d'un problème d'accès à la base de données. La base de données SCCM n'est pas hébergée sur le serveur de site, elle est de plus installée dans une instance SQL dédiée (port différent de 1433). Nous avons correctement défini le SPN du service conformément à la documentation (http://technet.microsoft.com/en-us/library/bb735885.aspx), mais nous l'avons fait avec le nom court du serveur. Nous avons redéclaré le SPN avec le FQDN du serveur de base de données, cela a corrigé le problème d'accès à la base.

    Merci pour votre aide.

    jeudi 27 mai 2010 08:54

Toutes les réponses

  • Salut,

    Merci de vérifier que la composante WEBDAV est configuré correctement http://technet.microsoft.com/fr-fr/library/cc431377.aspx

    Sinon vous pouvez télécharger sccm toolkit v2 qui contient l'outil MPTroubleshouter permettant de détacter les pb relatifs à votre point de gestion https://www.microsoft.com/downloads/details.aspx?familyid=5A47B972-95D2-46B1-AB14-5D0CBCE54EB8&displaylang=en

    Cordialement,


    Bechir Gharbi. MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront (Time Zone : GMT+1)
    mercredi 26 mai 2010 09:24
    Modérateur
  • Merci de votre réponse rapide.

    L'article que sous suggérez concerne IIS 7.0 et les serveurs Windows 2008. Le problème concerne un management point hébergé sur un serveur Windows 2003.

    L'outil de diagnostic dont vous avez fourni le lien a été exécuté sur ce serveur. Lors de la phase d'analyse, le groupe administrators est recherché. Un message spécifie que le service World Wide Web Publishing Service n'est pas en cours d'exécution à divers reprises - alors que le service IIS est bien démarré sur le serveur -. J'ai omis de spécifier que l'OS Windows 2003 est en français ainsi que l'installation de SCCM. Cet outil est il compatible avec une localisation française ?

    mercredi 26 mai 2010 13:07
  • Et si vous essayez de tester ces deux urls :

    http://server/sms_mp/.sms_aut?mplist

    http://server/sms_mp/.sms_aut?mpcert

    Server : le nom de votre serveur Point de gestion.

    Aussi, avez vous essayé de désinstaller IIS/Point de gestion, ensuite réinstaller IIS/Point de gestion ? Dans la plupart des cas c'est une solution fiable et rapide :

    Alors pour cela vous pouvez suivre cette méthode :

    1.  supprimer le point de gestion à partir de la console sccm

    2.  exécuter la commande ccmclean /all (cet outil est inclus dans l'outil SMS 2003 Toolkit 2 http://www.microsoft.com/downloads/details.aspx?FamilyID=61e4e21f-2652-42dd-a04d-b67f0573751d&displaylang=en)

    Notez bien aussi que ccmclean /all va désinstaller le client sccm sur le point de gestion s'il existe

    3.  supprimer completement IIS, BITS, WebDav, ...

    4.  Redemarrer le serveur

    5.  Arrêter le service Planificateur de tâche

    6.  Renomer le répertoire %windir%\Tasks ou bien supprimer le

    7.  Démarrer le service Planificateur de tâche (Le répertoir %windir%\Tasks sera recréer automatiquement)

    9.  réinstaller et configurer IIS, BITS, WebDAV, ...

    10.  Réinstaller le point de gestion et son client sccm s'il existait

    J'attend votre retour.


    Bechir Gharbi. MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront (Time Zone : GMT+1)
    mercredi 26 mai 2010 13:20
    Modérateur
  • Désolé pour la latence de ma réponse, nous poursuivons d'autres tests en parallèle.

    La réinstallation du point de gestion n'a pas corrigé le problème.

    La première URL que vous nous avez demandé de tester retournait un code HTTP 500.

    La seconde retournait le certificat du site au format XML.

    Quoiqu'il en soit, il semble que nous ayons résolu le problème, il s'agissait bien d'un problème d'accès à la base de données. La base de données SCCM n'est pas hébergée sur le serveur de site, elle est de plus installée dans une instance SQL dédiée (port différent de 1433). Nous avons correctement défini le SPN du service conformément à la documentation (http://technet.microsoft.com/en-us/library/bb735885.aspx), mais nous l'avons fait avec le nom court du serveur. Nous avons redéclaré le SPN avec le FQDN du serveur de base de données, cela a corrigé le problème d'accès à la base.

    Merci pour votre aide.

    jeudi 27 mai 2010 08:54