locked
Connexions multiples au même lecteur réseau. RRS feed

  • Question

  • Bonjour...

    Je viens de m'offrir un nouveau PC (portable Toshiba Satellite P850-304 15", processeur i7, RAM 8Go DDR3, HD 1To, Windows 7 premium family).

    Je me connecte via un réseau domestique (4 PC, 2 Mac), par wifi, connexion internet via routeur connecté sur une box SFR.

    L'essentiel de mes fichiers est stocké sur un NAS Drobo 4 baies, via Droboshare connecté au routeur.

    Mon NAS est "partitionné" en 3 unités de 2 To, subtilement appelées drobo01, drobo02 et drobo03.

    Quand j'ai installé tout ça il y a trois jours, j'ai déclaré et connecté mes 3 unités NAS, via la commande "Connecter un lecteur réseau" : j'ai affecté les lettres X: Y: et Z: respectivement aux unités drobo01 drobo02 et drobo03.

    J'ai également connecté un lecteur multimédia, qui est câblé directement sur le routeur (et sur mon système TV-ampli vidéo), en lui affectant le nom "LaCie" et  la lettre T:

    Sur mon portable Toshiba, il y a un disque dur interne (C:) et un lecteur CD/DVD (D:).

    Jusque là, tout allait bien...

    Et puis j'ai rebooté le Toshiba suite à une mise à jour Windows Update...

    Et après le reboot, j'ai eu la surprise en allumant mon poste de travail de trouver :

    - C: en C: et D: en D: (normal)

    - LaCie en T: (normal)

    - drobo01 en X: (normal)

    - drobo02 en Y: (normal)

    - drobo03 en Z: mais aussi en A: B: E: F:... et toutes les lettres possibles, sauf C: D: T: X: et Y: !!! soit 21 connexions pour cette seule unité.

    Toutes ces connexions à drobo03 fonctionnent, je peux accéder aux fichiers via Z: ou G: ou N: etc.

    Quand je cherche à déconnecter une de ces connexions, par exemple L:, soit ça ne marche pas (aucune réaction), soit ça marche mais ça se reconnecte au bout de quelques secondes....

    Le problème est que d'une part c'est pas beau et inutilement compliqué... mais surtout je ne peux plus connecter un disque externe (disque dur portable) : toutes les lettres sont utilisées....

    J'ai bien l'impression que c'est un petit truc tout simple et évident pour beaucoup d'entre vous, mais moi, je n'ai pas la solution, alors please, pretty please, help me !

    Merci d'avance.

    lundi 18 juin 2012 12:14

Réponses

  • Bonsoir les Experts !

    Les voies de l'informatique sont impénétrables....

    Depuis hier j'ai travaillé sur un autre site avec mon PC, sans connexion réseau.

    Mes unités "fantômes" apparaissaient toujours. Je les ai supprimées (clic droit supprimer, tout simplement). J'ai éteint et rallumé plusieurs fois ce PC (éteint, pas mis en veille), et de retour chez moi, quand j'ai rallumé, l'unité T:, correspondant au disque multimédia (appelé LaCie) est apparue en double (T: et Y:), en rouge avec la croix, ce qui était normal parce que ce disque dur était physiquement éteint (alimentation coupée), mais mes trois unités Drobo sont réapparues et se sont connectées normalement, sans autres instances "fantômes"...

    Seule bizarrerie, les lettres n'étaient plus X: Y: Z: mais U: V: et Z:

    Bon, j'avoue que je n'ai pas tout compris, mais laissé en l'état, j'ai rebooté 4 ou 5 fois à l'occasion de mises à jour (Windows, Photoshop, etc.) et tout revient tel quel après chaque reboot, LaCie en T: et Y:, les 3 Drobo en U: V: et Z:

    Je ne suis pas certain que ce soit définitivement réglé, mais pour l'instant tout va bien donc.

    Alors Merci ++++ de votre accueil et de votre aide, j'espère ne pas avoir à vous solliciter à nouveau !

    Thierry.

    • Marqué comme réponse Glimmerchef mardi 19 juin 2012 21:49
    mardi 19 juin 2012 21:48

Toutes les réponses

  • Bonjour,

    ...c'est un petit truc tout simple et évident pour beaucoup d'entre vous...

    Pas pour moi en tous cas.

    As-tu essayé de réinitialiser la configuration, le WinSock et l'adressage ?

    • ipconfig /release
    • ipconfig /renew
    • netsh winsock reset (reboot après)
    • netsh int ip reset (reboot après)


    P.S. : si tu débranches le NAS, peux-tu supprimer les connexions ?
    Si oui, essaye non pas de "Connecter un lecteur réseau" mais de faire dans Ordinateur clic droit, Ajouter un emplacement réseau.


    Cordialement, Quartzkyte (Michel pour les intimes).
    Sites : 7 extra (annuaire Win 7)(webmaster ) - F.A.Q. Outlook (admin )
    Win 7 : Travailler avec un Netbook et l'édition Starter - Utiliser le compte Administrateur - Sauvegarde sous Windows 7
    Newsgroup Win7 créé par M. Claveau : news:\\ponx.fr\win7, Utilisateur et Passe : v.





    • Modifié Quartzkyte lundi 18 juin 2012 13:23 Typo... :(
    lundi 18 juin 2012 13:19
  • Le lundi 18/06/2012 14:14:15, Glimmerchef a écrit dans le message <news:189f9ddb-f9d0-4a40-84d5-297bc5fe4166@communitybridge.codeplex.com> ce qui suit :

    Bonjour...

    Je viens de m'offrir un nouveau PC (portable Toshiba Satellite P850-304 15", processeur i7, RAM 8Go DDR3, HD 1To, Windows 7 premium family).

    Je me connecte via un réseau domestique (4 PC, 2 Mac), par wifi, connexion internet via routeur connecté sur une box SFR.

    L'essentiel de mes fichiers est stocké sur un NAS Drobo 4 baies, via Droboshare connecté au routeur.

    Mon NAS est "partitionné" en 3 unités de 2 To, subtilement appelées drobo01, drobo02 et drobo03.

    Quand j'ai installé tout ça il y a trois jours, j'ai déclaré et connecté mes 3 unités NAS, via la commande "Connecter un lecteur réseau" : j'ai affecté les lettres X: Y: et Z: respectivement aux unités drobo01 drobo02 et drobo03.

    J'ai également connecté un lecteur multimédia, qui est câblé directement sur le routeur (et sur mon système TV-ampli vidéo), en lui affectant le nom "LaCie" et  la lettre T:

    Sur mon portable Toshiba, il y a un disque dur interne (C:) et un lecteur CD/DVD (D:).

    Jusque là, tout allait bien...

    Et puis j'ai rebooté le Toshiba suite à une mise à jour Windows Update...

    Et après le reboot, j'ai eu la surprise en allumant mon poste de travail de trouver :

    - C: en C: et D: en D: (normal)

    - LaCie en T: (normal)

    - drobo01 en X: (normal)

    - drobo02 en Y: (normal)

    - drobo03 en Z: mais aussi en A: B: E: F:... et toutes les lettres possibles, sauf C: D: T: X: et Y: !!! soit 21 connexions pour cette seule unité.

    Toutes ces connexions à drobo03 fonctionnent, je peux accéder aux fichiers via Z: ou G: ou N: etc.

    Quand je cherche à déconnecter une de ces connexions, par exemple L:, soit ça ne marche pas (aucune réaction), soit ça marche mais ça se reconnecte au bout de quelques secondes....

    Le problème est que d'une part c'est pas beau et inutilement compliqué... mais surtout je ne peux plus connecter un disque externe (disque dur portable) : toutes les lettres sont utilisées....

    J'ai bien l'impression que c'est un petit truc tout simple et évident pour beaucoup d'entre vous, mais moi, je n'ai pas la solution, alors please, pretty please, help me !

    Curieux !

    Dans un 1er temps, pourrais-tu exécuter les commandes
    (dans une fenêtre de commandes exécutée en tant qu'administrateur)
        NET SHARE

    et
        NET USE

    et nous faire part du résultat ?
     Je rappelle qu'il est très facile de copier "à la souris" le contenu d'une fenêtre de commandes :
    (c'est ainsi au moins depuis NT4, soit 1996, mais peu d'utilisateurs connaissent la manip!)
     1) Une fois pour toutes, depuis le menu système / Propriétés de la fenêtre, onglet "Options", zone "options d'édition", cocher les 2 cases "Mode d'édition rapide" et "Mode insertion".

    2) Dans la fenêtre de commandes dont on veut copier du texte, appuyer sur le bouton gauche de la souris, puis "peindre" le rectangle concerné (il apparaît en vidéo inverse). Relâcher le bouton quand on a fini.

    3) Aller dans l'appli "réceptrice" (IE, Notepad, Word, un éditeur quelconque, ...), et clic droit "Coller" (ou CTRL-V ou MAJ-Ins)



    May the Force be with You!
    La Connaissance s'accroît quand on la partage
    ----------------------------------------------------------
    Jean-Claude BELLAMY [MVP Expert IT Pro]
    http://www.bellamyjc.org  ou http://jc.bellamy.free.fr

    lundi 18 juin 2012 13:44
  • Bonjour Jean-Claude,

    ...
     Je rappelle qu'il est très facile de copier "à la souris" le contenu d'une fenêtre de commandes :
    (c'est ainsi au moins depuis NT4, soit 1996, mais peu d'utilisateurs connaissent la manip!)
     1) Une fois pour toutes, depuis le menu système / Propriétés de la fenêtre, onglet "Options", zone "options d'édition", cocher les 2 cases "Mode d'édition rapide" et "Mode insertion".

    2) Dans la fenêtre de commandes dont on veut copier du texte, appuyer sur le bouton gauche de la souris, puis "peindre" le rectangle concerné (il apparaît en vidéo inverse). Relâcher le bouton quand on a fini.

    J'ai plus rapide pour cette partie !

    Clic droit dans la boîte, Sélectionner, "peindre" le rectangle concerné et faire Entrée (ou Sélectionner tout si on veut tout !). Après, pareil pour coller :)

    @+


    Cordialement, Quartzkyte (Michel pour les intimes).
    Sites : 7 extra (annuaire Win 7)(webmaster ) - F.A.Q. Outlook (admin )
    Win 7 : Travailler avec un Netbook et l'édition Starter - Utiliser le compte Administrateur - Sauvegarde sous Windows 7
    Newsgroup Win7 créé par M. Claveau : news:\\ponx.fr\win7, Utilisateur et Passe : v.

    lundi 18 juin 2012 14:18
  • Curieux !

    Dans un 1er temps, pourrais-tu exécuter les commandes
    (dans une fenêtre de commandes exécutée en tant qu'administrateur)
        NET SHARE

    et
        NET USE

    et nous faire part du résultat ?

    Merci Jean-Claude !

    Réponse rapide++

    Alors j'ai fait, et voilà ce que ça donne :

    Pour NET SHARE :

    Microsoft Windows [version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.

    C:\windows\system32>NET SHARE

    Nom partage  Ressource                       Remarque

    ------------------------------------------------------------------------------
    C$           C:\                             Partage par défaut
    IPC$                                         IPC distant
    ADMIN$       C:\windows                      Administration à distance
    DOCUMENTS    C:\DOCUMENTS
    SOFTWARE     C:\SOFTWARE
    La commande s'est terminée correctement.

    et pour NET USE :

    C:\windows\system32>NET USE
    Les nouvelles connexions seront mémorisées.


    État         Local     Distant                   Réseau

    -------------------------------------------------------------------------------
    OK           A:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           B:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           E:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           F:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           G:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           H:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           I:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           J:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           K:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           L:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           M:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           N:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           O:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           P:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           Q:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           R:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           S:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           T:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           W:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           X:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           Z:        \\DroboShare\Drobo03      Microsoft Windows Network
    OK                     \\DROBOSHARE\Drobo01      Microsoft Windows Network
    La commande s'est terminée correctement.

    Je vais tester maintenant les suggestions de Quartzkyte....

    lundi 18 juin 2012 14:22
  • Voilà, testé les suggestions de Quartzyke :

    • ipconfig /release
    • ipconfig /renew
    • netsh winsock reset (reboot après)
    • netsh int ip reset (reboot après)

    Les deux premières ont donné plusieurs pages de résutats, je pourrais copier-coller si vous voulez mais c'est un peu long.

    La troisième a été bien plus courte, j'ai ensuite fait un reboot.

    Quant à la dernière, erreur :

    La commande suivante n'a pas été trouvée : ip reset

    Le problème n'est pas résolu, j'ai toujours une vingtaine d'instance de drobo03.... Mais déjà, je vous remercie d'avoir essayé (aussi rapidement !) de m'aiguiller. Je reste ouvert à toute autre suggestion, et je vous tiendrai au courant, mais boulot oblige, je ne serai pas reconnecté avant demain après midi.

    Merci encore !!!

    Th.

    PS : ça n'empêche pas ce PC de fonctionner très bien par ailleurs, et si je veux installer un disque dur externe, je coupe le réseau, déconnecte manuellement quelques instances, branche le disque dur et une fois qu'il est reconnu et installé, je rebranche le réseau et ça fonctionne. Mais bon, j'aime bien comprendre... même si je ne comprends pas grand chose  tout ça !

    lundi 18 juin 2012 14:41
  • Hello,

    Pour les deux premières, c'est un simple release / renouvellement, donc aucun intérêt ici.

    Pour le netsh int ip reset, au temps pour moi, j'aurais dû écrire
    netsh int ip reset c:\resetlog.txt
    (avec un nom de fichier de destination)
    ou t'orienter vers le fix-it (cf.
    http://support.microsoft.com/kb/299357/fr).

    Pour le reste, je pense que Jean-Claude te conseillera de tester sans connexions persistantes (net use /persistent:no) ou de démonter les connexions superflues (par exemple net use A: \\DROBOSHARE\Drobo01 /delete) mais comme il est beaucoup plus fort que la plupart d'entre nous ici, autant lui laisser la parole...

    Bon courage !


    Cordialement, Quartzkyte (Michel pour les intimes).
    Sites : 7 extra (annuaire Win 7)(webmaster ) - F.A.Q. Outlook (admin )
    Win 7 : Travailler avec un Netbook et l'édition Starter - Utiliser le compte Administrateur - Sauvegarde sous Windows 7
    Newsgroup Win7 créé par M. Claveau : news:\\ponx.fr\win7, Utilisateur et Passe : v.


    • Modifié Quartzkyte lundi 18 juin 2012 15:06 :( :( encore des fôtes...
    lundi 18 juin 2012 15:05
  • Le lundi 18/06/2012 16:22:33, Glimmerchef a écrit dans le message <news:9ca4e1a0-c72a-42fe-b4d6-10c3e6dfbfff@communitybridge.codeplex.com> ce qui suit :

    Curieux !

    Dans un 1er temps, pourrais-tu exécuter les commandes
    (dans une fenêtre de commandes exécutée en tant qu'administrateur)
        NET SHARE

    et
        NET USE

    et nous faire part du résultat ?

    Merci Jean-Claude !

    Réponse rapide++



    Alors j'ai fait, et voilà ce que ça donne :

    Pour NET SHARE :

    Microsoft Windows [version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Tous droits réservés.

    C:\windows\system32>NET SHARE

    Nom partage  Ressource                       Remarque

    ------------------------------------------------------------------------------ C$           C:\                             Partage par défaut
    IPC$                                         IPC distant
    ADMIN$       C:\windows                      Administration à distance
    DOCUMENTS    C:\DOCUMENTS
    SOFTWARE     C:\SOFTWARE
    La commande s'est terminée correctement.



    et pour NET USE :

    C:\windows\system32>NET USE
    Les nouvelles connexions seront mémorisées.


    État         Local     Distant                   Réseau

    ------------------------------------------------------------------------------- OK           A:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           B:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           E:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           F:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           G:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           H:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           I:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           J:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           K:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           L:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           M:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           N:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           O:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           P:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           Q:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           R:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           S:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           T:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           W:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           X:        \\DROBOSHARE\Drobo01      Microsoft Windows Network
    OK           Z:        \\DroboShare\Drobo03      Microsoft Windows Network
    OK                     \\DROBOSHARE\Drobo01      Microsoft Windows Network
    La commande s'est terminée correctement.

    Il doit y avoir un SALC (script à la con) qui a créé ces montages au démarrage, du style :
       NET USE * \\DROBOSHARE\Drobo01  /PERSISTENT:YES

    avec vraisemblablement changement de lettre, les précédentes apparaissant "in use".
    (il faudrait "investiguer" plus en détail, mais il me faudrait le PC sous les yeux)

    Il faut donc SUPPRIMER tous ces montages persistants :
    dans une fenêtre de commandes, exécute la commande :
       FOR %L in (A B E F G H I J K L M N O P Q R S T W Z) do NET USE %L: /DELETE
     Puis (p.ex.)
      NET USE X: \\DROBOSHARE\Drobo01 /PERSISTENT:NO 
      NET USE Y: \\DROBOSHARE\Drobo02 /PERSISTENT:NO
      NET USE Z: \\DROBOSHARE\Drobo03 /PERSISTENT:NO
    à mettre dans un batch p.ex., qui sera lancé au démarrage
     Il faudrait, en parallèle, chercher ce %*?#&! de batch ou script qui a créé ces montages ... (avec MSCONFIG p.ex.)
     --
    May the Force be with You!
    La Connaissance s'accroît quand on la partage
    ----------------------------------------------------------
    Jean-Claude BELLAMY [MVP Expert IT Pro]
    http://www.bellamyjc.org  ou http://jc.bellamy.free.fr

    lundi 18 juin 2012 16:19
  • Bonsoir les Experts !

    Les voies de l'informatique sont impénétrables....

    Depuis hier j'ai travaillé sur un autre site avec mon PC, sans connexion réseau.

    Mes unités "fantômes" apparaissaient toujours. Je les ai supprimées (clic droit supprimer, tout simplement). J'ai éteint et rallumé plusieurs fois ce PC (éteint, pas mis en veille), et de retour chez moi, quand j'ai rallumé, l'unité T:, correspondant au disque multimédia (appelé LaCie) est apparue en double (T: et Y:), en rouge avec la croix, ce qui était normal parce que ce disque dur était physiquement éteint (alimentation coupée), mais mes trois unités Drobo sont réapparues et se sont connectées normalement, sans autres instances "fantômes"...

    Seule bizarrerie, les lettres n'étaient plus X: Y: Z: mais U: V: et Z:

    Bon, j'avoue que je n'ai pas tout compris, mais laissé en l'état, j'ai rebooté 4 ou 5 fois à l'occasion de mises à jour (Windows, Photoshop, etc.) et tout revient tel quel après chaque reboot, LaCie en T: et Y:, les 3 Drobo en U: V: et Z:

    Je ne suis pas certain que ce soit définitivement réglé, mais pour l'instant tout va bien donc.

    Alors Merci ++++ de votre accueil et de votre aide, j'espère ne pas avoir à vous solliciter à nouveau !

    Thierry.

    • Marqué comme réponse Glimmerchef mardi 19 juin 2012 21:49
    mardi 19 juin 2012 21:48