none
Problème d'affichage de pilote d'imprimante sous W10 (1709) RRS feed

  • Question

  • Bonsoir,

    Une imprimante laser i-SENSYS LBP7200Cdn de Canon est installée sur mon ordinateur et comme le montre la capture d'écran suivante, elle fonctionne. Néanmoins la fenêtre Périphériques et imprimantes ne veut pas l'afficher (voir la deuxième capture qui suit).

    Deuxième capture :

    Mon imprimante est installée avec les derniers pilotes de Canon pour Windows 10 64bits.

    Que faire pour corriger ce défaut ?

    Merci de votre aide

    Antony

    samedi 16 décembre 2017 20:49

Toutes les réponses

  • Bonsoir,

    La commande "Get-Printer" sous powershell retourne quel résultat ?

    Si vous trouvez votre imprimante, vous pouvez essayer cette commande :
    Get-Printer | Where-Object {$_.Name -eq "LE NOM DE VOTRE IMPRIMANTE"} | Remove-Printer

    (en remplaçant donc LE NOM DE VOTRE IMPRIMANTE)

    Puis essayer de l'ajouter à nouveau

    dimanche 17 décembre 2017 17:13
  • Bonsoir,

    La commande "Get-Printer" renvoie :

    Name              ComputerName    Type         DriverName                PortName        Shared   Published
    ----                           ------------    ----         ----------                --------        ------   --------
    Send To OneNote 2016                           Local        Send to Microsoft OneN... nul:            False    False
    PDFCreator                                     Local        PDFCreator                pdfcmon         False    False
    HP Deskjet F2400 series                        Local        HP Deskjet F2400 series   USB003          False    False
    Fax                                            Local        Microsoft Shared Fax D... SHRFAX:         False    False
    Canon LBP7200C                                 Local        Canon LBP7200C            USB001          False    False

    Donc j'ai exécuté la commande :

    Get-Printer | Where-Object {$_.Name -eq "Canon LBP7200C"} | Remove-Printer

    Après réinstallation, maintenant, "Get-Printer" renvoie :

    Name                           ComputerName    Type         DriverName                PortName        Shared   Published  DeviceType
    ----                           ------------    ----         ----------                --------        ------   ---------  ----------
    Canon LBP7200C                                 Local        Canon LBP7200C            USB001          False    False      Print
    Send To OneNote 2016                           Local        Send to Microsoft OneN... nul:            False    False      Print
    PDFCreator                                     Local        PDFCreator                pdfcmon         False    False      Print
    HP Deskjet F2400 series                        Local        HP Deskjet F2400 series   USB003          False    False      Print
    Fax                                            Local        Microsoft Shared Fax D... SHRFAX:         False    False      Print

    Dans Périphériques et imprimantes l'imprimante ne figure toujours pas parmi les icônes disponibles...

    C'est dommage, car c'est tout de même plus pratique pour la placer (ou non) en imprimante par défaut.

    Merci de votre aide

    Antony


    • Modifié antony.pare dimanche 17 décembre 2017 18:56
    dimanche 17 décembre 2017 18:54
  • Pour la mettre par défaut, tu peux faire comme ça :

    $Printer = Get-WmiObject -Class Win32_Printer -Filter "Name='$("TON_IMPRIMANTE")'"
    $Printer.SetDefaultPrinter()

    (remplace TON_IMPRIMANTE ;-))

    Certains disent que l'antivirus peut faire ce problème, je n'ai pas vérifié cette information donc je te laisse tester si tu as envie (pour ma part, si j'en parle c'est que c'est plausible)

    EDIT: je te recolle le code ci-dessous, Visual Studio m'a copié collé les couleurs...
    $Printer = Get-WmiObject -Class Win32_Printer -Filter "Name='$("TON_IMPRIMANTE")'"
    $Printer.SetDefaultPrinter()



    dimanche 17 décembre 2017 19:06
  • Bonjour,

    Oui, C'est une méthode comme une autre pour sélectionner une imprimante par défaut... On peut aussi passer par la file d'attente d'impression et dans le menu imprimante sélectionner l'option.

    J'ai désinstallé totalement l'antivirus (Avira) et le pare-feu (Zone Alarm), mais ça ne résout pas la question de ce thread. Mon imprimante ne figure toujours pas dans la fenêtre Périphériques et imprimantes après sa réinstallation.

    L'avantage de l'utilisation de la fenêtre Périphériques et imprimantes c'est qu'on peut y récupérer l'icône de n'importe quelle imprimante et en faire un raccourci sur le bureau Windows :

    Toutes les options sont alors directement accessibles sans passer par d'autres utilitaires et menu ou par PowerShell.

    Merci pour votre aide

    Antony


    lundi 18 décembre 2017 15:33
  • NB :Le fait que cette imprimante figure dans la section "Autres périphériques" est-il normal ?
    lundi 18 décembre 2017 15:42
  • Bonjour.

    > NB :Le fait que cette imprimante figure dans la section "Autres périphériques" est-il normal ?

    Non, je ne le crois pas.

    Idem d'ailleurs pour l'imprimante "HP Deskjet F2400 series" dont on ne voit pas l'icône, et que vous êtes censé avoir, en compagnie du programme "HP Deskjet F2400 All-in-One Driver Software 14.0 Rel. 6" que j'ai vu dans votre rapport ZHPDiag du 16 décembre.


    Ex-helpeur de Community


    lundi 18 décembre 2017 16:12
  • Bonsoir Antony,

    Je suis très perspicace, et je vais donc te demander de tester une énième chose (deux enfaite)

    Peux-tu regarder dans le nouveau menu des imprimantes sur Windows 10 (Démarrer > la petite roue pour les paramètres > device > printers & scanners sur la gauche) et voir si par hasard tu ne vois pas l'imprimante...

    Tu pourrais également vérifier si les services sont bien démarré, les miens sont comme ça:

    (désolé, mon Windows est en anglais...)

    lundi 18 décembre 2017 21:26
  • Bonjour Romain,

    J'avais déjà consulté la liste des imprimantes dans ce nouveau gestionnaire, elle se présente ainsi :

    J'ai aussi essayé de rajouter l'imprimante par cet interface, mais sans succès non plus.

    Pouvez-vous montrer la capture d'écran des services qui sont démarrés sur votre machine ?

    Merci de votre aide

    Antony

    mardi 19 décembre 2017 09:41
  • Bonsoir antony,

    La capture d'écran que j'avais faites ne semble pas avoir fonctionné (encore newbie sur les forum technet...)

    J'ai fait un export via Powershell:

    DisplayName                          Name                      Status StartType
    -----------                          ----                      ------ ---------
    Device Association Service           DeviceAssociationService Running Automatic
    Device Install Service               DeviceInstall            Stopped    Manual
    DevQuery Background Discovery Broker DevQueryBroker           Stopped    Manual
    Device Management Enrollment Service DmEnrollmentSvc          Stopped    Manual
    Device Setup Manager                 DsmSvc                   Stopped    Manual

    Ils sont tous en "delayed start" sauf device management enrollment
    (je vous ai ajouté le nom du service en plus du nom affiché, ce sera plus pratique pour retrouver leur traduction)

    mardi 19 décembre 2017 19:14
  • Bonjour Romain,

    J'ai regardé dans l'onglet Services du Gestionnaire des tâches, j'ai tous ces services et dans le même statut. C'est à dire tous à l'arrêt sauf DeviceAssociationService qui est en cours d'exécution.

    Quelle est la commande sous PowerShell pour avoir ces mêmes informations ?

    Merci de votre aide

    Antony


    • Modifié antony.pare mercredi 20 décembre 2017 11:38
    mercredi 20 décembre 2017 11:38
  • Bonsoir Momominta,

    Je viens de reprendre la lecture de mon thread maintenant et vais tester la solution proposée...

    Merci beaucoup pour votre aide

    Antony

    jeudi 4 janvier 2018 18:46
  • Bonsoir,

    Je reviens "alimenter" mon thread...

    Les conseils donnés par Canon m'ont permis de régler ma configuration du point de vue du Gestionnaire de périphériques, en effet l'imprimante ne figurait pas dans la bonne rubrique, alors que maintenant elle est rentrée dans le "rang" :

    Mais pour ce qui est des Périphériques et imprimantes, le problème persiste.

    Autre point positif :

    Depuis que j'ai installé la dernière version du pilote Canon (de février 2017) l'imprimante a retrouvé l'usage de son tiroir à feuille que je pensais mécaniquement et/ou électroniquement définitivement défectueux.

    Alors puisqu'il en est ainsi, et que "le mieux n'est pas toujours l'ami du bien". Je pense en rester là pour la résolution de mon problème. On fera avec...

    Merci encore à vous Momominta et vous tous qui vous êtes penchés sur cette question.

    Antony

    jeudi 4 janvier 2018 20:51