none
[WSS3] Restore BD RRS feed

  • Discussion générale

  • Bonjour.

    Hier, on m'a demandé de supprimer une collection de sites... De suite après on m'annonce qu'il fallait pas la supprimer... Que du bonheur!

    Niveau sauvegardes on n'a que du SQL Server (pas de backup stsadm).

    J'ai essayé maintes fois avec addcontentdb mais sans succès.

    Dans les logs du serveur j'ai "impossible de se connecter à la base"...

    Auriez vous une idée svp..

    Merci
    vendredi 11 mars 2011 09:00

Toutes les réponses

  • Bonjour,

    Je dirais qu'il faut ajouter l'utilisateur qui est utilisé pour lancer la commande en tant que dbowner de la base de contenu

    La cinématique de création est la suivante (cf http://blogs.developpeur.org/fabrice69/archive/2009/09/28/sharepoint-comment-remonter-un-environnement-complet-si-on-ne-poss-de-plus-que-les-bases-de-contenu.aspx):

    Création de chaque Web Application

    A partir de maintenant, il nous faut créer chacune des Web Applications existante (suivant votre cas).

    Création de la Web Application

    • Créer une nouvelle Web Application avec les renseignements nécessaire (Ceux de l’ancienne) :
      • Host header + port TCP
      • Folder d’installation
    • Lors de la création, vous devez spécifier une nouvelle base de données pour cette Web Application (qui restera vide)
    • Surtout ne pas créer la collection de site racine !!!!

    Ajout de l’ancienne base de contenu

    • Remonter la base de contenu sur le serveur SQL (si elle n’est pas déjà présente) avec un SQL Restore
    • Utiliser la commande AddContenDB de STSADM :
      • STSADM -o addcontentdb -url http://myWebApplication –databasename “MyDataBaseName”
      • Les options sont à adapter suivant votre cas
    • On peut ensuite faire un petit IISReset pour recharger toute l’application Web

     Suppression de la base Vide (Créée lors de la première étape)

    • Simplement fait directement depuis la Centrale Admin
    • Ne pas oublier de supprimer cette base du moteur SQL Server

    Thierry Buisson

    vendredi 11 mars 2011 09:12
    Modérateur
  • Merci pour votre aide.

    J'ai ajouté à la commande addcontentdb le nom et mot de passe d'un utilisateur qui a les bons droits niveau sql server mais la commande échoue avec "échec de l'ouverture de session de l'utilisateur "...". L'utilisateur n'est pas associé à une connexion SQL Server approuvée"...

    Une idée?

    vendredi 11 mars 2011 09:49
  • Bonjour,

    Il s'agit bien d'un utilisateur de l'AD (pas SQL) ?

    Idéalement cette commande doit être lancée avec le compte système Sharepoint.

    Dans tous les cas il faut tester l'accès à cette base via le compte utilisé (en ODBC hors Sharepoint)

    Thierry Buisson

    vendredi 11 mars 2011 10:00
    Modérateur