none
Problème tracking licence utilisateur en infra RDS RRS feed

  • Question

  • Bonjour,

    Je travaille actuellement à la finalisation de la mise en place de mon infrastructure RDS. La dernière étape, qui me pose problème, est l'installation des CALs par Utilisateur.

    Voici un résumé rapide de l'infrastructure mise en place :

    ==> Domaine A :

    - Deux serveurs Web / gateway

    - Deux serveurs Broker / Licence

    - Deux serveur DC

    ==> Domaine B :

    - Ensemble des machines ayant besoin d'être accédées (donc installées avec le service RDSH)

    Il existe entre les deux domaine une approbation bi-directionnelle.

    Les utilisateurs qui se connectent sont exclusivement des utilisateurs du domaine B.

    Les connexions fonctionnaient bien, et utilisaient la période d'essai de 120 jours accordés. 

    Nous avons reçu en début de semaine les licences, et j'ai donc installé sur chaque serveur de licence 25 licences, pour un total donc de 50 licences.

    Voici les configurations que j'ai déjà effectué :

     - Dans le Remote Desktop Services (Deployment Properties), selection du type de licences (Per User), et ajout des deux serveurs de licence

    - Dans les serveurs de domaine A et B, ajout des deux serveurs de licence dans le groupe Terminal Server Licence Servers

    - Dans les serveurs de domaine A et B, ajout des GPO "Set the specified Remote Desktop licence servers" avec le nom complet des deux serveurs de licence, et "Set the Remote Desktop licensing mode" à "Per User"

    Il semble que cette configuration fonctionne, puisque lorsque la machine est bien à jour au niveau de la GPO (test avec un gpupdate /force), le message à la connexion indiquant qu'il reste X jours d'essai n’apparaît plus.

    Cependant, je voudrai en être certain, et cela m'amène à mon problème principal : Je n'arrive pas à avoir un tracking des licences utilisées. Lorsque je vérifie sur mes deux serveurs de licence les licences "Issued", le chiffre reste à 0, et le nombre de licences disponibles reste à 25.

    Lorsque je vérifie sur une machine RDSH via utilitaire RD Licensing Diagnoser, celui-ci commence par m'indiquer qu'il faut que je m'authentifie auprès des serveurs de licence pour qu'il puisse faire un check et me remonter les erreurs. Je pense que c'est normal, et lorsque l'authentification est faite, il m'indique qu'il n'y a pas de problème détecte.

    Quelqu'un aurait une idée pour le tracking se fasse enfin, que je puisse vérifier que l'attribution des licences se fait bien ?

    Merci par avance.


    • Modifié Lexo17 mercredi 9 mai 2018 08:22
    mercredi 9 mai 2018 08:17

Réponses

  • Bonjour,

    Il semble que le temps était mon meilleur allié... L'ensemble de configuration décrit ci-dessus fonctionne bien, le tracking est bien présent.

    Le dernier élément que j'ai configuré, et qui a visiblement débloqué la situation est la configuration de la GPO "Set the specified Remote Desktop licence servers" sur le DC du domaine A.

    Si ça peut aider :-)

    Cordialement

    mercredi 9 mai 2018 09:39
  • Bonjour,

    Juste pour informations je vous déconseille de paramétrer à différents endroit la même information :

    On spécifie le serveur de licence soit au niveau de la collection RDS via l'interface graphique soit via GPO mais le faire 2 fois me parait pas très judicieux en cas de besoin de débugage…

    Toutefois, dans le cas présent, les GPOs sont prioritaires au réglage graphique (c'est bon à savoir).

    Ensuite, le serveur de licence doit être spécifié par GPO sur les serveurs hotes de session car lorsqu'un utilisateur se connecte il se connecte au broker, le proker le redirige ensuite vers un serveur hote de session et c'est le serveur hote de session qui contacte ensuite le serveur de licence. C'est donc sur les hotes de session qu'il est nécessaire d'avoir la GPO concernant les serveurs de licence. Les DCs n'ont rien à voir dans ce processus.

    Toutefois, le problème semble résolu et c'est le plus important !


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    mercredi 9 mai 2018 13:14

Toutes les réponses

  • Bonjour,

    Il semble que le temps était mon meilleur allié... L'ensemble de configuration décrit ci-dessus fonctionne bien, le tracking est bien présent.

    Le dernier élément que j'ai configuré, et qui a visiblement débloqué la situation est la configuration de la GPO "Set the specified Remote Desktop licence servers" sur le DC du domaine A.

    Si ça peut aider :-)

    Cordialement

    mercredi 9 mai 2018 09:39
  • Bonjour,

    Juste pour informations je vous déconseille de paramétrer à différents endroit la même information :

    On spécifie le serveur de licence soit au niveau de la collection RDS via l'interface graphique soit via GPO mais le faire 2 fois me parait pas très judicieux en cas de besoin de débugage…

    Toutefois, dans le cas présent, les GPOs sont prioritaires au réglage graphique (c'est bon à savoir).

    Ensuite, le serveur de licence doit être spécifié par GPO sur les serveurs hotes de session car lorsqu'un utilisateur se connecte il se connecte au broker, le proker le redirige ensuite vers un serveur hote de session et c'est le serveur hote de session qui contacte ensuite le serveur de licence. C'est donc sur les hotes de session qu'il est nécessaire d'avoir la GPO concernant les serveurs de licence. Les DCs n'ont rien à voir dans ce processus.

    Toutefois, le problème semble résolu et c'est le plus important !


    Merci de marquer comme reponses les interventions qui vous ont ete utile.

    mercredi 9 mai 2018 13:14