none
Installation Serveur TSE / Problème mode de licence du serveur hôte de session Bureau à distance n'est pas configuré RRS feed

  • Question

  • Bonjour,

    Je prépare actuellement un serveur TSE en remplacement de l'ancien qui a des signes de faiblesse, mais je rencontre une petite difficulté que je n'arrive pas à résoudre malgré les divers articles sur Internet.

    Il s'agit d'un serveur sous server 2012 R2, j'ai installé les différents rôles servant à la bonne utilisation du bureau à distance, mes CAL RDS sont bien ajoutés dans le gestionnaire de licence, mon serveur est bien actif, mais lorsque je vais dans Diagnostic des licences SBD, ça m'indique le problème suivant : "Le mode de licence du serveur hôte de session Bureau à distance n'est pas configuré".  Comme proposition de résolution, j'ai : "Attribuez au mode de licence du serveur hôte de session de Bureau à distance la valeur Par Utilisateur ou Par Périphérique. Utilisez le Gestionnaire de licence des services Bureau à distance pour installer les licences correspondantes sur le serveur de licences.

    J'ai pourtant bien indiqué lors de la configuration "passerelle des services bureaux à distance" d'utiliser le mode Par Utilisateur, mais je ne sais pas si celui-ci a bien été pris en compte, ou si j'ai oublié de faire autre chose quelque part.

    Je ne sais pas si j'ai été bien clair, n'hésitez pas à me demander plus de détails.

    Merci de votre aide.

    jeudi 10 mars 2016 16:26

Réponses


  • Bonjour,
    La description du problème est assez claire. Merci.

    Pouvez-vous vérifier dans votre déploiement (dans le gestionnaire du serveur, au niveau de l'overview ) si vous avez bien ajouter le serveur de licence et si dans votre déploiement la licence est bien mise "Per User" ?

    Vous pouvez vérifier ce point rapidement en Powershell

    Get-RDLicenseConfiguration -ConnectionBroker "broker.domain.local"

    Il devrait retourner votre mode de licence et le serveur spécifié.

    Si il ne retourne rien, vous pouvez le configurer dans votre option de déploiement ou bien en Powershell à nouveau :

    Set-RDLicenseConfiguration -Mode PerUser -ConnectionBroker "broker.domain.local"
    Si l'option était bien définie, nous irons un peu plus loin.

    https://technet.microsoft.com/en-us/library/jj215465.aspx



    jeudi 10 mars 2016 17:16

Toutes les réponses


  • Bonjour,
    La description du problème est assez claire. Merci.

    Pouvez-vous vérifier dans votre déploiement (dans le gestionnaire du serveur, au niveau de l'overview ) si vous avez bien ajouter le serveur de licence et si dans votre déploiement la licence est bien mise "Per User" ?

    Vous pouvez vérifier ce point rapidement en Powershell

    Get-RDLicenseConfiguration -ConnectionBroker "broker.domain.local"

    Il devrait retourner votre mode de licence et le serveur spécifié.

    Si il ne retourne rien, vous pouvez le configurer dans votre option de déploiement ou bien en Powershell à nouveau :

    Set-RDLicenseConfiguration -Mode PerUser -ConnectionBroker "broker.domain.local"
    Si l'option était bien définie, nous irons un peu plus loin.

    https://technet.microsoft.com/en-us/library/jj215465.aspx



    jeudi 10 mars 2016 17:16
  • Bonjour,

    Merci de votre aide.

    Je vous confirme qu'il m'a bien retourné le mode de licence (PerUser) ainsi que le serveur de licence spécifié, donc l'option était bien définie.

    Que souhaitez-vous que je fasse désormais ?


    • Modifié Mazar75 vendredi 11 mars 2016 13:41
    vendredi 11 mars 2016 10:39
  • Est-ce le nom netbios ou le nom FQDN dans la config ?

    Est-ce vous utilisez une GPO quelconque pour contrôler le licensing ?
    Il sera interrésant de vérifier sur vos hôtes RDS cette stratégie :

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing

    Si vide, essayez de spécifier votre RD Licensing là et redémarrer l'hôte. (gpupdate computer)

    samedi 12 mars 2016 01:05
  • C'est le nom FQDN dans la config.

    Dans la GPO "Gestionnaire de licences" sur l'AD, j'ai ajouté le serveur actuel (en plus de l'ancien qui était déjà inscrit).

    J'ai fais gpudate, redémarrer le serveur TSE, ainsi que l'AD, mais toujours la même chose dans "Diagnostic des licences des services bureaux à distance" sur le nouveau serveur, ça me dit toujours que le mode de licence du serveur hôte de session Bureau à Distance n'est pas configuré.


    • Modifié Mazar75 mercredi 16 mars 2016 15:46
    lundi 14 mars 2016 15:27
  • Je récapitule pour que tout soit bien claire :

    Je dispose actuellement d'un serveur AD sous 2008, et d'un TSE sous 2003.

    Ce dernier est trop vieux, je le remplace par un 2012 R2.

    J'ai installé les services de Bureau à Distance, j'ai installé/validé les licences CAL RDS achetés au préalable (dans le gestionnaire de licence, elles apparaissent bien en valide, avec le petit logo de validation vert).

    J'ai bien précisé qu'il s'agit de licence par Utilisateur, et que le serveur de licence est bien le 2012.

    Au niveau de l'AD, j'ai ajouté dans la GPO le nom du nouveau serveur de licence.

    Malgré toutes ces différentes choses, dans "Diagnostic des licences des services bureaux à distance" sur le nouveau serveur, ça me dit toujours que le mode de licence du serveur hôte de session Bureau à Distance n'est pas configuré.

    Quelqu'un a une idée ?

    Merci de votre aide.

    vendredi 18 mars 2016 10:01
  • Bonjour,

    Je suis dans la même situation que vous, avez-vous depuis trouvé une solution à votre problème ?

    En vous remerciant.

    Renaud

    jeudi 21 juillet 2016 11:16