none
très grosse erreur de manipulation lors d'un transfert exchange 2003 vers un exchange 2010 RRS feed

  • Discussion générale

  • Bonjour,

    lors d'un migration d'un serveur exchange 2003 (en production) vers un nouveau serveur w2008 r2 Exchange 2010 SP1 nous avons fait une très grosse erreur de manipulation avec la commande robocopy.

    Je m'explique :

    l'installation du serveur 2008r2 c'est parfaitement passé. Nous l'avons joint en tant que controleur de domaine AD sans difficulté. Le serveur windows 2003 avec exchange 2003 doit à terme complétement disparaitre.

    L'installation d'exchange 2010 SP1 c'est parfaitement réalisé. Il a bien été créé une "exchange administrative group" dans la console d'administation exchange 2003 (avec un nom affiché composé de lettres et de chiffres). Dans cette "exchange administrative group", les connecteurs ont bien créé pour communiquer entre le serveur exchange 2003 et le 2010.

    J'ai d'ailleurs pu tester le déplacement d'une boite aux lettres qui n'était plus utilisé sans problèmes.

    J'ai modifier les réplications des dossiers publics. Il n'y avait pas de connecteurs SMTP.

    Nous ne sommes pas allez plus loin dans le transfert exchange 2003 vers 2010.

    La très grosses erreurs est arrivées à ce moment : Nous avons utilisés la commande robocopy pour copier un répertoire de fichiers bureautiques vers le disque dur d: du serveur w2008r2. C'est sur le disque dur d: que j'avais installer Exchange 2010. La commande robocipy a purgé mon disque dur D: et supprimé mon exchange 2010.

    Nous avons essayé de récupérer les fichiers supprimées avec un utilitaire undelete, mais cela n'a rien résolu, la console exchange n'a pas redémarré ainsi que certains services.

    Nous avons pris la décission d'essayer la désinstallation d'exchange 2010 ou de réinstaller sans succés.

    Bref, nous avons rebasculer les droits FSMO sur le serveur 2003, et effectué un DCPROMO rétroactif du serveur 2008r2 pour pouvoir le formater et rélancer l'installation.

    Pour le moment, l'organisation exchange 2003 fonctionnent sauf pour le carnet d'adresse en mode hors connexion.

    Mon soucis principal (pour le moment) est que je me trouve avec une "exchange administrative group" dans la console exchange 2003 que je n'arrive pas à supprimer et, qui va surement m'empécher de tenter une réinstallation d'exchange 2010.

    est ce que l'outil adsiedit peut m'aider à nettoyer mon organisation exchange 2003 ?

    merci d'avance

     

    Christian CASTEL


    Christian
    • Type modifié Florin Ciuca mercredi 14 décembre 2011 12:19 attente de feedback
    samedi 10 décembre 2011 13:28

Toutes les réponses

  • Bonsoir,

    oui, l'outil ADSIEDIT.MSC pourrait vous permettre de supprimer le nouveau groupe administratif, mais je ne pense pas que sa suppression soit utile.

    Si Exchange 2010 n'a pas (réellement) été désinstallé, il est normalement possible de réinstaller un serveur de même nom, puis d'utiliser l'option /m:recoverserver pour réinstaller et reconfigurer un serveur Exchange identique en configuration à celui qui était installé.

    Si cette option ne fonctionne pas du tout, on pourra alors penser à supprimer le serveur Exchange 2010 dans ADSIEDIT.MSC !

    Bon courage!

     


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    dimanche 11 décembre 2011 20:40
    Modérateur
  • Bonjour Thierry

     

    merci pour ta réponse rapide.

    le client m'a planifié la deuxième tentative mi-février prochain.

    Je vais faire une maquette pour tester cela  et je vous tiens au courant.

     

    cordialement


    Christian
    lundi 12 décembre 2011 10:51