locked
RPC_IN_DATA et RPC_OUT_DATA Exchange 2013 TMG 2010 Outlook anywhere RRS feed

  • Question

  • Bonjour à tous, 

    je rencontre actuellement un problème avec mon serveur exchange 2013 et un TMG 2010.

    La configuration est la suivante :

    LAN (client, serveur exchange,..) => TMG => WAN

    Lorsque je me connecte via outlook au serveur de messagerie a l'intérieur du réseau local, je ne rencontre aucun problème, l'autodiscover fonctionne parfaitement.

    Lorsque je me connecte via l'ip public, avec la configuration Exchange => WAN, je ne rencontre aucun problème également.

    En revanche, lorsque je me connecte via l'ip public avec un TMG entre mon LAN et le WAN, il m'est impossible d'utiliser outlook.

    Le client me demande toujours mon mot de passe.

    J'ai bien publié les règles a l'intérieur de mon TMG pour autodiscover.mondomain.com et mail.mondomain.com

    Les enregistrements DNS existent, la découverte automatique fonctionne (test effectué sur https://testconnectivity.microsoft.com/)

    J'ai réussi a récupérer l'erreur suivante via le TMG :

    Connexion refusée

    TMG 25/02/2015 11:17:19

    Type de journal : <id id="L_LogPane_WebProxyForward">Proxy Web (inverse)</id>

    État : 12309 Le serveur requiert l'autorisation d'exécuter la demande. L'accès au serveur Web est refusé. Contactez l'administrateur du serveur.

    Règle : Exchange 2013 EWS, OAB, OA, AutoD and Apps

    Source : 192.168.2.122:52194

    Destination : 192.168.2.121:443

    Demande : RPC_IN_DATA http ://mail.domain.com/rpc/rpcproxy.dll?acdc0cf0-3ee3-44c1-8048-3489fd6da163@domain.com:6002

    Informations sur les filtres : Req ID: 0a5ce796; Compression: client=No, server=No, compress rate=0% decompress rate=0% ; FBA cookie: exists=no, valid=no, updated=no, logged off=no, client type=unknown, user activity=yes

    Protocole : https

    Utilisateur : anonymous


    Connexion refusée

    TMG 25/02/2015 11:17:19

    <id id="L_LogPane_LogType">

    Type de journal : <id id="L_LogPane_WebProxyForward">Proxy Web (inverse)</id>

    </id>
    <id id="L_LogPane_Status">

    État : 12309 Le serveur requiert l'autorisation d'exécuter la demande. L'accès au serveur Web est refusé. Contactez l'administrateur du serveur.

    </id>
    <id id="L_LogPane_Rule">

    Règle : Exchange 2013 EWS, OAB, OA, AutoD and Apps

    </id>
    <id id="L_LogPane_Source">

    Source : 192.168.2.122:52195

    </id>
    <id id="L_LogPane_Destination">

    Destination : 192.168.2.121:443

    </id>
    <id id="L_LogPane_Request">

    Demande : RPC_OUT_DATA http://mail.domain.com/rpc/rpcproxy.dll?acdc0cf0-3ee3-44c1-8048-3489fd6da163@domain.com:6002

    </id>
    <id id="L_LogPane_FilterInfo">

    Informations sur les filtres : Req ID: 0a5ce799; Compression: client=No, server=No, compress rate=0% decompress rate=0% ; FBA cookie: exists=no, valid=no, updated=no, logged off=no, client type=unknown, user activity=yes

    </id>
    <id id="L_LogPane_Protocol">

    Protocole : https

    </id>
    <id id="L_LogPane_User">

    Utilisateur : anonymous

    </id>

    Mes paramètres d'authentification sont les suivants :

    get-outlookanywhere | fl *auth*

    ExternalClientAuthenticationMethod : Basic
    InternalClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods           : {Basic, Ntlm}
    IISAuthenticationMethods           : {Basic, Ntlm}

    Au niveau du TMG :

    - Règle pour ActiveSync : fonctionne

    - Règle pour OWA : fonctionne

    -Règle pour Anywhere : fonctionne partiellement comme dit plus haut.

    Mes paramètres pour la règle Anywhere sont les suivants :

    - Nom public = autodiscover.domain.com et mail.domain.com

    - Délégation de l'authentification : De base

    - Chemin d'accès : /rpc/*, /owa/guid@domain.com/*,  /OAB/*, /EWS/*, /AutoDiscover/*

    Au niveau du listener, je suis en "authentification des formulaires HTML"

    D’ou cela peut-il venir ?

    Merci d'avance,

    Cordialement

    mercredi 25 février 2015 13:32

Réponses

  • Problème résolu, il fallait autoriser "tous les utilisateurs" dans la règle pour Outlook Anywhere sous l'onglet utilisateur.

    Cdt

    • Marqué comme réponse KpR_ mercredi 4 mars 2015 16:35
    mercredi 4 mars 2015 16:35

Toutes les réponses