none
How to change Date field displaying date in UTC format to MM/DD/YYYY on InfoPath 2013 form?

    Question

  • I have  an InfoPath form and one of the fields displays the date in UTC format(ex: 2018-03-22T00:00:00Z) bordered  by red dashed lines with 'Only Date Allowed' error.

     I would like to know how this can be changed so that it displays date in MM/DD/YYYY format.

    Any help is appreciated. Thank you in advance.

    Regards

    SLS




    • Modifié SLS22 lundi 9 juillet 2018 15:52
    lundi 9 juillet 2018 15:50

Toutes les réponses

  • Hi SLS,

    How do you display the date in UTC format? Using a date picker field or a custom solution?

    Also please provide the screenshot of your red dashed lines error.

    You can apply the following steps to achieve your purpose:

    1. Right click on the date field to edit its properties.

    2. Click on the “Format” button besides the data type, and pick the format you desired. Then check the results.


    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    mardi 10 juillet 2018 06:24
  • Hi Allen,

    Thank you for your response. Here is the screenshot of the error displayed:

    I changed it to 'Date and Time' and 'Do not display time' under 'Format' but got the below error and it failed to publish to the form library. 

    Appreciate your help.

    Regards

    SLS

    


    • Modifié SLS22 mardi 10 juillet 2018 22:34
    mardi 10 juillet 2018 19:27
  • Hi SLS,

    1. Are you creating the rule of this field to use Today()? If yes, use the "now()" function instead of "today()" function.

    2. What is your date type? Try to use "Date" as your Date Type.

    3. Go to Site settings > Regional Settings and check your time zone. Maybe the timezone of your SP site does not match the format in your form.

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    mercredi 11 juillet 2018 06:35
  • Hi Allen,

    Below are the answers to the questions --

    1. Yes, initially it was today() function. 

    Changed it to now() 

    2. Data Type was 'Date and Time' with 'Do no Display Time'

    Changed it to 'Date' with mm/dd/yyyy format

    3. Checked the regional settings and they seem to be fine.

    I believe the reason is ' InfoPath(Product Activation failed)' error at the top.

    Thank you so much for all your help and time.

    Regards

    SLS

    mercredi 11 juillet 2018 17:38
  • Hi SLS,

    This mean there is license error on your InfoPath product. You need to first solve this issue(repair your office package). 

    You can try to use the activation troubleshooter:

    https://support.office.com/en-us/article/Unlicensed-Product-and-activation-errors-in-Office-0d23d3c0-c19c-4b2f-9845-5344fedc4380 

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 12 juillet 2018 03:01
  • Hi Allen,

    Thank you. That helped and now the product acivation error is gone but i still see the publish failed error.

    After i made the changes to data type and clicked on 'Save', here is the message i received. 

    Any ideas if anything else could be the reason? 

    Regards

    SLS


    • Modifié SLS22 jeudi 12 juillet 2018 21:38
    jeudi 12 juillet 2018 20:29
  • Hi SLS,

    Are you using the "Quick publish" button to publish the form? I don't ever get these messages, so my guess is that you have an alternate access mapping (AAM) issue.

    Click "File" > Designer Checker to find incompatibilities in your form template.

    In addition, do you have a root site in your web application?

    Best regards,

    Allen Bai



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 13 juillet 2018 02:49
  • Hi Allen,

    I clicked on Save and received that message. When i clicked publish and chose SharePoint Server->Form Library->Path>Publish

    The same is the case with 'Quick Publish'.

    How do i know if there is an alternate access mapping and where can i specify it? I am sorry but i am new to InfoPath forms.

    I checked in the 'Design Checker' and there are no incompatibilities.

    Regards

    Sravya

    vendredi 13 juillet 2018 21:45
  • Hi Sravya,

    AAM need to deploy manually. Since you do not know more about AAM, this may not be an issue about AAM.

    Since you are new to InfoPath form, I think it is related to your steps. Please provide your detailed steps about creating the InfoPath from, I will follow your steps to test in my environment.

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    mardi 17 juillet 2018 08:51