none
Exchange 2013 - MAPI sur HTTP RRS feed

  • Question

  • Bonjour,

    depuis hier, j'ai activé MAPI sur mon serveur Exchange 2013.

    A l'ouverture de mon client Outlook 2013.

    J'ai ce message d'erreur d'Alerte:

    ** Le certificat de sécurité émane d'un organisme de certification digne de confiance (OK)

    ** La date du certificat de sécurité est valide (OK)

    ** Le nom sur le certificat de sécurité n'est pas valide ou ne correspond pas au nom de ce site (NOK)

    Pouvez SVP m'aider.

    Merci

    Ahoko

    mardi 13 décembre 2016 08:00

Réponses

  • Avez-vous bien respecté les pre-requis? et notamment la création de la variable systeme COMPLUS_DisableRetStructPinning

    https://technet.microsoft.com/fr-fr/library/dn635177%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    mercredi 14 décembre 2016 20:11

Toutes les réponses

  • Bonjour,

    L'activation a ete suivi de la modification des url /mapi?

    merci


    Hakim Taoussi - Consultant Exchange - http://exchangediscover.blogspot.fr

    mardi 13 décembre 2016 09:22
  • Bonjour,

    Oui.

    Voici ce que j'ai fait:

    Set-MapiVirtualDirectory -id "exch2013\mapi (Default Web Site)" -InternalUrl "https://exch2013/mapi" –ExternalUrl "https://mail.ahoko.fr/mapi" -IISAuthenticationMethods NTLM

    mon url internet: owa.ahoko.fr

    mon url externe: mail.ahoko.fr

    Je ne sais pas si à la place de exch2013\mapi, jedois mettre owa.ahoko.fr\mapi.

    Merci

    Ahoko

    mardi 13 décembre 2016 10:06
  • Bonjour

    est-ce que "exch2013" est dans votre certificat?

    mardi 13 décembre 2016 11:02
  • Non "exch2013" n'est pas dans mon certificat.

    voici ceux qui sont ds mes certificats:

    mon url internet: owa.ahoko.fr

    mon url externe: mail.ahoko.fr

    Que faire?

    Merci pour votre retour

    Ahoko

    mardi 13 décembre 2016 11:12
  • dans ce cas, modifiez l'internal url MAPI et configurez la comme l'external url

    https://mail.ahoko.fr/mapi

    mardi 13 décembre 2016 11:15
  • ça serait pas mieux de modifier l'internal url MAPI avec mon url interne: owa.ahoko.fr/mapi?

    Merci pour votre retour

    mardi 13 décembre 2016 11:35
  • Comme pour les autres VDIR, l'important c'est que la résolution DNS fonctionne et que le certificat match les nom fournis dans les paramètres du VDIR.

    Si

    mon url internet: owa.ahoko.fr

    mon url externe: mail.ahoko.fr

    Alors

    Set-MapiVirtualDirectory -id "exch2013\mapi (Default Web Site)" -InternalUrl "https://owa.ahoko.fr/mapi" –ExternalUrl "https://mail.ahoko.fr/mapi" -IISAuthenticationMethods NTLM


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr


    mardi 13 décembre 2016 12:53
    Modérateur
  • Bonjour,

    Est ce que je peux lancer maintenant la commande afin d'apporter la modification.

    Ou attendre quand les users ne seront plus connecté.

    MErci

    mardi 13 décembre 2016 14:30
  • Vous pouvez apporter la modification maintenant, cela ne coupera pas les accès en cours. Lors du prochain Autodiscover réalisé par Outlook, celui-ci essaiera de basculer sur la nouvelle InternalURL, et si elle ne fonctionne pas, l'externalURL.

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 13 décembre 2016 14:45
    Modérateur
  • OK,

    Dois je redemarrer IIS, apres la manipulation?

    Merci 

    mardi 13 décembre 2016 14:49
  • Non, cela va prendre un peu plus de temps avant que cela soit actif, mais redémarrer IIS va impacter les utilisateurs.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mardi 13 décembre 2016 14:53
    Modérateur
  • OK,

    Merci pour vos conseils ingénieux.

    Je vous tiens au courant

    Merci

    mardi 13 décembre 2016 14:56
  • Ca marche.

    Merci

    mardi 13 décembre 2016 16:23
  • Bonjour,

    Je reviens vers vous, car après la manipulation, tout a l'air de fonctionner.

    Mais certains utilisateurs, rencontre des problèmes.

    Outlook se déconnecte et demande intempestivement le mot de passe.

    Pouviez vous me dire les étapes a vérifier pour sa résolution

    Merci

    Ahoko

    mercredi 14 décembre 2016 20:04
  • Avez-vous bien respecté les pre-requis? et notamment la création de la variable systeme COMPLUS_DisableRetStructPinning

    https://technet.microsoft.com/fr-fr/library/dn635177%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    mercredi 14 décembre 2016 20:11
  • Bonjour,

    creer

    Non j'ai pas  cette variable.

    Puis je la creer maintenant que le serveur est en production?

    A la fin de la création, dois je redémarrer le serveur?

    merci de votre retour

    jeudi 15 décembre 2016 08:28
  • Oui vous pouvez la créer maintenant. Pour le redémarrage, je pense que c'est mieux de le faire
    jeudi 15 décembre 2016 08:29
  • Bonjour,

    Tout fonctionne bien après avoir creee la variable.

    Merci

    lundi 19 décembre 2016 11:43
  • Bonjour.

    C'est parfait. N'oubliez pas de fermer le thread en marquant les post qui vous ont aidé à résoudre votre problème.

    lundi 19 décembre 2016 12:53