locked
Désinstallation de SCEP (forefront) RRS feed

  • Question

  • Bonjour,

    J'essaye en vain de désinstaller SCEP sur tous nos postes (300).

    J'ai donc fait une GPO avec un petit script de démarrage.

    Seulement lorsque j’exécute le script manuellement j'obtiens  une erreur me disant que l'option /u est invalide.

    Voici le script:

    ------------------------------------------debut--------------------------------------------------------

    reg query HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{A370C527EF4A-4172B1F6-310C121BAB02}
    if %ERRORLEVEL% EQU 0 goto INSTALL

    GOTO end

    :INSTALL

    cmd.exe /c "\\WONDERBOX.lan\wbx\install$\SCEPInstall.exe" /u /s
    start /W ""\\Server\fsroot\install$\SCEPInstall.exe"" /u /s
    start /w "%ProgramFiles%\Microsoft Security Client\setup.exe /u /s"
    call ""\\Server\fsroot\install$\SCEPInstall.exe"" /u /s

    :end
    PAUSE

    ------------------------------------fin-----------------------------------------------------------------------

    Y'a t'il une autre solution,sachant que nous n'avons déjà décomissioné SCCM?

    Aidez moi s'il vous plait je m'arrache les cheveux avec  ça depuis une semaine.


    Orwell

    vendredi 31 octobre 2014 14:16

Toutes les réponses

  • Bonjour,

    je n'ai pas ce qu'il faut sous la main pour le tester immédiatement, et de tête j'ai un tour, mais cette erreur vous arrive sur quelle commande du script?

    En effet, il y a une incohérence entre l'écriture des guillements:

    start /W ""\\Server\fsroot\install$\SCEPInstall.exe"" /u /s

    start /w "%ProgramFiles%\Microsoft Security Client\setup.exe /u /s"

    Je sens bien la tentative d'executer un { start xxxx /u }

    J'espère que cela pourra vous aider.

    Bon week-end,

    Laurent Dumont

    vendredi 31 octobre 2014 16:29
  • Bonjour,

    J'ai modifié le script en remplacant

    start /W ""\\Server\fsroot\install$\SCEPInstall.exe"" /u /s

    par

    start /W ""\\Server\fsroot\install$\SCEPInstall.exe /u /s""

    Mais il ne se désinstalle toujours pas.

    J'ai plus de cheveux... Help please


    Orwell

    mardi 4 novembre 2014 23:47
  • Bonjour,

    SCEP ne se désinstalle toujours pas.

    Any help ??

    voici le script que je lance:

    ---------------------------------------debut script -----------------------------------

    rem @echo off

    reg query HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{A370C527-EF4A-4172-B1F6-310C121BAB02}
    if %ERRORLEVEL% EQU 0 goto INSTALL

    GOTO end

    :INSTALL


    start /W ""\\Server\fsroot\install$\SCEPInstall.exe /u /s""
    start /w ""%ProgramFiles%\Microsoft Security Client\setup.exe /u /s""
    start /w "%ProgramFiles%\Microsoft Security Client\setup.exe /u /s"
    start /W "\\Server\fsroot\install$\SCEPInstall.exe /u /s"
    start /W \\Server\fsroot\install$\SCEPInstall.exe /u /s
    :end

    -------------------------------------fin script ----------------------------------------------------


    Orwell

    vendredi 7 novembre 2014 13:55
  • Bonjour,

    Désolé de ne pas avoir répondu plus tôt.

    A priori je n'ai pas d'idée "toute faite"....

    Savez vous sur quelle ligne votre erreur s'affiche?

    Laurent Dumont

    vendredi 7 novembre 2014 19:56
  • Bonjour,

    finalement j'ai retiré le start /w pour ne laisser que ceci

    \\Server\fsroot\install$\SCEPInstall.exe /u /s

    et vérification faite la désinstallation fonctionne parfaitement lorsque je lance le script manuellement.

    Mais quand le script s’exécute au démarrage d'ordinateur (par GPO) , l'application ne se désinstalle pas.


    Orwell

    dimanche 9 novembre 2014 11:29
  • Bonjour Laurent,

    Avez vous une idée de ce qui cloche?

    Le script s’exécute parfaitement depuis un profile administrateur mais en script de démarrage d'ordinateur il ne s’exécute pas.


    Orwell

    mercredi 12 novembre 2014 11:04
  • Bonjour,

    désolé pour le délais de réponse, mais je crois que je viens de comprendre à votre avant dernier post...

    Je ne suis pas sur mais c'est une piste probable... Pouvez vous controler les droits sur votre partage?

    L'ordinateur utilise un compte spécifique qui n'est pas "utilisateurs du domaine" mais "ordinateurs du domaine" ("domain computers", je ne suis plus sur du Français ;) ). Il est probable qu'il n'ai pas accès au partage.

    Pouvez vous vérifier cela et me faire un retour?

    Merci,

    Laurent

    jeudi 13 novembre 2014 08:42
  • Bonjour Laurent,

    Le partage est bien configuré, y a en effet le groupe ordinateurs du domaine  et le groupe utilisateurs authentifiés sur le partage avec les droits de partage full et les droits NTFS (readonly).


    Orwell

    jeudi 13 novembre 2014 14:03
  • Essayez de tracer l'erreur du script en ajoutant à la fin de chaque ligne un ">>c:\script_SCEP.log"

    Ensuite dans le log il sera plus simple de voir l'erreur remontée lors de l'execution.

    Laurent

    jeudi 13 novembre 2014 14:40
  • Bonsoir Laurent,

    J'ai mis en place la redirection la semaine dernière comme tu me l'as indiqué cependant j'ai l'impression que le script ne s’exécute même pas puisque je n'ai aucun fichier de log qui est créé.


    Orwell

    lundi 17 novembre 2014 17:36
  • Bonsoir,

    si vous commenciez le script par un "echo début de script >>c\script_SCEP.log" pour vérifer déja si le script s'execute?

    Pour ma part sinon j'avais souvent un partage "tout le monde controle total" (caché) sur le réseau pour centraliser les executions de script, avec un %computername% dans le nom du log par exemple...

    Si effectivement il ne laisse pas de trace et qu'il ne s'execute pas, il faudra voir un peu plus en détails côté GPO...

    Dites moi ce qu'il en sort.

    Bonne journée,

    Laurent

    lundi 17 novembre 2014 19:57
  • Il me semble que le problème vient plus des permission du GPO qui est appliquer dans le contexte de l'ordinateur et l'ordinateur n'a pas la permission de désinstaller un programme simplement.

    Par quoi as tu remplacer SCCM si tu l'as déjà désinstaller ?

    On sait que ta command fonctionne, dans il reste plus qu'un probleme de droit d'utilisateur ou d'ordinateur.

    Malheureusement avec les GPO, c'est pas facile a désinstaller le tout .

    vendredi 21 novembre 2014 13:14
  • Bonsoir,

    Je l'ai pas encore désinstallé, mais comme nous n'avons pas de licence SCCM et qu'on vient d'avoir un contrôle, je ne devrais plus l'utiliser.

    Tu dis l'ordinateur n'a pas la permission de désinstaller SCEP, alors comment puis-je la lui donner?

    En plus j'ai voulu désinstaller avec SCCM et je n'ai pas réussi.


    Orwell

    vendredi 21 novembre 2014 21:26
  • Bonjour,

    dans quelle stratégie le script est il lancé dans les GPO?

    Ou est situé le script en question?

    Quels sont les droits du partage ou est situé le script?

    A priori il n'y a pas de raisons de ne pas y arriver, mais il peut parfois y avoir quelques grains de sable...

    Bonne journée,

    Laurent

    lundi 24 novembre 2014 10:58
  • Bonjour Laurent,

    Au niveau GPO, le script est positionné ainsi:

    Computer > Windows Settings> scripts > startup script

    Au niveau smb le script se trouve ici:

    \\Server\fsroot\install$\

    et les droits sur le share install$ sont :

    Autorisations de partage: Full control pour les groupes utilisateurs authentifiés et ordinateurs du domaine

    Autorisations de sécurité: Full control pour les groupes utilisateurs authentifiés et ordinateurs du domaine

    Voilà


    Orwell

    mercredi 26 novembre 2014 12:01
  • Bonjour...

    Pas simple à priori, mais sinon on ne serais pas sur ce forum ;)

    Avez vous d'autres scripts de démarrage?

    Si oui, se lancent ils du même share?

    Sinon, vous est il possible de faire un script tout bête du genre:

    ----------

    @echo %computername% >>\\Server\fsroot\install$\logs\test.log

    @echo %computername% >c:\test.log

    ----------

    juste histoire de vérifier si le script s'execute, si il arrive à lire sur le partage et si il arrive à écrire en mode admin en local....

    Laurent

    mercredi 26 novembre 2014 12:48
  • Oui je vais essayer de faire ça dans l'après midi et de faire une retour dans la volée.

    Merci de ton aide


    Orwell

    mercredi 26 novembre 2014 12:52