none
Accès Exchange 2010 impossible depuis l'exterieur avec Outlook RRS feed

  • Question

  • Bonjour,

    Nous avons migré un serveur Exchange 2003 vers un serveur 2010.

    Tout fonctionne en interne, mais impossible de se connecter à Exchange depuis l'exterieur.

    Sauf depuis un Iphone et un Samsung Galaxy. Donc depuis les smartphones ça fonctionne bien. Mais Outlook ne trouve pas le serveur.

    En VPN, cela fonctionne jusqu'à Outlook 2013. Pas le 2016. J'ai l'erreur suivante :

    Connexion au serveur de messagerie Exchange ActiveSync (EAS): Serveur introuvable.

    Sur mon routeur, j'ai redirigé les ports suivants vers le serveur Exchange :
    993,143,5060,5061,5062,25,465,110,587,80,443.

    Merci de votre aide

    Résultat du test microsoft : https://testconnectivity.microsoft.com



    mercredi 22 juin 2016 08:42

Réponses

  • Je me réponds à moi-même :

    Pour le certificat, s'il est généré en interne, il faut effectivement l'installer sur les postes locaux. L'idéal serait d'avoir un certificat généré par une autorité de certification reconnue mais c'est couteux.

    Cependant, cette action n'avait pas résolue mon problème. En effet, Outlook utilise le chemin dns autodiscover.mondomaine.fr pour se connecter. Lorsque je suis en local, pas de problème. Mais dans mon cas, les postes sont sur un autre site connecté en VPN (IPSec site à site).

    Depuis Outlook 2013 et 2016, il ne trouve pas l'autodiscover sur le LAN mais il fait une recherche sur l'externaldns. Il considère donc que c'est une connexion depuis l'exterieur du LAN pour atteindre le serveur de messagerie.

    Il faut donc modifier la zone DNS (chez votre gestionnaire de nom de domaine) avec le champ SRV autodiscover (tcp et port 443) vers le dns mailhost.mondomaine.fr

    mailhost.mondomaine.fr étant la redirection externe définit pour renvoyer vers le serveur de messagerie.

    Problème résolu ;-)

    vendredi 19 août 2016 11:38

Toutes les réponses

  • Bonjour,

    le certificat est privé et non public?

    avez vous tester en ajouter la root ca de votre pki dans les devices qui ne fonctionnent pas par exemple?

    pour EAS, seul le 443 est nécessaire

    merci


    Hakim Taoussi - Consultant Exchange - http://exchangediscover.blogspot.fr

    mercredi 22 juin 2016 10:32
  • Bonjour Hakim,

    Merci pour votre réponse.

    J'ai créé le certificat à partir de la console Exchange puis via le PKI : http://NomServeur/certsrv

    Je l'ai ensuite installé dans "Autorités de certification racines de confiance", j'ai suivi la procédure classique il me semble.

    Voici les captures d'écran du certificat lorsque j'essaie de configurer une boite email depuis l'exterieur.


    mercredi 22 juin 2016 15:05
  • Bonsoir,

    outlook (à distance) ne fonctionne pas avec les mêmes répertoires virtuels que les téléphones mobiles !

    Avez-vous configuré Outlook Anywhere ?

    Sinon, Outlook 2013 et 2016 fonctionnent de la même manière... La différence doit se trouver ailleurs.

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mercredi 22 juin 2016 16:47
    Modérateur
  • Bonjour Thierry,

    Merci pour votre réponse, je creuse toujours.

    L'Outlook Anywhere était activé. J'ai le choix entre le désactiver ou Réinitialiser le répertoire virtuel. J'ai essayé les deux méthodes d'authentification. Je ne vois pas...

    jeudi 23 juin 2016 13:18
  • Je précise que la configuration en POP et IMAP fonctionne depuis l’extérieur.

    Merci bien,

    jeudi 23 juin 2016 15:13
  • Le port 443 suffit pour Outlook et les mobiles depuis Internet.

    En revanche, il est très important de n'avoir aucune erreur ou warning  sur le certificat pour que Outlook puisse se connecter.

    Les ports 5060,61,62 ne devraient pas être utiles pour le moment.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    jeudi 23 juin 2016 21:53
    Modérateur
  • Bonsoir,

    D'après le screen votre certificat n'est pas reconnu pas le poste client, il n'est pas dans le magasin root CA du PC (pas celui de l'utilisateur).

    Comme l'indique Thierry, depuis Outlook vous devriez configurer le profile en utilisant soit l'autodiscover, soit en entrant le hostname de votre serveur Exchange et non ActiveSync (dernier screen)

    Merci


    Hakim Taoussi - Consultant Exchange - http://exchangediscover.blogspot.fr

    jeudi 23 juin 2016 22:30
  • Bonjour,

    J'ai supprimé les ports 5060 ... de la redirection.

    Pour ce qui est du certificat, je l'ai bien dans le magasin "Autorités de certification de racine de confiance" pour l'ordinateur local et l'utilisateur local (c'est ça le Root CA?)

    Je l'ai aussi importé dans internet explorer.

    Selon Thierry, il ne faut aucun warning. Donc le premier warning étant : "Le certificat de sécurité a été émis par une société à laquelle vous n'avez pas choisi de faire confiance..."
    Comment puis-je faire pour corriger cela?

    Pour te répondre Hakim, dans Outlook 2016 je n'ai pas beaucoup de choix :

    Je saisie les mêmes informations que pour un compte IMAP (adresse, serveur, user pass).

    C'est frustrant.

    Merci tout de même de votre aide.

    vendredi 24 juin 2016 08:17
  • Je me réponds à moi-même :

    Pour le certificat, s'il est généré en interne, il faut effectivement l'installer sur les postes locaux. L'idéal serait d'avoir un certificat généré par une autorité de certification reconnue mais c'est couteux.

    Cependant, cette action n'avait pas résolue mon problème. En effet, Outlook utilise le chemin dns autodiscover.mondomaine.fr pour se connecter. Lorsque je suis en local, pas de problème. Mais dans mon cas, les postes sont sur un autre site connecté en VPN (IPSec site à site).

    Depuis Outlook 2013 et 2016, il ne trouve pas l'autodiscover sur le LAN mais il fait une recherche sur l'externaldns. Il considère donc que c'est une connexion depuis l'exterieur du LAN pour atteindre le serveur de messagerie.

    Il faut donc modifier la zone DNS (chez votre gestionnaire de nom de domaine) avec le champ SRV autodiscover (tcp et port 443) vers le dns mailhost.mondomaine.fr

    mailhost.mondomaine.fr étant la redirection externe définit pour renvoyer vers le serveur de messagerie.

    Problème résolu ;-)

    vendredi 19 août 2016 11:38