locked
Inscrire un proxy en utilisant la commande netsh RRS feed

  • Discussion générale

  • Bonjour,

     

    je rencontre un problème sur Serveur 2008.

    En effet je veux inscrire un proxy qui à la forme http://a.b.c.d/z.x:8080

    J'ai trouvé que pour faire cela sous Windows Serveur 2008, il n'existait pas la commande proxycfg et donc on devait passer par

    1) Ouvrir un console CMD en tant qu'administrateur

    2) tapez netsh

    3) Tapez : winhttp

    4) taper set proxy proxy-server= "http://a.b.c.d/z.x:8080"

    Mais il apparaît "Erreur lors de l'écriture des paramètres de proxy. (87) Paramètre incorrect".

    Si par contre je fais http://a.b.c.d", cela fonctionne on dirait qu'il n'aime pas mon dernier / ???? (Mais je ne peux pas faire autrement, mon proxy (enfin celui d emon entreprise est comme ça)

    Pour information si je vais la même chose sur une machine équipé de Seven, la commande set proxy proxy-server= http://a.b.c.d/z.x:8080 fonctionne.

    La seule chose que j'ai vu de différent, c'est qu'a l'ouverture de la console CMD :
    Sous 2008 il affiche une version 6.0.6002

    Sous Seven il affiche une version 6.1.7600

     

    Merci pour votre aide

    mercredi 26 mai 2010 12:08

Toutes les réponses

  • Bonjour,

    Vous comme référence technique : http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=e2e7d0fc-5774-47fb-a31a-f10ba9e37660

    Vous pouvez consulter :

    http://blogs.msdn.com/b/wndp/archive/2006/05/08/592895.aspx

    http://technet.microsoft.com/fr-fr/library/cc731131(WS.10).aspx

    Cordialement,

    Roxana


    Roxana Panait, MSFT ________ Votez l’article qui vous est utile ou postez un pour participer au concours : Appel a la contribution! Publiez un tip ou un petit tutorial (comment faire) sur la technologie que vous connaissez le mieux ! - Appel à la contribution
    jeudi 27 mai 2010 07:47
  • Bonjour,

     

    Merci pou ces liens sur les aides et la syntaxe de netsh, mais il ne me donne pas la solution à mon problème.

    J'ai l'impression qu'il y a un probléme de caractère dans la commande

    Cordialement.

     

    jeudi 27 mai 2010 14:31
  • Bonjour,

    Le nom du proxy ne doit pas contenir une ULR mais bien le nom d'hôte, exemple: monproxy.masociete.local. Il peut être optionnellement suivi d'un port (:8080).

    Est-vous certain de bien vouloir paramétrer un serveur proxy et non pas l'adresse d'un script de configuration automatique (PAC)?

     


    --- Marc Lognoul [MCSE, MCTS, MVP] Heureux celui qui a pu pénétrer les causes secrètes des choses Happy is the one who could enter the secret causes of things Blog EN: http://www.marc-antho-etc.net/blog/ Blog FR: http://www.marc-antho-etc.net/blogfr/
    jeudi 27 mai 2010 15:10
  • Bonsoir,

     

    Ce que je voudrai comprendre c'est que la même chose taper sous Seven et sous WIndows Serveur 2008 ne donne pas le même résultat comme je l'ai expliqué.

     

    Sous Seven cela fonctionne sous 2008 j'ai une erreur, alors que je tape strictement la même chose ????

    ================================================================================

    Bonjour,

     

    je rencontre un problème sur Serveur 2008.

    En effet je veux inscrire un proxy qui à la forme http://a.b.c.d/z.x:8080

    J'ai trouvé que pour faire cela sous Windows Serveur 2008, il n'existait pas la commande proxycfg et donc on devait passer par

    1) Ouvrir un console CMD en tant qu'administrateur

    2) tapez netsh

    3) Tapez : winhttp

    4) taper set proxy proxy-server= "http://a.b.c.d/z.x:8080"

    Mais il apparaît "Erreur lors de l'écriture des paramètres de proxy. (87) Paramètre incorrect".

    Si par contre je fais http://a.b.c.d", cela fonctionne on dirait qu'il n'aime pas mon dernier / ???? (Mais je ne peux pas faire autrement, mon proxy (enfin celui d emon entreprise est comme ça)

    Pour information si je vais la même chose sur une machine équipé de Seven, la commande set proxy proxy-server= http://a.b.c.d/z.x:8080 fonctionne.

    La seule chose que j'ai vu de différent, c'est qu'a l'ouverture de la console CMD :
    Sous 2008 il affiche une version 6.0.6002

    Sous Seven il affiche une version 6.1.7600

     =====================================================================================================

    Merci pour votre aide

    jeudi 27 mai 2010 16:36
  • <var>

    Bonjour,

    Vous avez essayé avec :

     

    Netsh winhttp  set proxy proxy-server="http=myproxy;https=sproxy:88" bypass-list="*.domaine.com"

     

     

     http://technet.microsoft.com/fr-fr/library/cc731131(WS.10).aspx#BKMK_5  (pour Windows Server 2008)

     

    set proxy

    Configures the WinHTTP proxy setting.

    Syntax

    set proxy [proxy-server=] ProxyServerName [bypass-list=] <HostsList>

    Parameters

    Proxy-Server

    Required. Specifies the proxy server to use for http, secure http (https), or both http and https protocols.

    Bypass-list

    Optional. Specifies a list of Web sites that should be visited without utilizing the proxy server. Use "<local>" to bypass all short name hosts.

    Examples

    Following are three examples of how to use the set proxy command.

    Copier le code

    set proxy myproxy
    set proxy myproxy:80 "<local>bar"
    set proxy proxy-server="http=myproxy;https=sproxy:88" bypass-list="*.contoso.com"

    </var>

     

    Cordialement,

    Roxana

     

     


    Roxana Panait, MSFT ________ Votez l’article qui vous est utile ou postez un pour participer au concours : Appel a la contribution! Publiez un tip ou un petit tutorial (comment faire) sur la technologie que vous connaissez le mieux ! - Appel à la contribution
    vendredi 28 mai 2010 07:17
  • Bonjour,

     

    Oui j'ai essayé, après avoir ouvrir CMD en tant qu'administrateur

    Je tape

    netsh winhttp set proxy proxy-server="Http=http://proxy.intranet.service.gouv.fr/aiguillage.proxy:8080"

     

    En retour j'ai

    =====================================================================

    Erreur de l'écriture des paramètres proxy. (87) Paramètre incorrect.

     

    Paramètres de proxy WinHTTP actuels :

    Accès direct (sans serveur proxy)

    =========================================================================

    La même chose sur un poste en Seven fonctionne parfaitement.

    J'ai fait x tentatives sous 2008, dès que je saisi dans le proxy le dernier / alors la commande ne passe pas http://proxy.intranet.service.gouv.fr/aiguillage.proxy:8080

     

    Merci de votre aide

    vendredi 28 mai 2010 07:49
  • J'ai eu le même soucis en mettant la commande sous la forme suivante cela fonctionne:

    netsh winhttp set proxy "proxy-server="http=nomduproxy:portproxy;https=nomduproxy:portproxy"" "bypass-list="*.contoso.com""

    Cela doit fonctionner tu dois avoir en retour:

    Proxy Server(s) : http=xxxxxxx

    Bypass List       : *.contoso.com

    lundi 3 janvier 2011 13:14