none
[Sharepoint 2013] Recherche RRS feed

  • Question

  • Bonjour à vous ,

    J'ai suivi de nombreux tutoriel concernant la recherche dans sharepoint sans succes .
    (J'ai suivi les conseils dictés dans le livre sharepoint 2013 foundation)

    J'ai un utilisateur (spsearch) dédié au service recherche de sharepoint.
    Lorsque je tape un mot dans le module de recherche en haut à droite je n'ai aucune erreur, en revanche sharepoint ne me retrouve rien ....

    Je suis allé voir du coté de l'observateur d’évènement et la j'ai un message qui m'alerte : Impossible d'analyse l'adresse de démarrage http://sharepoint.domain.net...

    Je précise que lorsque j'ai déclaré le nom de ma batterie le serveur est : http://sharepoint.domain.net et nom pas http://sharepoint/  (comme dans les tutos).

    Je continue mes recherches, mais si je pouvais bénéficier de l'expérience d'un utilisateur ce serait super !

    Merci

    lundi 25 novembre 2013 14:10

Réponses

  • Bonjour

    Vous êtes confronté à une sécurité de IIS.

    En gros :

    • le serveur SharePoint s’appelle Toto (au sens NetBios du terme)
    • la WebApplication SharePoint s’appelle Titi
    • Le serveur faisant l'indexation est le meme que le serveur frontal (Toto), donc lors de la recherche il va s’appeler lui même en http (du coup en local) mais avec un nom qui ne lui correspond pas (Titi), donc erreur 401 Access Denied par sécurité (voyez ça comme un antipishing)
    • Si l'indexeur etait un autre serveur, l'appel httm arriverai sur Toto de l'exterieur et ça serait accepté.


    Il y a donc 2 solutions :

    - en DEV on fait un GROS et MECHANT disable de cette sécurité (ce que vous avez fait avec le disableLoiopbackCheck)

    - en PROD on fait propre, en indiquant la liste des hotes DNS autorisés....

    Pour plus de détail : http://paslatek.net/2012/04/sharepoint/acces-refuses-lors-de-lindexation-de-mon-sharepoint/


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    • Proposé comme réponse lionel limozin mardi 26 novembre 2013 16:15
    • Marqué comme réponse Maskk111 mercredi 27 novembre 2013 07:42
    mardi 26 novembre 2013 16:14
  • Bon poster sur le social.technet me réussi un peu je pense.... 

    j'ai testé plusieurs modifications : 

    Modifié mon fichier host ->host 127.0.0.1 sharepoint.domain.net

    Modifié les clés registre:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Nom de la valeur : DisableLoopbackCheck  
    Type de données : REG_DWORD
    Base : Hexadécimale
    Valeur : 1
    http://support.microsoft.com/kb/896861

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    Nom de la valeur : DisableStrictNameChecking
    Type de données : REG_DWORD
    Base : Décimale
    Valeur : 1
    http://support.microsoft.com/kb/281308

    Et :

    1. Cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
    2. Dans l'Éditeur du Registre, recherchez la clé de Registre suivante et cliquez dessus :
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Cliquez avec le bouton droit sur MSV1_0, pointez sur Nouveau, puis cliquez sur Valeur de chaînes multiples.
    4. Tapez BackConnectionHostNames, puis appuyez sur ENTRÉE.
    5. Cliquez avec le bouton droit sur BackConnectionHostNames, puis cliquez sur Modifier.
    6. Dans la zone Données de la valeur, tapez le ou les noms d'hôte pour les sites situés sur l'ordinateur local, puis cliquez sur OK.
    7. Fermez l'Éditeur du Registre, puis redémarrez le service IISAdmin.

    J'ai relancé dans: application de service de recherche -gérer les sources de contenu l'analyse "des sites sharepoint locaux".
    Et maintenant ... alors qu'il me mettait Succes 0 il me renvoie Succes : 3233 (chiffre imaginé)
    Ca marche en revanche sans modifier le fichier host et les clés registres rien ne fonctionnait cela souligne un defaut sur mon serveur dns peut être ?


    • Modifié Maskk111 lundi 25 novembre 2013 16:40
    • Marqué comme réponse Maskk111 mercredi 27 novembre 2013 07:42
    lundi 25 novembre 2013 16:07

Toutes les réponses

  • Bon poster sur le social.technet me réussi un peu je pense.... 

    j'ai testé plusieurs modifications : 

    Modifié mon fichier host ->host 127.0.0.1 sharepoint.domain.net

    Modifié les clés registre:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    Nom de la valeur : DisableLoopbackCheck  
    Type de données : REG_DWORD
    Base : Hexadécimale
    Valeur : 1
    http://support.microsoft.com/kb/896861

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
    Nom de la valeur : DisableStrictNameChecking
    Type de données : REG_DWORD
    Base : Décimale
    Valeur : 1
    http://support.microsoft.com/kb/281308

    Et :

    1. Cliquez sur Démarrer, sur Exécuter, tapez regedit, puis cliquez sur OK.
    2. Dans l'Éditeur du Registre, recherchez la clé de Registre suivante et cliquez dessus :
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Cliquez avec le bouton droit sur MSV1_0, pointez sur Nouveau, puis cliquez sur Valeur de chaînes multiples.
    4. Tapez BackConnectionHostNames, puis appuyez sur ENTRÉE.
    5. Cliquez avec le bouton droit sur BackConnectionHostNames, puis cliquez sur Modifier.
    6. Dans la zone Données de la valeur, tapez le ou les noms d'hôte pour les sites situés sur l'ordinateur local, puis cliquez sur OK.
    7. Fermez l'Éditeur du Registre, puis redémarrez le service IISAdmin.

    J'ai relancé dans: application de service de recherche -gérer les sources de contenu l'analyse "des sites sharepoint locaux".
    Et maintenant ... alors qu'il me mettait Succes 0 il me renvoie Succes : 3233 (chiffre imaginé)
    Ca marche en revanche sans modifier le fichier host et les clés registres rien ne fonctionnait cela souligne un defaut sur mon serveur dns peut être ?


    • Modifié Maskk111 lundi 25 novembre 2013 16:40
    • Marqué comme réponse Maskk111 mercredi 27 novembre 2013 07:42
    lundi 25 novembre 2013 16:07
  • Bonjour

    Vous êtes confronté à une sécurité de IIS.

    En gros :

    • le serveur SharePoint s’appelle Toto (au sens NetBios du terme)
    • la WebApplication SharePoint s’appelle Titi
    • Le serveur faisant l'indexation est le meme que le serveur frontal (Toto), donc lors de la recherche il va s’appeler lui même en http (du coup en local) mais avec un nom qui ne lui correspond pas (Titi), donc erreur 401 Access Denied par sécurité (voyez ça comme un antipishing)
    • Si l'indexeur etait un autre serveur, l'appel httm arriverai sur Toto de l'exterieur et ça serait accepté.


    Il y a donc 2 solutions :

    - en DEV on fait un GROS et MECHANT disable de cette sécurité (ce que vous avez fait avec le disableLoiopbackCheck)

    - en PROD on fait propre, en indiquant la liste des hotes DNS autorisés....

    Pour plus de détail : http://paslatek.net/2012/04/sharepoint/acces-refuses-lors-de-lindexation-de-mon-sharepoint/


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    • Proposé comme réponse lionel limozin mardi 26 novembre 2013 16:15
    • Marqué comme réponse Maskk111 mercredi 27 novembre 2013 07:42
    mardi 26 novembre 2013 16:14
  • Merci pour cette clarification :)

    je vais modifier la premier clé registre alors ca ne sert a rien d'avoir les deux .

    mercredi 27 novembre 2013 07:42