none
OWA - IIS - RPC : Erreur 0x5 RRS feed

  • Question

  • Suite à mon install d'exchange, je cherche à personnaliser l'accès à OWA du type : webmail.domaine.fr

    Mon soucis c'est que sous IIS, exchange à choisi de s'installer sur le service par defaut et donc sur le site par defaut.. (contenant email.domaine.fr)
    Pour pallier à ce probleme j'ai donc creer un site webmail.domaine.fr, et j'ai dupliquer les services / repertoires virtuels pour avoir la même arborescence que sous le site par defaut. 

    Problème, si email.domaine.fr/owa fonctionne bien, webmail.domaine.fr/owa lui me jette une erreur : 

    Request
    Url: https://webmail.domaine.fr:443/owa/auth/error.aspx
    User host address: 192.168.50.254
    OWA version: 14.1.355.2
    
    Exception
    Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException
    Exception message: The Microsoft Exchange Active Directory Topology service on server localhost can't be contacted via RPC. Error 0x5.
    
    Call stack
    à Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager() à Microsoft.Exchange.Clients.Owa.Core.OwaSettingsLoader.Load() à Microsoft.Exchange.Clients.Owa.Core.OwaApplicationBase.ExecuteApplicationStart(Object sender, EventArgs e)
    
    Inner Exception
    Exception type: Microsoft.Exchange.Data.Directory.ADTransientException
    Exception message: The Microsoft Exchange Active Directory Topology service on server localhost can't be contacted via RPC. Error 0x5.
    
    Call stack
    à Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetServersForRole(String[] currentlyUsedServers, ADServerRole role, Int32 serversRequested, Int32[]& mapping) à Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetConfigDCInfo(Boolean throwOnFailure) à Microsoft.Exchange.Data.Directory.TopologyProvider.PopulateConfigNamingContexts() à Microsoft.Exchange.Data.Directory.ADSession.GetConfigurationNamingContext() à Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String fqdn, NetworkCredential credential) à Microsoft.Exchange.Clients.Owa.Core.Utilities.CreateADSystemConfigurationSessionScopedToFirstOrg(Boolean readOnly, ConsistencyMode consistencyMode) à Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.InitializeConfigurationManager() à Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager()
    
    Inner Exception
    Exception type: Microsoft.Exchange.Rpc.RpcException
    Exception message: Error 0x5 (Accès refusé) from HrGetServersForRole
    
    Call stack
    à ThrowRpcException(Int32 rpcStatus, String message) à Microsoft.Exchange.Rpc.RpcClientBase.ThrowRpcException(Int32 rpcStatus, String routineName) à Microsoft.Exchange.Rpc.ADTopology.ADTopoRpcClient.HrGetServersForRole(String[] currentlyUsedServers, ServerRole role, Int32 serversRequested, ServerInfo[]& suitableServers, Int32[]& mapping) à Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetServersForRole(String[] currentlyUsedServers, ADServerRole role, Int32 serversRequested, Int32[]& mapping)

    Quelqu'un aurait une idée sur le dysfonctionnement (je me doute que cela a a voir avec IIS, mais je vois pas quelle est le problème de configuration)

    Merci d'avance pour vos retours 

    tdldp


    • Modifié tdldp1 lundi 4 juin 2012 13:50
    lundi 4 juin 2012 13:48

Réponses

  • Bon finalement je crois avoir trouvé...

    Pour ajouter un site fqdn supplémentaire, il faut pas y aller à la mano sous iis, mais en passant par les commandlets prévu pour...
    Après avoir supprimé tout ce que j'ai fait, j'ai suivi ce tuto : http://technicaljeditrials.info/2011/02/28/exchange-2010-multiple-owaecp-directories-part-1/
    e
    t bingo, j'ai bien owa présent sous les 2 domaines..

    Bon j'ai un autre soucis par contre : 

    Visiblement il y aura des conflits d'authentification entre les 2 owa... il semblerait qu'il ne faille pas utiliser les mêmes méthodes entre les 2 sites sinon ca bloque owa..
    J'ai d'ailleurs un owa qui ne marche plus actuellement : 

    Échec de l'initialisation d'Outlook Web App. Si le problème persiste, cliquez sur Aide.
    
    Request
    Url: https://email.domaine.fr:443/owa/auth/error.aspx
    User host address: 192.168.50.254
    OWA version: 14.1.355.2

    Bon en meme temps je trifouille l'authentification à donf, donc c'est peut etre normal... 
    Je vous tiens au courant

    EDIT : D'ailleurs en desactivement l'authentification anonyme, c'est beaucoup mieux...
    • Modifié tdldp1 mardi 5 juin 2012 08:04
    • Marqué comme réponse tdldp1 mardi 5 juin 2012 08:04
    • Non marqué comme réponse Florin Ciuca lundi 25 juin 2012 14:24
    • Marqué comme réponse Florin Ciuca lundi 25 juin 2012 14:24
    mardi 5 juin 2012 07:51

Toutes les réponses

  • Je me répond à moi même mais après avoir vue le sujet suivant : http://technet.microsoft.com/fr-fr/library/dd577063(v=exchg.80).aspx et passé en revue ma configuration je me suis rendu compte que j'avais mal reporté ma configuration des pools d'application. 
    Après correction des erreurs j'ai désormais un nouveau message d'erreur : 

    Les paramètres de configuration Active Directory pour le répertoire virtuel "owa" sous le site Web "webmail.domaine.fr" ne sont pas accessible.

    Request
    Url: https://webmail.domaine.fr:443/owa/auth/error.aspx
    User host address: 192.168.50.254
    OWA version: 14.1.355.2
    
    Exception
    Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException
    Exception message: Les paramètres de configuration Active Directory pour le répertoire virtuel "owa" sous le site Web "webmail.domaine.fr" ne sont pas accessible.
    
    Call stack
    à Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager() à Microsoft.Exchange.Clients.Owa.Core.OwaSettingsLoader.Load() à Microsoft.Exchange.Clients.Owa.Core.OwaApplicationBase.ExecuteApplicationStart(Object sender, EventArgs e)
    
    Inner Exception
    Exception type: Microsoft.Exchange.Clients.Owa.Core.OwaInvalidConfigurationException
    Exception message: Les paramètres de configuration Active Directory pour le répertoire virtuel "owa" sous le site Web "webmail.domaine.fr" ne sont pas accessible.
    
    Call stack
    à Microsoft.Exchange.Clients.Owa.Core.Configuration..ctor(ADSystemConfigurationSession session, String virtualDirectory, String webSiteName, ADObjectId distinguishedName, Boolean isPhoneticSupportEnabled) à Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.LoadConfiguration() à Microsoft.Exchange.Clients.Owa.Core.OwaConfigurationManager.CreateAndLoadConfigurationManager()


    • Modifié tdldp1 lundi 4 juin 2012 14:54
    lundi 4 juin 2012 14:36
  • Bon finalement je crois avoir trouvé...

    Pour ajouter un site fqdn supplémentaire, il faut pas y aller à la mano sous iis, mais en passant par les commandlets prévu pour...
    Après avoir supprimé tout ce que j'ai fait, j'ai suivi ce tuto : http://technicaljeditrials.info/2011/02/28/exchange-2010-multiple-owaecp-directories-part-1/
    e
    t bingo, j'ai bien owa présent sous les 2 domaines..

    Bon j'ai un autre soucis par contre : 

    Visiblement il y aura des conflits d'authentification entre les 2 owa... il semblerait qu'il ne faille pas utiliser les mêmes méthodes entre les 2 sites sinon ca bloque owa..
    J'ai d'ailleurs un owa qui ne marche plus actuellement : 

    Échec de l'initialisation d'Outlook Web App. Si le problème persiste, cliquez sur Aide.
    
    Request
    Url: https://email.domaine.fr:443/owa/auth/error.aspx
    User host address: 192.168.50.254
    OWA version: 14.1.355.2

    Bon en meme temps je trifouille l'authentification à donf, donc c'est peut etre normal... 
    Je vous tiens au courant

    EDIT : D'ailleurs en desactivement l'authentification anonyme, c'est beaucoup mieux...
    • Modifié tdldp1 mardi 5 juin 2012 08:04
    • Marqué comme réponse tdldp1 mardi 5 juin 2012 08:04
    • Non marqué comme réponse Florin Ciuca lundi 25 juin 2012 14:24
    • Marqué comme réponse Florin Ciuca lundi 25 juin 2012 14:24
    mardi 5 juin 2012 07:51