locked
Menus contextuels disparus dans WSS 3.0 RRS feed

  • Question

  • Bonjour,

     

    Suite à une modification d'un affichage (ajout d'un WebPart Editeur de contenu), j'ai "perdu" les menus contextuels qui permettent de gérer mes documents (extraction, modification, suppression). Comment les "retrouver" ?

     

    Par avance merci pour votre aide

    lundi 11 août 2008 14:55

Toutes les réponses

  • Bonjour,

     

    Je pense avoir la solution a ton problème cela me semble assez simple (si c'est bien la solution...), quand tu ajoutes ta WebPart de contenu, n'oublie de sélectionner dans le champs "Type de barre d'outils" (traduction française car je ne dispose pas de SharePoint en français sous la main, dsl) ou "Toolbar Type", l'option "Barre d'outils complète" ou "Full Tollbar".

     

    Et normalement la barre d'outil ou menu contextuel sera ajoutée a ta webpart.

     

    Fais moi savoir, si cela fonctionne.

     

    Gilles 

     

    mardi 12 août 2008 18:35
  • Bonjour,

     

    Je suis déjà super content d'avoir eu une réponse et d'avoir réussi à retrouver le fil de la conversation dans la "jungle" des forums Microsoft....

    A part ça, j'entame une partie de cache-cache dans WSS avec les affichages pour vérifier/modifier le paramètre "Type de barre d'outils"...

    Je m'explique : au départ, j'avais juste une bibliothéque de dossiers et de documents avec comme affichage "Tous les documents" ou "mode explorateur". Comme le nom de mes documents est normalisé et codifié, j'ai voulu ajouter un accès plus aisé pour l'utilisateur non averti en créant un tableau avec des liens vers les documents à partir de leur titre. J'ai donc pour cela créer un type d'affichage par type de dossier avec un Web part Editeur de contenu dans lequel j'ai créé le tableau de lien et là rien ne va plus .......(merci d'avoir continuer à lire jusqu'ici)

    Dans certains affichages, le menu "Barre d'outil complète" est ok. Dans d'autres le simple fait d'éditer la page pour vérification et l'affichage disparaît de la liste des affichages de la bibliothèque. J'ai réussi à supprimer la barre d'outil complète de la bibliothèque, sueurs froides...plus d'accès aux paramètres du site. Je les ai retrouvés en me connectant en admin, ouf.....

     

    Questions :  y aurait il des bugs référencés concernant la gestion des affichages ? un service pack à appliquer ? une incompatibilité avec IE 7 ?

     

    Encore merci pour votre réponse, je retourne dans la "jungle"

     

     

    mercredi 13 août 2008 07:29
  • Bonjour,

     

    pas de bug référencé à ce sujet. Pas besoin de service pack et pas d'incompatibilité avec IE 7.

     

    J'essai de comprendre ce qui vous arrive. L'URL de la page que vous avez modifié pourrait beaucoup m'aider. Est ce directement sur la page AllItems.aspx que vous avez essayé d'ajouter la WebPart d'édtion de contenu ? Lorsque vous vous êtes connecté avec votre compte puis en admin, étiez vous bien sur la même URL (pas de changement d'affichage entre temps ?)

     

    En cas de problème, dans l'urgence, vous pourriez trouver utile de créer un nouvel affichage standard pour retrouver vos composants.

     

    N'hésitez pas à nous donner plus de détail pour qu'on puisse vous aider.

    jeudi 14 août 2008 09:31
  • Bonjour,

     

    Ce doit être l'explication effectivement : j'ai tenté de modifié la page qui s'appelait AllItems sans me rendre compte qu'elle servait à tous les affichages de la bibliothèque. J'ai aussi "joué" avec la notion de page par défaut pour définir une page spécifique pour chacun de mes dossiers. Résultat : perte de ma page AllItems de la liste des affichages du site. Par "chance" une des pages spécifiques avait conservé semble t il la notion de page par défaut et j'ai donc pu recréer une page "Tous les documents.aspx".

    Tout cela me parait pour le moins "fragile". Avec la seule aide en ligne, l'adaptation ou le paramètrage d'un site semble être un exercice périlleux voire risqué. Ou bien alors est ce du à la version livrée en standard de WSS ?

    Je suis toujours à la recherche d'une solution (un affichage spécifique par dossier ayant le statut de page par défaut pour ce dossier) et d'une source de documentation plus technique.

    Merci pour vos réponses.

     

    lundi 18 août 2008 06:57