locked
Problème de synchronisation - Fichiers Hors Connexion RRS feed

  • Question

  • Bonjour,

    J'ai 1 Serveur SBS 2008 avec des postes clients sous Windows XP et Windows 7.

    J'ai un problème au niveau des postes clients concernant l'utilisation des fichiers Hors Connexion à priori uniquement sur les fichiers MS Office.

    Chaque utilisateur possède un dossier personnel sur le serveur (accessible en lecture uniquement pour tous les autres utilisateurs de la société).

    Chaque utilisateur a donc son dossier disponible hors connexion sur son postes client et synchronisé automatiquement à chaque ouverture/fermeture des session.

    Cela fonctionnait parfaitement bien sous Windows XP (Suite Office 2007). Mais pose problème sous Windows 7 (Suite Office 2010).

    Description du problème: Lorsque un utilisateur travaille sur un fichier Office de son dossier personnel en mode connecté (par exemple fichiers .xls, .xlsx, .doc, .docx), le fichier passe de façon aléatoire en mode "hors connexion" (visible dans les propriétés du fichier). Le fichier passe en mode hors connexion principalement lors de l'enregistrement des modifications alors que la connexion RJ45 est bien présente et stable. Du coup le centre de synchronisation affiche régulièrement des conflits sur des fichiers, indiquant que "le fichier a été modifié sur  le serveur et sur l'ordinateur alors que l'ordinateur était hors connexion". Je confirme que le PC est resté connecté au LAN tout ce temps. Je ne sais pas trop si le problème est lié à Windows 7, à Office 2010 ou au serveur.

    Toujours est-il que ce problème n'apparait pas sur les postes Windows XP (qui ont Office 2007).

    Je vous remercie par avance si vous avez quelques pistes concernant ce problème.

    Cordialement,

    lundi 16 janvier 2012 10:01

Réponses

  • Bonjour,

    Je pense avoir trouvé l'origine du problème.

    Nous avons Symantec EndPoint Protection v 11.

    Sur l'interface de Management de Symanted sur le serveur SBS, j'ai modifié les politiques pour faire confiance aux fichiers sur les ordinateurs réseaux exécutant Autoprotect.

    Depuis, les fichiers ne passent plus en mode "hors connexion" de façon aléatoire.

    A confirmer avec le temps.

    Merci en tout cas pour les réponses proposées.

     

    J'ai modifié les

    • Marqué comme réponse matha68 jeudi 26 janvier 2012 10:53
    jeudi 26 janvier 2012 10:53

Toutes les réponses

  • Bonsoir Matha68 ,

     

    Le problème d instabilité peut subvenir lorsque les fichiers hors connexion et les profils utilisateur itinérants essaient de synchroniser les fichiers dans un profil utilisateur.

     

     

    Pour résoudre le problème désactiver le cache des fichiers hors connexion en exécutant la syntaxe suivante en tant qu administrateur

    net share sharename /cache:no , où sharename est le nom du dossier partagé

     

     

    D autre part ,le centre de synchronisation dispose d un utilitaire de résolution de problème :

    Accéder au centre de synchronisation via le panneau de configuration de windows 7 ou en exécutant la commande suivant MOBSYNC

    cliquer sur la ligne afficher les conflit de synchronisations et cliquer sur résoudre pour afficher les détails des conflits .

     

    Cordialement

    lundi 16 janvier 2012 19:53
    Auteur de réponse
  • Bonjour

    - désactiver l'option de cache à l'aide de la ligne de commande :

    1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez CMD dans la zone Ouvrir et puis cliquez sur OK .
    2. À l'invite de commandes, tapez net share <var>sharename</var> /cache:no , où <var>sharename</var> est le nom du dossier partagé

    - activer l'option de cache à l'aide de la ligne de commande :

    1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez CMD dans la zone Ouvrir et puis cliquez sur OK .
    2. À l'invite de commandes, tapez net share <var>sharename</var> nom_partage/cache : Oui , où <var>sharename</var> est le nom du dossier partagé.
    • Marqué comme réponse Florin Ciuca dimanche 22 janvier 2012 19:43
    • Non marqué comme réponse matha68 lundi 23 janvier 2012 09:33
    mardi 17 janvier 2012 07:46
  • Bonjour

    - désactiver l'option de cache à l'aide de la ligne de commande :

    1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez CMD dans la zone Ouvrir et puis cliquez sur OK .
    2. À l'invite de commandes, tapez net share <var>sharename</var> /cache:no , où <var>sharename</var> est le nom du dossier partagé

    - activer l'option de cache à l'aide de la ligne de commande :

    1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez CMD dans la zone Ouvrir et puis cliquez sur OK .
    2. À l'invite de commandes, tapez net share <var>sharename</var> nom_partage/cache : Oui , où <var>sharename</var> est le nom du dossier partagé.


    Bonjour,

     

    J'ai effectué la commande indiquée.

    Effectivement, j'ai effectué sur le serveur SBS la commande  net share <var>sharename</var> /cache:no, il n'y a plus de problème, mais les fichiers ne sont plus disponibles Hors Connexion sur le poste client/

    Ensuite, je tape la commande, net share <var>sharename</var> /cache:yes, le dossier est de nouveau disponible "hors connexion" sur le poste client mais le problème susbiste.

    Si vous avez une idée, je suis preneur.

    Pour information, je n'utilise pas de profils itinérants.

    Merci d'avance. 


    • Modifié matha68 lundi 23 janvier 2012 09:39
    lundi 23 janvier 2012 09:38
  • Bonjour,

    Je pense avoir trouvé l'origine du problème.

    Nous avons Symantec EndPoint Protection v 11.

    Sur l'interface de Management de Symanted sur le serveur SBS, j'ai modifié les politiques pour faire confiance aux fichiers sur les ordinateurs réseaux exécutant Autoprotect.

    Depuis, les fichiers ne passent plus en mode "hors connexion" de façon aléatoire.

    A confirmer avec le temps.

    Merci en tout cas pour les réponses proposées.

     

    J'ai modifié les

    • Marqué comme réponse matha68 jeudi 26 janvier 2012 10:53
    jeudi 26 janvier 2012 10:53