locked
Forcer application premier plan RRS feed

  • Question

  • Bonjour,

    j'ai deux postes qui servent pour une application de cantine. Les postes sont programmés via le bios pour démarrer le matin à une heure précise. Il y a un auto logon pour Windows, et l'application de cantine se lance aussi automatiquement via une option du programme.

    Seulement, lorsque le programme est lancé, il n'est pas au premier plan, autrement dit, le programme n'est pas l'application active, ce qui a pour conséquence que les gens qui viennent badger pour récupérer leur ticket à l'avance, et bien cela ne fonctionne pas.

    Y a t-il un moyen de forcer l'application à se mettre au premier plan au démarrage, de sorte qu'il n'y ait pas besoin de cliquer une fois avec la souris sur la fenêtre de l'application afin que celle-ci soit active?

    Merci à vous.

    Cordialement.

    jeudi 19 mars 2015 07:47

Réponses

  • Bonjour,

    merci pour le lien.

    En fait j'ai utiliser une méthode somme toute archaïque mais ça marche, j'ai fais un batch avec un timeout de 15 seconde qui se lance au démarrage et qui lance mon application ensuite. De cette manière, cela fonctionne. Alors que si je mets le raccourci dans "démarrage", mon application se lance bien mais elle n'est pas active au premier plan.

    Ton lien est intéressant, mais moi je veux que tout se fasse automatiquement au démarrage du poste, or ton application néssésite une intervention.

    Cordialement.


    • Modifié Kayho jeudi 19 mars 2015 08:26
    • Proposé comme réponse Boris Ivanov lundi 23 mars 2015 14:32
    • Marqué comme réponse Boris Ivanov mardi 24 mars 2015 15:14
    jeudi 19 mars 2015 08:22

Toutes les réponses

  • Bonjour,

    je ne sais pas si ce liens peut être utile :

    http://www.nikopik.com/2011/08/mettre-nimporte-quelle-fenetre-toujours-au-premier-plan-2.html

    Cordialement

    • Marqué comme réponse Kayho jeudi 19 mars 2015 08:22
    • Non marqué comme réponse Kayho jeudi 19 mars 2015 08:24
    jeudi 19 mars 2015 08:11
  • Bonjour,

    merci pour le lien.

    En fait j'ai utiliser une méthode somme toute archaïque mais ça marche, j'ai fais un batch avec un timeout de 15 seconde qui se lance au démarrage et qui lance mon application ensuite. De cette manière, cela fonctionne. Alors que si je mets le raccourci dans "démarrage", mon application se lance bien mais elle n'est pas active au premier plan.

    Ton lien est intéressant, mais moi je veux que tout se fasse automatiquement au démarrage du poste, or ton application néssésite une intervention.

    Cordialement.


    • Modifié Kayho jeudi 19 mars 2015 08:26
    • Proposé comme réponse Boris Ivanov lundi 23 mars 2015 14:32
    • Marqué comme réponse Boris Ivanov mardi 24 mars 2015 15:14
    jeudi 19 mars 2015 08:22