locked
Windows 7 RC and ATI RADEON 4850 RRS feed

  • Question

  • Hi, I just installed Windows 7 RC after 6 monthes on a previous beta build. My system is exactly the same. My problem is 7 RC seems to not detect my graphic card. Let me explain:
    1) I downloaded the last Catalyst as usual, but It wouldn't install any drivers nor CCC... only the Visual C++ thing and ATI Install Manager... Like it wasn't detecting my Radeon 4850.
    2) In my device manager map, I don't have ANY device under display adapter, I don't even have the display adapter section... But I have 2 "Unknown Devices" under "Other Devices" that I'm pretty sure is my Radeon (for Radeon users you know ATI card appears as 2 devices in the device manager right)
    3) To summarize, it seems 7 RC is using the video card just fine since Aero works and all, but for some weird reason it doesn't want to see it as a Radeon and the catalyst installation fail in the same way. So no drivers available with windows update, catalyst fails from 9.1 to 9.6, I don't know what to do anymore!!!
    Any help would really be appreciated :)
    • Modifié surlaw jeudi 25 juin 2009 20:46
    jeudi 25 juin 2009 20:44

Réponses

  • Just to let you know I reinstalled 7 RC and encountered the exact same thing, so I checked my bios, I thought I had the last version but actually there was a new one, so I updated it and that fixed the code 12 error and my radeon was recognized again in the device manager :) I'm closing the thread, thanks again for your time.
    • Marqué comme réponse surlaw dimanche 28 juin 2009 21:59
    dimanche 28 juin 2009 21:59

Toutes les réponses

  • hi there,

    have you tryed to eliminate the unknown device from the hardware panel and let it discover it again to see if it can make a difference? have you done all of the updates from  windows updates (including optional ones, wich usually are the drivers...)?

    can you try that and keep us posted please?

    best regards,

    Pierre.

    Http://www.redkaffe.com - Recherche poste Consultant/Formateur en region PACA ou IDF
    samedi 27 juin 2009 07:06
  • Hi, thanks for the answer, actually I posted my question both on the English and French forums by mistake, sorry about that. I noticed some code 12 error in the device manager, on a PCI bridge, and it seems it is causing my Radeon to not function properly. I didn't resolve the problem yet, I think I will just reinstall the 7 RC, since my hardware is fine, that error should'nt be here. I'll give feedback in the English forums, therefore this post should be deleted.
    dimanche 28 juin 2009 07:48
  • hi there,

    ok, agreed :)

    but, there's alwas a but, this forum isn't yet moderated at least i don't have the rights or even know about someone who does have the rights to close a topic here...

    Could you please close it by clicking on 'Marquer comme réponse' on your own answer, so in the meantile it doesn't show up in the 'Not resolved' search we use to follow up on unresolved posts?

    thanks ahead,

    PierrE.

    Http://www.redkaffe.com - Recherche poste Consultant/Formateur en region PACA ou IDF
    dimanche 28 juin 2009 13:16
  • Just to let you know I reinstalled 7 RC and encountered the exact same thing, so I checked my bios, I thought I had the last version but actually there was a new one, so I updated it and that fixed the code 12 error and my radeon was recognized again in the device manager :) I'm closing the thread, thanks again for your time.
    • Marqué comme réponse surlaw dimanche 28 juin 2009 21:59
    dimanche 28 juin 2009 21:59
  • hi there

    glad to know you could fix this issue, and thanks for closing the tread AND giving the solution too.

    good expermineting to you on Seven,


    best regards,

    PierrE.

    Http://www.redkaffe.com - Recherche poste Consultant/Formateur en region PACA ou IDF
    lundi 29 juin 2009 03:35