none
Problème migration vers Exchange 2013 RRS feed

  • Question

  • Bonjour à tous,

    J'utilise actuellement Exchange 2007 sur un serveur windows 2003R2 qui est aussi DC d'un domaine unique et d'une foret unique.

    Cet environnement Exchange 2007 est issu d'exchange 2000: migration qui s'est déroulé en 2009. Je n'ai pas réussi à désinstaller ''proprement'' Exchange 2000 de son serveur Windows 2000 initial. Toujours est-il que se serveur windows 2000 est déconnecté physiquement du réseau et déconnecté dans AD. Le niveau de AD est 2003 natif avec un autre DC sur Windows 2008R2 .

    Lorsque j'essaie de migrer vers Exchange 2013, le programme d'installation m'indique

    l'erreur : ''Impossible d'installer Exchange 2013 dans une foret contenant des serveurs Exchange 2000 ou 2003''.

    l'avertissement: ''Le programme d'installation va préparer l'organisation pour Exchange 2013 à l'aide de « Setup /PrepareAD ». Aucun rôle de serveur Exchange 2010 n'a été détecté dans cette topologie. Après cette opération, vous ne pourrez plus installer de serveurs Exchange 2010''.

    l'avertissement: ''Impossible de trouver le responsable du service de mise à jour du domaine « DC=sobem-france,DC=lan ». Il se peut qu'Exchange ne soit pas correctement activé pour certains utilisateurs.''

    Que me conseillez-vous? Tenter de reconnecter mon ancien serveur Exchange 2000 (si il démarre) et réaliser certaines manipulations (je crois que exchange 2000 ne peut plus démarrer, à vérifier hors réseau) ou existe-il une solution depuis mon serveur Exchange 2007 et/ou existe-t-il une solution depuis active directory.

    Je suis totalement bloqué par cette ancienne migration et je suis impuissant concernant la solution. Je compte sur votre aide pour m'indiquer une piste.

    Je reste à votre disposition pour tout renseignement.

    Cordialement

    JL

    vendredi 30 octobre 2015 08:27

Réponses

  • Bonsoir,

    idéalement, on préfère désinstaller proprement les anciennes version Exchange.

    Dans votre cas, cela fait longtemps (2009) que le Exchange 2000 n'a pas été connecté à l'organisation. Ce n'est donc pas une bonne idée de le reconnecter, alors que la configuration actuellement semble fonctionnelle.

    Donc, la suppression du serveur Exchange 2000 UNIQUEMENT dans la partition de "configuration" dans ADSIEDIT.MSC devrait suffire à débloquer la situation.

    Exemple plus concret des actions à mener:

    https://thlnk3r.wordpress.com/2013/04/17/how-to-remove-legacy-exchange-servers-using-adsiedit-tool/

    A bientôt,

     


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    dimanche 1 novembre 2015 02:35
    Modérateur
  • Bonjour Thierry,

    J'ai suivi vos conseils et j'ai pu installer Exchange 2013 sans message d'erreur lors de l'installation.

    Je vous remercie pour votre aide et je vais continuer ma migration. Je ne serais pas surpris d'avoir à  vous solliciter d'autres fois.......

    Merci aussi à Florent de m'avoir aussi aiguillé.

    A bientôt

    Cordialement

    Jean-Louis

    • Marqué comme réponse JLEC mardi 3 novembre 2015 13:59
    mardi 3 novembre 2015 13:58

Toutes les réponses

  • Bonjour,

    Bon, vous n'avez pas une configuration "facile".

    Il va vous falloir retrousser vos manches et retirer de votre Active Directory, manuellement, toute trace de votre serveur Exchange 2000.

    >ATTENTION<
    Pour cela il vous faudra utiliser ADSIEdit (qui n'est pas présent par défaut sur votre DC) mais attention : ce programme est "sans filet" et une modification incorrecte peut entraîner la perte irrémédiable de votre Active Directory ! Et, croyez-moi, vous n'avez pas envie de tenter une restauration de votre AD. Ne tentez cela que si vous avez un vol aller-simple vers un pays qui n'a pas d'accord d'extradition avec le votre.

    Est-ce que votre domaine de messagerie Exchange 2007 porte le même nom que votre domaine de messagerie "2000" ? Si c'est le cas, cela va être "coton".

    Florent

    vendredi 30 octobre 2015 13:44
  • Bonjour Florent,

    Merci de vous intéresser à mon problème.

    Petites précisions:

    Mon serveur Win2000/Echange2000  est toujours visible dans AD. Son compte a été 'désactivé' et il est déconnecté du réseau. Dans ses propriétés il est membre des groupes suivants: Exchange Domain Server, Exchange LegacyInterop, Ordinateurs du domaine.

    Du coté Organisation Exchange, ce que je vois lorsque je lance Best Practice Analyser sur mon DC  dans Exchange2007: je me retrouve avec 2 groupes d'administration : Exchange Administrative Group (pour mon serveur exchange 2007) et MonGroupe pour le serveur Exchange 2000 qu'il est donc impossible de contacter pour l'analyse.

    Quant aux domaines de messagerie gérés par ces serveurs il s'agit du même pour un domaine et un second a été rajouté sur le serveur 2007 (si vous parlez bien des domaines de messagerie internet du type MonEntreprise.com)

    Une reconnexion de mon serveur 2000 peut-elle être intéressante pour la modification de mon organisation Exchange? Une suppression de l'ordinateur win2000 de AD ? Quant ADSIEdit, pouvez vous me préciser la marche à suivre le cas échéant pour me sortir de cet état.

    Par avance merci pour votre aide

    Jean-Louis

    samedi 31 octobre 2015 15:45
  • Bonsoir,

    idéalement, on préfère désinstaller proprement les anciennes version Exchange.

    Dans votre cas, cela fait longtemps (2009) que le Exchange 2000 n'a pas été connecté à l'organisation. Ce n'est donc pas une bonne idée de le reconnecter, alors que la configuration actuellement semble fonctionnelle.

    Donc, la suppression du serveur Exchange 2000 UNIQUEMENT dans la partition de "configuration" dans ADSIEDIT.MSC devrait suffire à débloquer la situation.

    Exemple plus concret des actions à mener:

    https://thlnk3r.wordpress.com/2013/04/17/how-to-remove-legacy-exchange-servers-using-adsiedit-tool/

    A bientôt,

     


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    dimanche 1 novembre 2015 02:35
    Modérateur
  • Bonjour Thierry et merci pour votre aide.

    Juste une question concernant adsiedit : quelles précautions dois-je prendre au péalable de la suppression de mon serveur exhange 2000 dans adsiedit (vérifier que j'ai une sauvegarde de AD ou  autre).

    Deuxieme question : pourquoi ne pas supprimer tout le groupe d'administration concernant le FirstAdministrativeGroup concernant mon serveur Exchange 2000?

    par avance merci de vos éclaircissements.

    Cordialement

    Jean-Louis

    lundi 2 novembre 2015 07:14
  • Bonjour Thierry,

    J'ai suivi vos conseils et j'ai pu installer Exchange 2013 sans message d'erreur lors de l'installation.

    Je vous remercie pour votre aide et je vais continuer ma migration. Je ne serais pas surpris d'avoir à  vous solliciter d'autres fois.......

    Merci aussi à Florent de m'avoir aussi aiguillé.

    A bientôt

    Cordialement

    Jean-Louis

    • Marqué comme réponse JLEC mardi 3 novembre 2015 13:59
    mardi 3 novembre 2015 13:58
  • Bonjour,

    une sauvegarde d'un serveur contrôleur de domaine, contenant les données d'état du système.

    Il est déconseillé (par Microsoft) de supprimer le groupe administratif pour différentes raisons, notamment la gestion des dossiers publics qui par défaut reste basée sur l'ancien groupe administratif. Il existe une KB (un peu complexe) pour réparer cela, mais on préfère éviter. La suppression du conteneur "servers" suffit généralement.

    A bientôt, 


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    mardi 3 novembre 2015 22:27
    Modérateur