none
Autorisations de site accordées qui ne fonctionnent pas sous sharepoint foundation 2010 RRS feed

  • Question

  • Bonjour,

    Je bloque l'héritage des autorisations. Je créais un groupe Sharepoint avec des autorisations spécifiques créées au préalable. Je mets dans ce groupe des utlisateurs Active Directory et test => Les autorisations de site accordées ne fonctionnent pas. Pourquoi ?

    Merci de votre aide



    • Modifié Tony-21 mercredi 30 janvier 2013 13:04
    mercredi 30 janvier 2013 13:03

Réponses

  • Bonsoir,

    Vous devez travailler a l'envers .. D'abord créer un groupe global au niveau AD .. "grp_ALLUSERS_INTRANET" par exemple.. Mêtez vos utilisateurs la dedans.. Créez un nouveau groupe dans SP qui s'apelle "SP_grp_ALLUSERS_INTRANET" .. ajouter votre groupe AD dans votre groupe SP ..

    L'avantage c'est que le seul endroit a gerer les utilisateurs et l'AD et pas autre chose.

    Il se peux que les changement ne font pas directement un effet, il y un timer qui tourne chaque 12 heures je crois. Changer ceci vers toutes les heures et le tour sera jouer. ( je me rapelle vaguement d'une session ou on parlais de ceci )

    Courage,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    mercredi 30 janvier 2013 21:44
  • Bonjour Gokan,

    Il s’avère que ce sont les applications qui mettent la pagaille dans les autorisations !

    Cordialement,


    • Modifié Tony-21 vendredi 1 février 2013 14:23
    • Marqué comme réponse Gokan OzcifciMVP vendredi 1 février 2013 21:24
    vendredi 1 février 2013 14:23

Toutes les réponses

  • Bonsoir,

    Vous devez travailler a l'envers .. D'abord créer un groupe global au niveau AD .. "grp_ALLUSERS_INTRANET" par exemple.. Mêtez vos utilisateurs la dedans.. Créez un nouveau groupe dans SP qui s'apelle "SP_grp_ALLUSERS_INTRANET" .. ajouter votre groupe AD dans votre groupe SP ..

    L'avantage c'est que le seul endroit a gerer les utilisateurs et l'AD et pas autre chose.

    Il se peux que les changement ne font pas directement un effet, il y un timer qui tourne chaque 12 heures je crois. Changer ceci vers toutes les heures et le tour sera jouer. ( je me rapelle vaguement d'une session ou on parlais de ceci )

    Courage,

    G.


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    mercredi 30 janvier 2013 21:44
  • Bonsoir Gokan,

    Si je suis ton raisonnement, oui je travail à l'envers ;-( Je vais essayer dès demain en reprenant à zéro.

    Ce que je ne comprend pas c'est que ça peut fonctionner...

    Comment modifier ce timer ?

    Merci bcp

    Cordialement,

    • Modifié Tony-21 mercredi 30 janvier 2013 22:29
    mercredi 30 janvier 2013 22:22
  • Bonjour Gokan,

    Voilà j'ai suivi tes instructions mais ça ne fonctionne pour l'instant toujours pas ! Ce n'est pas ce qui est préconisé par Microsoft ?

    Si je test à nouveau en affectant des utilisateurs directement dans les groupes SharePoint (C'est ce que j'ai fais au départ mais ça ne fonctionne plus.) ça ne marche pas. Je n'ai pas d'erreurs d'affichées si ce n'est un refus de session comme je me connecte avec les utilisateurs "401 UNAUTHORIZED" ou "Erreur : accès refusé".

    J'ai créé des groupes SharePoint avec des autorisations spécifiques pour chaque sites sous le site parent qui doivent disposer d'autorisations uniques.

    Il n'y a pas un cache à vider (serveur et client) ?

    Je ne trouve rien sur ce timer pour l'instant pour pouvoir le modifier. Il est lié au service "Sharepoint 2010 Timer" ?

    Merci bcp

    Cordialement,


    • Modifié Tony-21 jeudi 31 janvier 2013 09:21
    jeudi 31 janvier 2013 07:52
  • Bonjour Gokan,

    Il s’avère que ce sont les applications qui mettent la pagaille dans les autorisations !

    Cordialement,


    • Modifié Tony-21 vendredi 1 février 2013 14:23
    • Marqué comme réponse Gokan OzcifciMVP vendredi 1 février 2013 21:24
    vendredi 1 février 2013 14:23
  • Bonsoir,

    Je suis ravi que vous ayez trouvé la solution, mais que voulez vous dire par applications?

    Merci,

    Gokan


    My New Technical Blog: WWW.GKNZCFC.NET
    SharePoint Community Expert

    vendredi 1 février 2013 21:24
  • Bonjour Gokan,

    Par applications j'entend fonctionnalités (WebParts). J'ai installé les différentes solutions suivantes :

    - ConsultPoint.SharePoint.GoogleAnalyticsConnector

    - ConsultPoint.SharePoint.RibbonVisibility

    - UsersADBrowser WebPart

    - Stadler - jQuery SharePoint 2010 Menu

    Sont-ils incompatibles les uns avec les autres ? Ou il y a un autre "processus" qui entre en compte ?

    Depuis l'Administration de la collection de sites via l'admin centrale (tout est activé) et via le site parent, je n'arrive pas à activer RibbonVisibility et Google Analytics Connector sans que les autorisations d'accés au site ne fonctionnent plus. Pourquoi ?

    Merci de votre aide

    Cordialement,



    • Modifié Tony-21 lundi 4 février 2013 11:00
    lundi 4 février 2013 07:58