none
Problème installation Client SCCM 5.00.8577.1108 Windows Serveur 2016 Datacenter Rôle HYPER-V RRS feed

  • Question

  • Bonjour à tous

    Actuellement j'ai un problème d'installation du client Client SCCM 5.00.8577.1108 sur des serveur physique Windows Serveur 2016 Datacenter Rôle HYPER-V + Cluster Installer sur la machine.

    L'installation se finalise pas ce qui provoque des problèmes au niveaux du Central Logiciel remonter inventaire déploiement maj etc.

    Sur les deux serveur voici les actions effectuer :

    - Demande réinstallation depuis la console sccm n'a pas régler le problème.

    - Désinstallation propre à l'aide de la commande  ci dessous

    cd Windows\ccmsetup\
    ccmsetup.exe /Uninstall

    - Lancement installation en manuelle depuis cmd avec cette commande :

    cd ccmsetup
    \\sccm***\SMS_***\bin\i386\CCMSetup.exe /source:\\ssccm***\SMS_***\bin\i386 /mp:SCCM***.**/config:\\sccm***\SMS_***\bin\i386\MobileClient.tcf SMSSITECODE=***

    - Ensuite j'ai vue que quand le fichier log ccmsetup-ccmeval est présent à cette endroit c:\Windows\ccmsetup\Logs cela indique bien un problème pendant l'installation.

    Donc en cmd lancement fichier C:\Windows\CCM\CcmEval.exe il m'indique des erreur dans le fichier logs C:\Windows\CCM\Logs\ccmeval.log

    Voici le fichier ccmeval.log de l'un des deux serveur.

    https://send.firefox.com/download/5fd6312f4c/#5C-Qg7zo9Grf5fNnGvTxuAM

    Merci de m'aider si quelqu’un à la solution.

    Cordialement.

    mardi 3 juillet 2018 10:03

Réponses

  • Bonsoir 

    Cela a fonctionner l'installation du client c'est finaliser dans la console mes deux serveur sont au vert. 

    Mais aussi la partie Centre de logiciel.

    Merci beaucoup du coût de main.

    En plus je viens de recevoir un nouveaux serveur physique en Windows Serveur 2016.

    Sa tombe bien :) 

    Cordialement.

    • Marqué comme réponse younesch vendredi 13 juillet 2018 16:09
    • Non marqué comme réponse younesch vendredi 13 juillet 2018 16:10
    • Marqué comme réponse younesch vendredi 13 juillet 2018 16:10
    vendredi 13 juillet 2018 16:09

Toutes les réponses

  • Bonjour younesch,

    Le lien pour le fichier log ne fonctionne pas - "This link has expired or never existed in the first place!". Pouvez-vous le publier de nouveau?

    Cordialement,
    Nina


    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mercredi 4 juillet 2018 09:35
    Modérateur
  • Bonjour

    Je vous fournie le fichier logs.

    https://send.firefox.com/download/a70794580f/#lza-PPdSrH7QUPxDnaC-_g

    Merci D'Avance

    You

    mercredi 4 juillet 2018 09:40
  • Bonjour,

    Les liens ne fonctionnent pas.

    Mes recommandations :

    1) On regarde le fichier ccmsetup.log pour être sur qu'on a bien un code de retour 0 à la fin.

    Ensuite, le problème que vous avez ressemble plus à un problème de récupération de stratégie cliente. Il faut donc s'assurer que le client peut communiquer avec un MP.

    Il faudrait commencer par analyser les fichiers de log

    c:\windows\ccm\logs\clientidmanagerstartup et cas.log et locationservices.log

    Pouvez vous les mettre à disposition sur internet ?


    Merci de marquer comme reponses les interventions qui vous ont ete utile.


    lundi 9 juillet 2018 06:46
  • Bonjour

    J'ai donc regarder dans le fichier ccmsetup.log à la fin j'ai bien un retour en O

    Voici les erreurs remonter : 

    clientidmanagerstartup.log : 

    [RegTask] - Server rejected registration request: 3    ClientIDManagerStartup    09/07/2018 12:17:32    12088 (0x2F38)
    Registering using registration hint    ClientIDManagerStartup    09/07/2018 12:33:53    12088 (0x2F38)
    GetSystemEnclosureChassisInfo: IsFixed=FALSE, IsLaptop=FALSE    ClientIDManagerStartup    09/07/2018 12:33:53    12088 (0x2F38)
    Computed HardwareID=2:1D9D256196E35C7A83891D659415B209DE574CCE
        Win32_SystemEnclosure.SerialNumber=<empty>
        Win32_SystemEnclosure.SMBIOSAssetTag=<empty>
        Win32_BaseBoard.SerialNumber=.2SXT9Q2.CNIVC008571586.
        Win32_BIOS.SerialNumber=****** = numéro TAG cacher pour infos
        Win32_NetworkAdapterConfiguration.MACAddress=02:******** = adresse mac caché                  ClientIDManagerStartup    09/07/2018 12:33:53    12088 (0x2F38)
    [RegTask] - Client is not registered. Sending registration request for GUID:4DEBD4CC-B388-4EC8-874C-FBD629257FE6 ...    ClientIDManagerStartup    09/07/2018 12:33:53    12088 (0x2F38)
    [RegTask] - Server rejected registration request: 3    ClientIDManagerStartup    09/07/2018 12:33:53    12088 (0x2F38)

    locationservices.log :

    Failed to persist AAD on-boarding info. Error 0x87d00217    LocationServices    09/07/2018 12:33:53    12088 (0x2F38)
    Refreshed security settings over AD    LocationServices    09/07/2018 12:33:53    12088 (0x2F38)
    No security settings update detected.    LocationServices    09/07/2018 12:33:53    12088 (0x2F38)
    Attempting to retrieve lookup MP(s) from AD    LocationServices    09/07/2018 12:33:53    12088 (0x2F38)
    Lookup Management Points from AD:    LocationServices    09/07/2018 12:33:53    12088 (0x2F38)

    Cas.log :

    ===== CacheManager: Initializing cache state from Wmi. =====    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)
    Cache size is 5120 MB.  Location is C:\Windows\ccmcache    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)
    Software Distribution site settings (CCM_SoftwareDistributionClientConfig) policy does not yet exist on the client.
    If the client is not yet registered, this is expected behavior.    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)
    CacheManager: GetSWDistSiteSettings failed with 0x80004005. Default site settings will be used.    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)
    CacheManager: MaxCacheDuration:43200 - MinTombstoneDuration:1440    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)
    CacheManager: There are currently 0 bytes used for cached content items (0 total, 0 active, 0 tombstoned, 0 expired).    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)
    ===== CacheManager: Cache state initialization completed =====    ContentAccess    03/07/2018 10:49:32    4100 (0x1004)

    Par contre quand je déploie mais serveur virtuel en Séquences de taches pas de soucis.


    • Modifié younesch lundi 9 juillet 2018 10:54
    lundi 9 juillet 2018 10:50
  • Bonjour

    Y a se poste sur reddit qui décrit un problème similaire au mien quand penser vous.

    https://www.reddit.com/r/SCCM/comments/54445j/sccm_client_refusing_to_register_with_management/

    lundi 9 juillet 2018 10:58
  • Je suis désolé mais la vous tronquez les logs comme vous le souhaitez et ce n'est malheureusement pas aux bons endroits...

    Je veux bien vous aider, mais avec une moitié d'info, vous n'aurez qu'une moitié de réponse...

    On voit bien qu'il y a un problème ici :

    [RegTask] - Server rejected registration request: 3    ClientIDManagerStartup    09/07/2018 12:33:53    12088 (0x2F38)

    Est ce que les serveur hyper-v sont dans le domaine ou bien en workgroup ? Si ils sont en workgroup, il faut les accepter au niveau de la console SCCM en faisant un clic droit approuver.

    Si ils sont dans le domaine, quelle est leur réseau ? Est ce qu'il est bien déclarer dans les limites ? Que ce soit via une limite de type site AD ou réseau.

    Le problème est là...

    C'est location services qui permettrait d'avoir la raison mais vous ne donnez qu'une petite portion.

    Vous avez également ce fichier sur le serveur MP MP_RegistrationManager.log(il faut regarder les évènements enregistrés à la même heure).

    Concernant le lien dont vous parlez, ce n'est pas supporté de modifier la base de donnée sans faire appel au support microsoft donc c'est à vos risques et péril... Je ne le conseillerai qu'en dernier recours (et après avoir étudier un peu l'impact) et pour l'instant nous n'en somme qu'au début.


    Merci de marquer comme reponses les interventions qui vous ont ete utile.




    lundi 9 juillet 2018 12:48
  • http://mylifeasatalentmanager.blogspot.com/2015/07/sccm-2012-r2-server-rejected.html

    donne plus d'explication sur les requêtes.

    Toutefois, j'utiliserai plutot la requete fourni dans le reddit si jamais il fallait aller jusque là

    Update ClientKeyData set IsRevoked = 1 where SMSID like (select SMSID0 from [dbo].[System_DATA] where Name0 like 'COMPUTERNAME')

    Qui permet de ne modifier que le champ du computer voulu. Alors que celle du lien

    que je viens de fournir va débloquer tous les clients qui auraient été bloqué.

    Si jamais il n'y a que celui là, alors vous pouvez utiliser la requête que vous

    souhaitez.

    Encore une fois, je vous recommande dans un premier temps de voir quelle est

    l'erreur présente dans MP_RegistrationManager.log dans un premier temps et les

    poster ici.


    Merci de marquer comme reponses les interventions qui vous ont ete utile.


    mardi 10 juillet 2018 07:01
  • Bonjour

    Est ce que les serveur hyper-v sont dans le domaine ou bien en workgroup ?

    Oui les deux serveur impacter sont sur un domaine.

    Si ils sont dans le domaine, quelle est leur réseau ?

    Le serveur SCCM est les deux machines sont sur un même VLAN est communique sans aucun problème.

    Est ce qu'il est bien déclarer dans les limites ?

    Oui il sont bien déclarer.

    Voici le fichier demander MP_RegistrationManager.log

    https://send.firefox.com/download/cef85035a9/#9cUkgK_IOlKGF-Y0DDqMaQ

    Voici le fichier demander clientidmanagerstartup.log 

    https://send.firefox.com/download/a1aa94a1ed/#R7UsA0aZ4tfeVWKoMej4Pg

    Cordialement.


    • Modifié younesch mercredi 11 juillet 2018 06:58
    mercredi 11 juillet 2018 06:33
  • En effet, on voit bien les message d'erreur

    Coté client : [RegTask] - Server rejected registration request: 3    ClientIDManagerStartup    11/07/2018 04:32:45    12088 (0x2F38)

    Coté serveur : Client 'GUID:4DEBD4CC-B388-4EC8-874C-FBD629257FE6' did not use the required hash algorithm to sign message.    MP_RegistrationManager    11/07/2018 02:22:36    19356 (0x4B9C)

    MP Reg: Registration request body is invalid.    MP_RegistrationManager    11/07/2018 02:22:36    19356 (0x4B9C)

    1) Pouvez vous commencer par mettre à jour votre SCCM en version 1802 ?

    Il faudra de toute façon réaliser l'opération pour des question de performance, stabilité, ...

    2) Vous êtes configuré en HTTP+HTTPS ou HTTPS seulement au niveau de la communication avec le MP ?

    Vous pouvez vous inspirer de cet article : https://microsofttouch.fr/default/b/js/posts/sccm-vous-recevez-le-message-suivant-quand-l-agent-scvmm-2016-est-installe-mp-has-rejected-a-message-from-client-because-it-was-not-signed-using-the-hash-algorithm-that-is-required-by-this-site


    Merci de marquer comme reponses les interventions qui vous ont ete utile.



    mercredi 11 juillet 2018 07:42
  • Bonjour

    Voici la configuration du MP au niveaux HTTP

    Par contre je préfère être direct les deux dernière fois où j'ai mis à jour mon serveur sccm bah il ma complétement détruit la partie PXE Déploiement OS deux fois de suit ça à était une galère à tout refaire surtout migration OS en cours. 

    Je préfère le mettre à jour que en dernière recours où vraiment pour des améliorations de fous.

    • Modifié younesch jeudi 12 juillet 2018 09:24
    jeudi 12 juillet 2018 09:19
  • Bonjour

    J'ai donc mis dans la partie Sélection du certificat du client la variable SMS = Code du site ? cependant il dise à la fin de l'article redémarrer le client sur le serveur sccm, serveur hyper-v, depuis la console SCCM ?

    Merci D'Avance


    • Modifié younesch vendredi 13 juillet 2018 11:38
    vendredi 13 juillet 2018 11:34
  • Bonjour,

    On parle de l'agent du poste client !

    C'est donc le client côté hote hyper-v qu'il vous faut le redémarrer. Pour cela, il suffit de redémarrer le service ccmexec.Cela permet de relancer complètement la communication avec le MP.

    Si jamais cela ne fonctionne pas, cela ne coute rien de lancer la requête SQL

    select * from ClientKeyData where IsRevoked = 1

    Et voir si vous avez un retour ou si c'est vide.

    Votre problème est intéressant techniquement :)


    Merci de marquer comme reponses les interventions qui vous ont ete utile.


    vendredi 13 juillet 2018 13:09
  • Bonsoir 

    Cela a fonctionner l'installation du client c'est finaliser dans la console mes deux serveur sont au vert. 

    Mais aussi la partie Centre de logiciel.

    Merci beaucoup du coût de main.

    En plus je viens de recevoir un nouveaux serveur physique en Windows Serveur 2016.

    Sa tombe bien :) 

    Cordialement.

    • Marqué comme réponse younesch vendredi 13 juillet 2018 16:09
    • Non marqué comme réponse younesch vendredi 13 juillet 2018 16:10
    • Marqué comme réponse younesch vendredi 13 juillet 2018 16:10
    vendredi 13 juillet 2018 16:09