locked
Rendre un HDD fixe amovible? RRS feed

  • Question

  • Bonjour,

    J'utilise actuellement dans mon système un gros disque SATA en tant que disque de sauvegarde.

    Je souhaiterai, pour plus de sécurité, que mon disque ne soit branché que lorsque je sauvegarde ou restaure des fichiers. La norme SATA est conçue pour être hot-swap et ma carte mère permet cette fonction. J’aimerais pour plus de facilité utiliser cette fonctionnalité.

    J'ai définit dans le bios de ma carte mère le port SATA sur lequel est branché mon disque comme étant hot-swap. Je compte utiliser (ce n'est pas encore le cas) un fonds de panier SATA (juste une carte reliée à la carte mère d'une part et dans laquelle s'enfiche le disque d'autre part).

    J'ai fait quelques essais et je peut réellement débrancher/rebrancher le disque à chaud. Mon problème c’est que actuellement mon disque est considéré comme un disque fixe et pas amovible, je doit donc être très prudent quand je fait ça. Y a t'il moyen de forcer Windows à considérer mon disque comme amovible, de manière à ce que je puisse l'éjecter (vider le cache quoi) et donc le débrancher à chaud en toute sécurité?



    • Modifié Guig2000 lundi 31 octobre 2011 16:25
    lundi 31 octobre 2011 16:24

Réponses

  • Ça y est!!

     

     

     

    Je me disais bien qu'il devait y avoir un problème de pilote.

    En fait il semble qu'il suffisait de ne pas installer le "interl rapid storage technology" (IRST). Je l'ai donc désinstallé. Je n'ai jamais vraiment bien compris à quoi ce package sers si on est en mode ahci, je pensait que ça améliorait les perfs.

    Précisément ce que j'ai fait:

    1°) Remplacement du pilote installé par le IRST (un truc qui ressemble à intel xeon 2100 series 6 sata ahci controleur) par le driver par défaut (contrôleur SATA standard AHCI 1.0).

    A ce moment là, je pouvait déjà éjecter le disque branché en hot plug.

    2°) désinstallation du logiciel IRST.

    3°) ré-installation du intel inf autoupdate. Le contrôleur est maintenant appelé "Intel(R) 6 Series/C200 Series Chipset Family 6 Port SATA AHCI Controller - 1C02"

     

    je pense donc que la simple désinstallation de l'IRST aurrait suffit me je n'en suis pas certain à 100%.

     

    Merci pour votre aide, qui m'a bien aiguillée.

     

    NB:

     une piste serrait de trouver où changer la stratégie de suppression: j'ai pu voir qu'elle est à 1 sur mes disques et à 3 sur une clé usb (propriétés du disque ou de la clé --> détails) mais je ne sais pas comment ça se change.

    En fait le méthode de suppression pour le disque hotplug est indiquée à 2.

     



    • Marqué comme réponse Guig2000 dimanche 6 novembre 2011 22:08
    • Non marqué comme réponse Guig2000 dimanche 6 novembre 2011 22:08
    • Marqué comme réponse Guig2000 dimanche 6 novembre 2011 22:09
    • Modifié Guig2000 dimanche 6 novembre 2011 22:41 ajout image.
    dimanche 6 novembre 2011 22:08

Toutes les réponses

  • Dans le cas où ce que je demande soit impossible, utiliser la commander mountvol (par exemple mountvol x: /D) videra-il le cache disque, me permettant ainsi de débrancher mon disque à chaud en toute sécurité?

    J'aimerai quand même éviter cette méthode puisque je doit remonter le disque après l'avoir branché. "mountvol x: \\?\Volume{97f9aed9-f825-11e0-8491-806e6f6e6963}\"
    lundi 31 octobre 2011 17:13
  • Bonsoir à toutes et tous ,

      Bonsoir Guig2000 ,

    C'est une question que j'ai moi-même déjà posée ( sur Answers , je crois , ou alors lorsque Answers et Technet ne faisaient "qu'un" ...) ... et il semblerait que depuis W98 , ce n'est plus possible , du moins sous XP et Windows 7.

     

      Mais effectivement , la norme Sata autorise le "Hot-Plug " à condition que vos disques soient renseignés en mode AHCI dans votre Bios .

      Honnêtement , il vaut mieux - par sécurité- que ce mode ait été défini tel avant l'installation de Windows7 .... puisque natif sous ce système d'exploitation, cela ne pose aucun inconvénient , ni n'exige aucun driver supplémentaire lors de l'installation.

      Ensuite vos disque fonctionnent "comme" une clé USB , pour ce qui est de l'insertion, et 'l'éjection" .

    Cependant , attention, comme le disque système lui-même apparaîtra comme "éjectable" .... prudence donc avant de cliquer "n'importe où.

      Si vous deviez passé en mode AHCI après l'installation de Windows7 , prenez garde à installer le driver préalablement à la modification du Bios , et surtout , ne revenez pas en mode IDE par la suite ( ou lors d'un "plantage" , retourner dans ce Bios afin de vérifier que vos disques sont toujours bien configurer en mode AHCI .

     Ceci étant , il est tout à fait possible d'avoir du multi-boot mélangeant RAID - IDE et AHCI sur la même machine , mais avec évidenment plusieurs disques durs et la nécessité de règler le Bios suivant le mode de gestion des disques durs utilisé par le système d'exploitation que vous envisagez de lancer .

    Mais cela rend le PC un peu moins convivial.

      Attention, également si vous êtes en multi-boot : bien qu'il soit tout à fait possible de passer également en mode AHCI sous XP par exemple , c'est un peu plus "délicat" pour cet OS , car il s'agît de ne pas se tromper de driver ( chez Asus , par exemple , j'ai rencontré des erreurs dans certaines documentations ....) .

      Bien entendû , je vous parle ici de disque physique et non de partitions ....

    Bref, pour votre question : non , cela n'est à ma connaissance pas possible.

    Portez-vous bien , et bonne fin de soirée.

    PS : un lien utile à tout hazard , et une petite remarque également :

    http://support.microsoft.com/kb/922976/fr

    .... tous les contrôleurs de Disques Durs n'acceptent pas le "Hot Plug " cependant , suivant l'ancienneté de votre matériel , voir suivant certaines configurations particulières.

     Le plus sage est de consulter la documentation de votre carte-mère à ce sujet.

    PPS : le lien suivant , comporte une remarque que j'avais souligné lors de la publication d'un 'Tips" et qui normalement aurait dû être attachée au "Tips " en question ( le lien est néanmoins indiqué en fin de billet) :

    http://social.technet.microsoft.com/Forums/fr-FR/win7fr/thread/7e867fdd-d09f-42fb-b044-9e6ab05c61e2

     


    A plus..... Cordialement. Hummmm... Seven .. un goût, un parfum, un ..OS venu d'ailleurs ..... Seven !




    • Modifié Loukiana mardi 1 novembre 2011 17:00 fautes de frappe
    lundi 31 octobre 2011 18:03
  • Bonsoir,

     

    jutilise personnellement la procédure suivante sur un deuxième disque fixe Sata sur lequel je clone le disque principal:

     

    Clic droit sur Ordinateur/Gérer/Gestion des diques/Clic droit sur le disque en cause (Disque 0, Disque 1, ...) sur la ligne descriptive des partitions du disque/Hors connexion: le disque n'est plus visible dans Ordinateur et plus accessible depuis l'explorateur.

     

    Quand nécessaire, manip inverse en cliquant sur "En ligne" au lieu de "Hors Connexion".


    Cordialement.
    • Modifié leobernard mardi 1 novembre 2011 12:18
    • Proposé comme réponse Florin Ciuca jeudi 3 novembre 2011 15:26
    lundi 31 octobre 2011 18:23
  • Bonjour,

    j'essaye actuellement de déterminer si avec ma carte mère (ASUS P8P67 3.1) si l'activation du mode branchement à chaud dans le bios est censé faire que les disques branchés sur ces ports soient détectés comme amovible ou pas. Je précise que cette option du bios de ma carte mère n'est pas générale, mais spécifique à chaque port. Je peux donc décider que tel ou tel port SATA est compatible hotplug ou pas.

     

    Chez moi l'activation du hotplug ne change rien dans windows. Je me demande si je n'aurai pas dû le faire avant d'installer windows. J'ai réinstallé le SATA (intel inf auto update), sans effet. Je n'ai pas osé supprimer le contrôleur SATA dans le gestionnaire de périph (pour forcer sa réinstallation) de peur de ne pas pouvoir rebooter.

    dimanche 6 novembre 2011 12:39
  • Bonjour à toutes et tous ,

       Bonjour et @ Guig2000 ,

    Si vos disques durs internes sont également en Sata ( celui où se trouve le "boot Manager" du moins) ne supprimez surtout pas ce contrôleur Sata .... !

      Effectivement et à conditions d'être en AHCI , tous les ports ne sont pas conçus pour accepter le "Hot Plug" .... les ports 3-Sata le sont théoriquement , et normalement il y en a souvent deux de couleurs différentes ...

    De plus , vous avez plusieurs contrôleur de disques certainement , et il ne sont pas égaux à ce sujet ....

    Le plus sage est de consulter la documentation - et complètement s'il vous plaît - de votre carte-mère.

    A ce sujet , télécharger plutôt la version anglaise qui est bien souvent la plus complète ( section Bios en particulier) ....

    Je téléchargerai votre documentation après 20 H ( dsésolée , mais j'ai un rendez-vous d'ici peu ... ) et si j'y trouve une remarque particulière , je vous l'indiquerai , éventuellement en "PS" si aucun billet ne s'est intercallé entre temps .

     Portez-vous bien , et bonne fin de journée.

     


    A plus..... Cordialement. Hummmm... Seven .. un goût, un parfum, un ..OS venu d'ailleurs ..... Seven !
    dimanche 6 novembre 2011 15:05
  • J'utilise les ports du southbridge intel P67.

    Rien de bien intéressant sur la doc asus, ils ne mentionnent même pas le hot-plug dans le manuel.

    D'après la doc intel le hot-plug est pris en charge par ce chipset mais sur des forums http://hardforum.com/showthread.php?t=1606213 (pas tout compris) j'ai lu qu'il semble qu'il faille utiliser le driver windows ahci par défaut et non pas le driver intel, pour que l'éjection soit prise en charge (mais je ne suis pas sûr que ce soit une grande idée). J'ai téléchargé cette doc et en ait tiré une modif du registre, mais qui s'est avéré sans effet car à mon avis elle concerne le pilote msahci par défaut.

     

    L'autre solution serait d'utiliser le contrôleur additionnel marvell SATA3 (qui n’est pas activé vu que j'ai assez de ports) intégré à la carte mère. J'ai aussi une carte additionnelle pci express 1x utilisant un JMB363 (pas terrible) je m'en sers pour pouvoir brancher mes deux lecteurs DVD IDE mais elle a deux ports SATA.

    En terme de perfs, je pense qu'il serait préférable de tout conserver sur le P67, je vais donc encore chercher. une piste serrait de trouver où changer la stratégie de suppression: j'ai pu voir qu'elle est à 1 sur mes disques et à 3 sur une clé usb (propriétés du disque ou de la clé --> détails) mais je ne sais pas comment ça se change.


    Je vais manger, @ +

    • Modifié Guig2000 dimanche 6 novembre 2011 19:07
    dimanche 6 novembre 2011 19:06
  • Ça y est!!

     

     

     

    Je me disais bien qu'il devait y avoir un problème de pilote.

    En fait il semble qu'il suffisait de ne pas installer le "interl rapid storage technology" (IRST). Je l'ai donc désinstallé. Je n'ai jamais vraiment bien compris à quoi ce package sers si on est en mode ahci, je pensait que ça améliorait les perfs.

    Précisément ce que j'ai fait:

    1°) Remplacement du pilote installé par le IRST (un truc qui ressemble à intel xeon 2100 series 6 sata ahci controleur) par le driver par défaut (contrôleur SATA standard AHCI 1.0).

    A ce moment là, je pouvait déjà éjecter le disque branché en hot plug.

    2°) désinstallation du logiciel IRST.

    3°) ré-installation du intel inf autoupdate. Le contrôleur est maintenant appelé "Intel(R) 6 Series/C200 Series Chipset Family 6 Port SATA AHCI Controller - 1C02"

     

    je pense donc que la simple désinstallation de l'IRST aurrait suffit me je n'en suis pas certain à 100%.

     

    Merci pour votre aide, qui m'a bien aiguillée.

     

    NB:

     une piste serrait de trouver où changer la stratégie de suppression: j'ai pu voir qu'elle est à 1 sur mes disques et à 3 sur une clé usb (propriétés du disque ou de la clé --> détails) mais je ne sais pas comment ça se change.

    En fait le méthode de suppression pour le disque hotplug est indiquée à 2.

     



    • Marqué comme réponse Guig2000 dimanche 6 novembre 2011 22:08
    • Non marqué comme réponse Guig2000 dimanche 6 novembre 2011 22:08
    • Marqué comme réponse Guig2000 dimanche 6 novembre 2011 22:09
    • Modifié Guig2000 dimanche 6 novembre 2011 22:41 ajout image.
    dimanche 6 novembre 2011 22:08
  • -Bonsoir à toutes et tous ,

     

       Bonsoir et @ Guig2000 ,

    Cool .... voilà qui résoud votre problème .... et qui m'évite d'ajouter la documentation de votre carte-mère à ma "petite collection" .... ;°)

       "Intel Matrix Storage " , je ne l'utilise pas sur mes machine car il induit une confusion : lorsqu vous désirez désinstaller et ré-installer un driver ( pour un des contrôleurs de disques présents) vous ne savez trop auquel ce logiciel fait appel .

      De plus , normalement , lors de l'installation de cet "Intel Matrix storage" il a dû vous être précisé ( c'est un message d'avertissement) que vous ne pourriez pas le désinstaller .... !

     Ayant en moyenne de quatre à six disques durs sur mes machines ( toutes et multi-boot) et celle-ci possédant à leurs tours deux à trois contrôleurs de disques au  minimum , je ne me complique pas la vie avec ce logiciel d'intel . Pour moi , il fait "double emploi" avec le driver de Windows 7 ( .... sous XP , ce serait différent).

      http://social.technet.microsoft.com/Forums/fr-FR/win7fr/thread/9fb2e0ac-15f5-46c6-b8a9-d234ebd13931 

    Ci dessus , un lien vers une question qu'avait posé notre collaborateur LéoBernard il y a près d'un an . Peut-êtere y trouverez-vous également quelques informations "utiles" ....

     Portez-vous bien et bonne nuit.

     


    A plus..... Cordialement. Hummmm... Seven .. un goût, un parfum, un ..OS venu d'ailleurs ..... Seven !
    dimanche 6 novembre 2011 23:18
  • Bonjour Loukiana,

     

    j'ai présenté ma procédure dans un des post précédents. Ca ne répond pas vraiment au problème posé, car je n'éprouve pas le besoin de "débrancher" matériellement le disque, je me contente d'une déconnexion système qui rend le disque inaccessible depuis Windows: il est invisible sauf dans Gestion des disques où il apparait déconnecté.

    Ceci dit, je ne suis pas convaincu qu'un "débranchement" physique périodique diminue les risques de problèmes: il faut interveneir dans la tripaille du PC avec les risques associés, effectuer des déconnexions régulières avec des connecteurs non prévus pour cet usage, etc..


    Cordialement.
    lundi 7 novembre 2011 13:51
  • Hello leobernard !

    Bonjour Loukiana,

     

    j'ai présenté ma procédure dans un des post précédents. Ca ne répond pas vraiment au problème posé, car je n'éprouve pas le besoin de "débrancher" matériellement le disque, je me contente d'une déconnexion système qui rend le disque inaccessible depuis Windows: il est invisible sauf dans Gestion des disques où il apparait déconnecté.

    Ceci dit, je ne suis pas convaincu qu'un "débranchement" physique périodique diminue les risques de problèmes: il faut interveneir dans la tripaille du PC avec les risques associés, effectuer des déconnexions régulières avec des connecteurs non prévus pour cet usage, etc..

    Je partage ce point de vue !  et la solution !


    Bien cordialement, Georges [Saamu.net]
    lundi 7 novembre 2011 14:25
  • C'est un point de vue d'un ex-softeux, pas celui d'un gars du hard... ;-)
    Cordialement.
    lundi 7 novembre 2011 16:38
  • Hello!

     

    Les solutions softs  c'est  mieux que les hards  


    Bien cordialement, Georges [Saamu.net]
    lundi 7 novembre 2011 17:16
  • Bonsoir à toutes et tous ,

     

       Salut PapyNet , ... salutations .... oui ,  cela ressemble à une répitition de mots .... ;°)

        Salut et @ LéoBernard  , comment vas-tu ?

        Le lien je j'ai indiqué avec ton cas , était juste là , afin d'"indiquer une autre manipulation réalisée à ta demande ... et à mes ... risques et périls .... ;°)

        Je ne procède jamais de la sorte , c'était plutôt ma curiosité "maladive" qui m'a poussée à tenter cette expérience . Rien de plus .... et puis , cela a eu du bon, puisque par la suite tu es venu régulièrement apporter ton aide sur ce forum ( et celui d' Answers également)  .... en fait nous avons "fait connaissance" via ce topic.

      Bref , ce n'est qu'un cas +/- pris au hazard et j'en ai d'autres , mais la recherche dans mes topics est fastudieuse d'autant que certains d'entre eux se trouvent sur Answers désormais et non sur "Technet" depuis la "séparation" de ces deux sites.

    Portes-toi bien et bonne fin de soirée.


    A plus..... Cordialement. Hummmm... Seven .. un goût, un parfum, un ..OS venu d'ailleurs ..... Seven !

    • Modifié Loukiana mardi 8 novembre 2011 15:53 faute de frappe " riques " au lieu de "risques"
    lundi 7 novembre 2011 17:55
  • You're welcome!
    Cordialement.
    lundi 7 novembre 2011 18:22
  • Utiliser un disque de sauvegarde dans un rack ou un fonds de panier avec rails est au contraire très pratique. Et justement la connectique SATA est prévue pour ça, par exemple, le disque n'a pas besoin d'une connexion intermédiaire entre ses connecteurs et le fonds du rack. J'en utilise trè souvent chez mes clients, c'est très pratique.


    Selon moi, une solution logicielle ne peux garantir à 100% un isolement complet. En plus cela permet de séparer physiquement le disque sauvegarde de l'UC.

    Cela ne garantit pas qu'il n'arrivera rien au disque de sauvegarde, mais qu'il n'arrivera pas de sinistre simultanément sur les disques de l'UC et sur le disque de sauvegarde.

    Dans le cas de sauvegarde sensible, certains de mes clients rangent le disque dans un coffre.

    lundi 7 novembre 2011 23:51
  • Bonsoir,

     

    c'est bien le rôle d'un disque externe, non? J'ai par ailleurs des disques externes pour assurer l'isolement du disque et du reste de la configuration.


    Cordialement.
    lundi 7 novembre 2011 23:56
  • J'y ai pensé mais j'ai choisi le rack/rail car d'une part il y a un gain de place et d'autre part on élimine le risque de chute.
    mardi 8 novembre 2011 09:59
  • Bonjour,

    Dans le même esprit, j'ai mes disques sur mon contrôleur ICH10R qui sont bien reconnus comme amovibles mais lorsque j'essaie d'éjecter l'un d'eux, il y a toujours une erreur de périphérique utilisé qui ne peut pas être éjecté. Pourtant aucun accès disque ni logiciels ouverts n'est actif au moment où je fais cette demande. J'ai Norton Ghost qui est désactivé,...

    Une solution?

    mardi 6 mars 2012 08:22
  • Bonsoir à toutes et tous ,

      Bonsoir et @ Mathieu,

     .... juste en passant ( faute de liaison ADSL - fonctionnelle- depuis trois mois .... ) n'auriez-vous pas certaines variables d'environnement sur une des partitions de ce disque ?

     Un espace temporaire lié à une application particulière , même si elle n'est pas "active" suffit habituellement ( mais ce n'est pas obligatoire) à vous empêcher " d'éjecter/déconnecter" ce disque.

     Ou le fichier temporaire de téléchargement d'un antivirus par exemple.

    De plus , j'ai un doute : je crois que tous les disques "Sata" ne permettent pas forcément ce " Hot Plug" .... mais ce n'est qu'un doute en ce moment que je ne puis vérifier.

     A tout hazard , visitez donc le site du manufacturier de ce disque dur afin d'avoir la confirmation que celui-ci prend bien en charge ce " Hot Plug" ainsi , que le contrôlleur sur lequel il est branché .

    Bonne fin de nuit , bon wweek-end et pardon d'avance si je ne pouvais suivre - et répondre - à ce topic.


    A plus..... Cordialement. Hummmm... Seven .. un goût, un parfum, un ..OS venu d'ailleurs ..... Seven !

    dimanche 18 mars 2012 00:23